NOTICE

The information in this document is subject to change without notice and should not be construed as a commitment by Waters Corporation. Waters Corporation assumes no responsibility for any errors that may appear in this document. This document is believed to be complete and accurate at the time of publication. In no event shall Waters Corporation be liable for incidental or consequential damages in connection with or arising from the use of this document.

©1998–2001 WATERS CORPORATION. PRINTED IN THE UNITED STATES OF AMERICA. ALL RIGHTS RESERVED. THIS DOCUMENT OR PARTS THEREOF MAY NOT BE REPRODUCED IN ANY FORM WITHOUT THE WRITTEN PERMISSION OF THE PUBLISHER.

Millennium, PowerStation, and Waters are registered trademarks, and ActlON, Delta Prep, LAC/E, PowerLine, Quanta 4000, SAT/IN, WISP, and ZQ are trademarks of Waters Corporation.

Adaptec is a trademark of Adaptec, Inc.

Compaq, Deskpro, and Ethernet are registered trademarks of Compaq Computer Corporation.

ControlIT and Remotely Possible are trademarks of Computer Associates International.

Intel and Pentium are registered trademarks of Intel Corporation.

Java is a trademark of Sun Microsystems, Inc.

Micromass is a registered trademark, and MassLynx is a trademark of Micromass Ltd.

Microsoft, MS, Windows, and Windows NT are registered trademarks of Microsoft Corporation.

Oracle, Oracle7, Oracle8, SQL*Net, and SQL*Plus are registered trademarks of Oracle Corporation.

TCP/IP is a trademark of FTP Software, Inc.

All other trademarks or registered trademarks are the sole property of their respective owners.
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Preface</strong></td>
<td>16</td>
</tr>
<tr>
<td><strong>Chapter 1</strong></td>
<td></td>
</tr>
<tr>
<td>Introduction</td>
<td>22</td>
</tr>
<tr>
<td>1.1 Typical System Configurations</td>
<td>22</td>
</tr>
<tr>
<td>1.2 Hardware and Software Requirements</td>
<td>24</td>
</tr>
<tr>
<td>1.3 Devices Supported by the System</td>
<td>27</td>
</tr>
<tr>
<td><strong>Chapter 2</strong></td>
<td></td>
</tr>
<tr>
<td>Installing and Configuring the Hardware</td>
<td>32</td>
</tr>
<tr>
<td>2.1 Selecting the Site</td>
<td>32</td>
</tr>
<tr>
<td>2.2 Installing and Configuring Computer Systems</td>
<td>33</td>
</tr>
<tr>
<td>2.2.1 Stand-Alone Millennium\textsuperscript{32} Workstation</td>
<td>33</td>
</tr>
<tr>
<td>2.2.2 Millennium\textsuperscript{32} PowerStation</td>
<td>34</td>
</tr>
<tr>
<td>2.2.3 Millennium\textsuperscript{32} Client/Server System</td>
<td>34</td>
</tr>
<tr>
<td>2.2.4 Optional Interface Cards</td>
<td>36</td>
</tr>
<tr>
<td>2.3 Connecting IEEE-488 Chromatographic Devices</td>
<td>37</td>
</tr>
<tr>
<td>2.3.1 busLAC/E Card Connections</td>
<td>37</td>
</tr>
<tr>
<td>2.3.2 Interface Overview</td>
<td>39</td>
</tr>
<tr>
<td>2.3.3 Interface Guidelines</td>
<td>40</td>
</tr>
<tr>
<td>2.3.4 Making Cable Connections</td>
<td>40</td>
</tr>
<tr>
<td>2.3.5 Making Device Connections</td>
<td>41</td>
</tr>
<tr>
<td>2.3.6 Setting IEEE-488 Device Addresses</td>
<td>43</td>
</tr>
</tbody>
</table>
2.4 Connecting Non-IEEE-488 Chromatographic Devices ........ 47
  2.4.1 I/O Distribution Box ................................................ 47
  2.4.2 busSAT/IN Module ................................................. 48
  2.4.3 Pumps ................................................................... 51
  2.4.4 Injectors ................................................................. 51
  2.4.5 Detectors ................................................................. 52
  2.4.6 Alliance GPC 2000 Series Systems ......................... 53
  2.4.7 150C plus and 150CV plus Systems ......................... 54
2.5 Installing Gas Chromatographs ............................................ 55
  2.5.1 GC Instrument Control ............................................. 55
  2.5.2 GC Data Overview .................................................. 56
  2.5.3 Digital Output Configuration ...................................... 56
  2.5.4 Analog Output Configuration .................................... 60
  2.5.5 Alternative Setup for a 5890 GC ............................. 63
2.6 Installing 1100 Series Instruments ....................................... 63
2.7 Installing ZQ Mass Detectors ............................................. 65
  2.7.1 Installing Hardware .................................................. 65
  2.7.2 Configuring the ZQ Mass Detector in Windows NT .......... 66
  2.7.3 Configuring the ZQ Mass Detector in Windows 2000 ....... 73
  2.7.4 Testing the Network Connection ............................... 80
2.8 Starting Up the System ...................................................... 81
Chapter 3
Installing a Stand-Alone Workstation ................................................. 82
  3.1 Requirements........................................................................ 82
  3.2 Installing the Millennium\textsuperscript{32} Software ......................... 83
    3.2.1 Starting the Installation .............................................. 83
    3.2.2 Finishing a Custom Installation...................................... 88
    3.2.3 Installing the Millennium\textsuperscript{32} Workstation License ...... 90
    3.2.4 Verifying Installed Files.............................................. 91
  3.3 Installing Millennium\textsuperscript{32} Options .................................. 93
    3.3.1 About Millennium\textsuperscript{32} Options on Key Disks .......... 93
    3.3.2 Installing Millennium\textsuperscript{32} Options....................... 94
    3.3.3 Uninstalling Millennium\textsuperscript{32} Options ..................... 94
    3.3.4 Restoring an Option Sample Project ......................... 95

Chapter 4
Installing a Client/Server or Primary PowerStation .......................... 96
  4.1 Server Planning .................................................................... 96
    4.1.1 Overview.................................................................... 96
    4.1.2 Memory Considerations............................................. 97
    4.1.3 Disk Space Considerations........................................ 98
  4.2 Installing the Millennium\textsuperscript{32} Software .......................... 100
    4.2.1 Starting the Installation ............................................ 101
    4.2.2 Configuration for a Server with Two Physical Drives (PowerStation) ........................................ 108
    4.2.3 Verifying That the Millennium\textsuperscript{32} Database is Running ......................................................... 110
    4.2.4 Starting Database Archiving........................................ 111
### Table of Contents

4.2.5 Configuring the Millennium\(^{32}\) Projects Directory ..... 112
4.2.6 Setting Up the Millennium\(^{32}\) Client Directory ........... 118
4.2.7 Verifying the Installed Files .............................................. 120

**Chapter 5**

**Installing a Client** .............................................................. 122

5.1 Preparing a Windows NT Client ........................................... 122
  5.1.1 Updating the Equinox Driver .................................... 123
  5.1.2 Disabling Error-Checking Software .......................... 123
  5.1.3 Changing the Page File Size .................................. 124

5.2 Preparing a Client on Windows 2000 .................................... 126
  5.2.1 Updating the Equinox Driver .................................... 127
  5.2.2 Changing the Page File Size .................................. 133

5.3 Installing the Client Software ............................................. 135
  5.3.1 Starting the Installation ............................................ 136
  5.3.2 Finishing a Custom Installation ............................... 140

5.4 Configuring a Database Service Name ............................... 141

5.5 Installing Millennium\(^{32}\) Licenses and Options ............... 145
  5.5.1 About Millennium\(^{32}\) Licenses and Options on Key Disks .................................................. 145
  5.5.2 Installing a Millennium\(^{32}\) License or Option .......... 146
  5.5.3 Uninstalling a Millennium\(^{32}\) License or Option...... 146

5.6 Restoring the Option Sample Project ............................... 147

5.7 Registering Acquisition Server Printers ........................... 148
Chapter 6
Installing an Acquisition Server ..................................................... 149
6.1 Preparing a Windows NT Acquisition Server ...................... 149
   6.1.1 Updating the Equinox Driver .................................... 150
   6.1.2 Disabling Dr. Watson Error-Checking Software ....... 151
   6.1.3 Changing the Page File Size ................................... 151
6.2 Preparing a Windows 2000 Acquisition Server ................... 153
   6.2.1 Updating the Equinox Driver .................................... 153
   6.2.2 Changing the Page File Size ................................... 159
6.3 Installing the Millennium\textsuperscript{32} Software ....................... 161
6.4 Configuring a Database Service Name .............................. 166
6.5 Registering Acquisition Server Printers .............................. 170
6.6 Disabling AutoLogon ........................................................... 170

Chapter 7
Installing the Millennium Service ................................................... 172
7.1 Considerations and Requirements...................................... 172
7.2 Installing the Millennium Service on a Server ..................... 173
7.3 Configuring the Raw Data Directory ................................... 174
7.4 Creating Another Share ...................................................... 175

Appendix A
Installing Custom Oracle Software ................................................. 177
A.1 Performing a Custom Oracle Installation ........................... 177
A.2 Installing the Oracle Patch .................................................... 190
Appendix B
Building a Custom Millennium\textsuperscript{32} Database............................................... 192
\hspace{1em} B.1 Using Script Files ................................................................. 192
\hspace{1em} B.2 Starting the Oracle 8i Listener ............................................. 193
\hspace{1em} B.3 Starting Database Archiving ............................................... 194
\hspace{1em} B.4 Configuring the Millennium\textsuperscript{32} Projects Directory ............. 195
\hspace{1em} \hspace{1em} B.4.1 Configuring the Projects Directory in
\hspace{1em} \hspace{1em} Windows NT .................................................................. 195
\hspace{1em} \hspace{1em} B.4.2 Configuring the Projects Directory in
\hspace{1em} \hspace{1em} Windows 2000 ................................................................ 197
\hspace{1em} B.5 Setting Up the Millennium\textsuperscript{32} Client Directory ................. 202
\hspace{1em} \hspace{1em} B.5.1 Configuring the Client Stack in Windows NT ........... 202
\hspace{1em} \hspace{1em} B.5.2 Configuring the Client Stack in Windows 2000 .......... 203
\hspace{1em} B.6 Verifying the Installed Files ................................................... 204

Appendix C
Connecting Remotely to a LAC/E\textsuperscript{32} Acquisition Server.................. 206
\hspace{1em} C.1 Installing the Software .......................................................... 206
\hspace{1em} C.2 Setting Preferences .............................................................. 210
\hspace{1em} C.3 Remotely Controlling the LAC/E\textsuperscript{32} Acquisition Server .... 215

Appendix D
Adding a Listener Service.......................................................................... 218

Index .......................................................................................................... 222
## List of Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-1</td>
<td>Typical Stand-Alone Workstation System Configuration</td>
<td>23</td>
</tr>
<tr>
<td>1-2</td>
<td>Typical PowerStation System Configuration</td>
<td>23</td>
</tr>
<tr>
<td>1-3</td>
<td>Typical Configuration for a Millennium&lt;sup&gt;32&lt;/sup&gt; Client/Server System</td>
<td>24</td>
</tr>
<tr>
<td>2-1</td>
<td>busLAC/E Card Ports</td>
<td>38</td>
</tr>
<tr>
<td>2-2</td>
<td>busLAC/E Card Port Connections</td>
<td>39</td>
</tr>
<tr>
<td>2-3</td>
<td>Example of IEEE-488 Cable Connections</td>
<td>41</td>
</tr>
<tr>
<td>2-4</td>
<td>DIP Switch Block</td>
<td>44</td>
</tr>
<tr>
<td>2-5</td>
<td>I/O Distribution Box</td>
<td>47</td>
</tr>
<tr>
<td>2-6</td>
<td>Connecting the I/O Distribution Box to the busLAC/E Card</td>
<td>48</td>
</tr>
<tr>
<td>2-7</td>
<td>busSAT/IN Module (Front View)</td>
<td>49</td>
</tr>
<tr>
<td>2-8</td>
<td>busSAT/IN Module (Rear View)</td>
<td>49</td>
</tr>
<tr>
<td>2-9</td>
<td>Alliance GPC 2000 Series Systems</td>
<td>54</td>
</tr>
<tr>
<td>2-10</td>
<td>Connecting a 5890 GC and 7673 Controller to a busLAC/E Card</td>
<td>57</td>
</tr>
<tr>
<td>2-11</td>
<td>Connecting a 5890 GC and 7673 Controller to the Serial Card</td>
<td>58</td>
</tr>
<tr>
<td>2-12</td>
<td>Connecting a 6890 GC and G1512A Controller to the Serial Card</td>
<td>59</td>
</tr>
<tr>
<td>2-13</td>
<td>Connecting a 6890 Plus GC to the Serial Card</td>
<td>60</td>
</tr>
<tr>
<td>2-14</td>
<td>Connecting a 5890 GC, 7673 Controller, and busSAT/IN to a busLAC/E Card</td>
<td>61</td>
</tr>
<tr>
<td>2-15</td>
<td>Connecting a 5890 GC and G1512A Controller</td>
<td>63</td>
</tr>
<tr>
<td>2-16</td>
<td>Connecting 1100 Series Instruments</td>
<td>64</td>
</tr>
<tr>
<td>2-17</td>
<td>Connecting a ZQ Mass Detector</td>
<td>66</td>
</tr>
<tr>
<td>2-18</td>
<td>Verifying Simple TCP/IP Services</td>
<td>67</td>
</tr>
<tr>
<td>2-19</td>
<td>Verifying TCP/IP Protocol</td>
<td>68</td>
</tr>
<tr>
<td>2-20</td>
<td>Microsoft TCP/IP Properties Dialog Box</td>
<td>69</td>
</tr>
<tr>
<td>2-21</td>
<td>Microsoft TCP/IP Properties Dialog Box, Second Adapter</td>
<td>70</td>
</tr>
<tr>
<td>2-22</td>
<td>Setup Options Page for Peer Web Services</td>
<td>71</td>
</tr>
</tbody>
</table>
2-23 Verifying Services in FTP Service Properties .......................... 72
2-24 Creating a New User ................................................................. 73
2-25 New User Dialog Box ............................................................... 74
2-26 Local Area Connection Properties, General Tab .................... 75
2-27 Intel(R) PRO/100 VM Network Connection Properties, Power Management Tab .......................................................... 76
2-28 Add/Remove Programs Window .............................................. 77
2-29 Windows Components Wizard ................................................. 78
2-30 Security Accounts Properties .................................................. 79
2-31 64.1.1.1:21 Properties, Home Directory Tab .............................. 80
3-1 Welcome to the InstallShield Wizard for Millennium32 Page .......... 84
3-2 Install Common System DLLs Dialog Box .................................. 85
3-3 Product Support Registration Page ............................................. 85
3-4 BusLAC/E Driver Installation Page ............................................ 86
3-5 Import a Millennium Database Dialog Box ............................... 87
3-6 Installation is Complete Page ...................................................... 87
3-7 Program Directory Page ............................................................. 88
3-8 Data Directory Page ................................................................. 89
3-9 Database Directory Page ........................................................... 89
3-10 Import a Millennium Database Dialog Box ............................... 90
3-11 Millennium32 Option Setup Dialog Box ................................. 91
4-1 Welcome to the InstallShield Wizard for Millennium32 Page ........ 101
4-2 Install Common System DLLs Dialog Box ................................. 102
4-3 Product Support Registration Page ............................................. 103
4-4 Select Oracle SID Name Page .................................................... 103
4-5 Number of Users Page ............................................................... 104
4-6 Database Size Page ................................................................. 105
4-7 Program Directory Page ........................................................... 105
4-8 Data Directory Page ................................................................. 106
4-9 Database Directory Page ........................................................... 106

List of Figures 10
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5-21</td>
<td>BusLAC/E Driver Installation Page</td>
<td>138</td>
</tr>
<tr>
<td>5-22</td>
<td>Installation is Complete Page</td>
<td>139</td>
</tr>
<tr>
<td>5-23</td>
<td>Program Directory Page</td>
<td>140</td>
</tr>
<tr>
<td>5-24</td>
<td>Welcome Page of the Oracle Net8 Configuration Assistant</td>
<td>141</td>
</tr>
<tr>
<td>5-25</td>
<td>Net Service Name Configuration, Database Version Page</td>
<td>142</td>
</tr>
<tr>
<td>5-26</td>
<td>Select Protocols Page</td>
<td>143</td>
</tr>
<tr>
<td>5-27</td>
<td>TCP/IP Protocol Page</td>
<td>143</td>
</tr>
<tr>
<td>5-28</td>
<td>Net Service Name Page</td>
<td>144</td>
</tr>
<tr>
<td>5-29</td>
<td>Register Acquisition Server Printers Dialog Box</td>
<td>148</td>
</tr>
<tr>
<td>6-1</td>
<td>Network Adapters Properties Sheet</td>
<td>150</td>
</tr>
<tr>
<td>6-2</td>
<td>Disabling Dr. Watson</td>
<td>151</td>
</tr>
<tr>
<td>6-3</td>
<td>Performance Tab of System Properties</td>
<td>152</td>
</tr>
<tr>
<td>6-4</td>
<td>Virtual Memory Dialog Box</td>
<td>152</td>
</tr>
<tr>
<td>6-5</td>
<td>Locating Equinox Driver in Device Manager</td>
<td>154</td>
</tr>
<tr>
<td>6-6</td>
<td>Equinox Adapter Properties, Driver Tab</td>
<td>154</td>
</tr>
<tr>
<td>6-7</td>
<td>Welcome Page of Upgrade Device Driver Wizard</td>
<td>155</td>
</tr>
<tr>
<td>6-8</td>
<td>Install Hardware Device Drivers Page</td>
<td>155</td>
</tr>
<tr>
<td>6-9</td>
<td>Locate Driver Files Page</td>
<td>156</td>
</tr>
<tr>
<td>6-10</td>
<td>Insert Disk Message</td>
<td>156</td>
</tr>
<tr>
<td>6-11</td>
<td>Driver Files Search Results Page</td>
<td>157</td>
</tr>
<tr>
<td>6-12</td>
<td>Driver Files Found Page</td>
<td>157</td>
</tr>
<tr>
<td>6-13</td>
<td>Digital Signature Not Found</td>
<td>158</td>
</tr>
<tr>
<td>6-14</td>
<td>Completing the Upgrade Device Driver Wizard</td>
<td>158</td>
</tr>
<tr>
<td>6-15</td>
<td>Equinox SST-8P PCI Adapter Properties Dialog Box</td>
<td>159</td>
</tr>
<tr>
<td>6-16</td>
<td>System Properties Dialog Box, Advanced Tab</td>
<td>160</td>
</tr>
<tr>
<td>6-17</td>
<td>Virtual Memory Dialog Box</td>
<td>161</td>
</tr>
<tr>
<td>6-18</td>
<td>Welcome to the InstallShield Wizard for Millennium^32 Page</td>
<td>162</td>
</tr>
<tr>
<td>6-19</td>
<td>Install Common System DLLs Dialog Box</td>
<td>163</td>
</tr>
<tr>
<td>6-20</td>
<td>Product Support Registration Page</td>
<td>164</td>
</tr>
<tr>
<td>6-21</td>
<td>BusLAC/E Driver Installation Page</td>
<td>164</td>
</tr>
<tr>
<td>6-22</td>
<td>Installation is Complete Page</td>
<td>165</td>
</tr>
<tr>
<td>Figure Number</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>6-23</td>
<td>Welcome Page of the Oracle Net8 Configuration Assistant</td>
<td>166</td>
</tr>
<tr>
<td>6-24</td>
<td>Net Service Name Configuration, Database Version Page</td>
<td>167</td>
</tr>
<tr>
<td>6-25</td>
<td>Select Protocols Page</td>
<td>168</td>
</tr>
<tr>
<td>6-26</td>
<td>TCP/IP Protocol Page</td>
<td>168</td>
</tr>
<tr>
<td>6-27</td>
<td>Net Service Name Page</td>
<td>169</td>
</tr>
<tr>
<td>6-28</td>
<td>Register Acquisition Server Printers Dialog Box</td>
<td>170</td>
</tr>
<tr>
<td>6-29</td>
<td>AutoLogon Dialog Box</td>
<td>171</td>
</tr>
<tr>
<td>7-1</td>
<td>Multi-String Editor Dialog Box</td>
<td>176</td>
</tr>
<tr>
<td>A-1</td>
<td>Oracle8i Autorun Dialog Box</td>
<td>178</td>
</tr>
<tr>
<td>A-2</td>
<td>Welcome Page</td>
<td>179</td>
</tr>
<tr>
<td>A-3</td>
<td>File Locations Page</td>
<td>180</td>
</tr>
<tr>
<td>A-4</td>
<td>Available Product Components Page</td>
<td>181</td>
</tr>
<tr>
<td>A-5</td>
<td>Component Locations Page</td>
<td>182</td>
</tr>
<tr>
<td>A-6</td>
<td>Create Database Page</td>
<td>182</td>
</tr>
<tr>
<td>A-7</td>
<td>Summary Page</td>
<td>183</td>
</tr>
<tr>
<td>A-8</td>
<td>Install Page</td>
<td>183</td>
</tr>
<tr>
<td>A-9</td>
<td>Configuration Tools Page</td>
<td>184</td>
</tr>
<tr>
<td>A-10</td>
<td>Welcome Page of Net8 Configuration Assistant</td>
<td>184</td>
</tr>
<tr>
<td>A-11</td>
<td>Directory Service Access Page</td>
<td>185</td>
</tr>
<tr>
<td>A-12</td>
<td>Listener Configuration, Listener Name Page</td>
<td>185</td>
</tr>
<tr>
<td>A-13</td>
<td>Listener Configuration, Select Protocols Page</td>
<td>186</td>
</tr>
<tr>
<td>A-14</td>
<td>Listener Configuration, TCP/IP Protocol Page</td>
<td>186</td>
</tr>
<tr>
<td>A-16</td>
<td>Naming Methods Configuration Page</td>
<td>188</td>
</tr>
<tr>
<td>A-17</td>
<td>Net8 Configuration Assistant Done Page</td>
<td>188</td>
</tr>
<tr>
<td>A-18</td>
<td>Configuration Tools Page</td>
<td>189</td>
</tr>
<tr>
<td>A-19</td>
<td>End of Installation Page of Oracle Universal Installer</td>
<td>189</td>
</tr>
<tr>
<td>B-1</td>
<td>Projects Properties Dialog Box, Sharing Tab</td>
<td>196</td>
</tr>
<tr>
<td>B-2</td>
<td>Directory Permissions Dialog Box</td>
<td>196</td>
</tr>
</tbody>
</table>
B-3 Add Users and Groups Dialog Box ............................................. 197
B-4 Project Properties Dialog Box, Sharing Tab ............................... 198
B-5 Project Properties Dialog Box, Security Tab ............................... 199
B-6 Security Message Box ............................................................ 199
B-7 Select Users, Computers, or Groups Dialog Box ....................... 200
B-8 Access Control Settings for Projects Dialog Box ....................... 201
B-9 Directory Permissions Dialog Box .......................................... 202

C-1 ControlIT Initial Install Page ................................................... 206
C-2 Welcome to ControlIT Installation Wizard Page ......................... 207
C-3 Emergency Repair Disk Page .................................................. 208
C-4 ControlIT Directory Selection Page ......................................... 208
C-5 Create ControlIT Program Icon Page ...................................... 209
C-6 Ready to Install Files Page ..................................................... 209
C-7 Change Preferences Dialog Box .............................................. 210
C-8 Setting Viewer Preferences .................................................... 211
C-9 Setting Host Preferences ...................................................... 211
C-10 Setting Internet (TCP/IP) Preferences .................................... 212
C-11 Setting General Preferences .................................................. 212
C-12 Setting Other General Preferences ........................................ 213
C-13 Setting NetBIOS/NetBEUI Preferences ................................... 213
C-14 ControlIT Proprietary Security Dialog Box ............................ 214
C-15 NetBios Page of Connect to Remote Dialog Box ...................... 215
C-16 Enter Address Dialog Box .................................................... 215
C-17 Switching to Windows Screen .............................................. 216
C-18 ControlIT Main Screen ....................................................... 216
C-19 Compatibility Message Box .................................................. 217

D-1 Net8 Configuration Assistant: Welcome Page .......................... 218
D-2 Listener Configuration, Listener Name Page ............................. 219
D-3 Listener Configuration, TCP/IP Protocol Page ......................... 220
D-4 Listener Configuration, Select Listener Page ........................... 221
# List of Tables

1-1 Requirements for Workstation, Secondary PowerStation, or Client .......................................................... 24
1-2 Requirements for Primary PowerStation ....................................... 25
1-3 Requirements for Server ............................................................ 26
1-4 Maximum Cable Lengths for IEEE-488 Devices .................... 27
1-5 IEEE-488 Devices Supported by the Millennium\textsuperscript{32} Software .... 28
1-6 Non-IEEE-488 Devices Supported by the Millennium\textsuperscript{32} Software ................................................................. 30
1-7 Serial Instrument Support .......................................................... 31
2-1 Setting DIP Switches ............................................................... 43
2-2 Settings for Waters 600, 410, 996, PCM, and TCM ................. 45
2-3 Settings for Waters 715 Injector ............................................ 46
2-4 Non-IEEE Device Connections ............................................... 50
2-5 Autosampler Connections ....................................................... 52
2-6 Detector Connections to busSAT/IN Module ......................... 53
2-7 150C plus Connections to busSAT/IN Module ......................... 54
2-8 150CV plus Connections to busSAT/IN Module ......................... 55
2-9 Analog Data Output Connections ........................................... 62
3-1 Minimum Disk Space Requirements ......................................... 83
4-1 Oracle Initialization Parameters ............................................. 97
4-2 Minimum Disk Space Requirements ....................................... 98
4-3 Small Server Database .......................................................... 99
4-4 Medium Server Database ...................................................... 99
4-5 Large Server Database ......................................................... 100

B-1 Script Files ............................................................................. 192
Preface

The Millennium®32 System Installation and Configuration Guide provides the information you need to install and configure the Millennium®32 System. It includes procedures for installing the hardware and the software on stand-alone workstations, PowerStations®, and Millennium®32 Client/Server Systems.

This guide is for system installers. While the area of expertise of the system installer may be in chemistry and/or chromatography with an understanding of the principles of chromatography and the basic Millennium®32 software, the installer should also have a good understanding of computer concepts and hardware and a working knowledge of networks in general. In addition the installer should be experienced with the following:

- Real-time data acquisition systems
- Intel® Pentium® Server (for client/server configurations)
- Windows NT® 4.0 or Windows® 2000 operating system
- Networks (for PowerStation and client/server configurations)
- Oracle® Server database software

*Note*: Hardware installation and configuration tasks are typically handled by an IT representative using appropriate product documentation. As with network installation and configuration, general hardware installation and configuration tasks are beyond the scope of this document but are critical to the successful operation of the Millennium®32 System.

Organization

This guide contains the following:

- **Chapter 1** introduces the product and describes the system requirements and supported devices.
- **Chapter 2** provides complete hardware installation and configuration procedures.
- **Chapter 3** provides the complete Millennium®32 software installation procedures for the stand-alone workstation.
- **Chapter 4** provides software installation procedures for a server in a Millennium®32 Client/Server System configuration or for a primary PowerStation.
- **Chapter 5** provides software installation procedures for a client.
- **Chapter 6** provides software installation procedures for the LAC/E™32 Acquisition Server or acquisition client.
**Chapter 7** provides software installation procedures for the Millennium Service.

**Appendix A** describes how to specify your own settings for Oracle software during a custom software installation on a server.

**Appendix B** describes how to specify your own settings for a custom build of the Millennium³² database.

**Appendix C** describes how to install ControlIT® remote administration software on a viewer client or server computer, so you can control a LAC/E³² Acquisition Server remotely.

**Appendix D** describes how to add a listener service.

**Related Documentation**

**Waters Licenses, Warranties, and Support:** Provides software license and warranty information, describes training and extended support, and tells how Waters® handles shipments, damages, claims, and returns.

**Online Documentation**

Online documentation includes the following:

**Millennium³² Help:** Describes all Millennium³² windows, menus, menu selections, and dialog boxes for the base software and all the software options. Also includes reference information and procedures for performing all tasks required to use the Millennium³² software. Included as part of the Millennium³² software.

**Millennium³² Read Me File:** Describes product features and enhancements, helpful tips, installation and/or configuration considerations, and changes since the previous Millennium software version.

**Millennium³² LIMS Help:** Describes how to use the Millennium³² LIMS Interface to export results and import worklists.

**Millennium³² Toolkit Professional Help:** Describes how to use the common-object-model, message-based protocol to communicate with the Millennium³² software from a third-party application.

**Millennium³² WebServer Help:** Describes how to use the Millennium³² WebServer application.

**Printed Documentation**

Printed documentation that comprises the base product includes the following:

**Millennium³² Read Me First:** Describes the Millennium³² software documentation using a flowchart as a reading path.
**Millennium** subtext **Software Getting Started Guide**: Provides an introduction to the Millennium subtext software. Describes the basics of how to use Millennium subtext software to acquire data, develop a processing method, review results, and print a report. Also covers basic information for managing projects and configuring systems.

**Millennium** subtext **Software Data Acquisition and Processing Theory Guide**: Provides theories pertaining to data acquisition, peak detection and integration, and quantitation of sample components.

**Millennium** subtext **System Installation and Configuration Guide**: Describes Millennium subtext software installation, including the stand-alone workstation, PowerStation configuration, and client/server system. Discusses how to configure the computer and chromatographic instruments as part of the Millennium subtext System. Also covers the installation, configuration, and use of acquisition servers such as the LAC/E module, the busLAC/E card, and interface cards used to communicate with serial instruments.

**Millennium** subtext **System Upgrade and Configuration Guide**: Describes how to add hardware and upgrade the Millennium subtext software using an import-and-export upgrade method.

**Millennium** subtext **Software Release Notes**: Contains last-minute information about the product. Also provides supplementary information about specific Millennium subtext software releases.

**Printed Documentation for Options**

Printed documentation that supports software options includes the following:

**Millennium** subtext **System Suitability Quick Reference Guide**: Describes the basics of the Millennium subtext System Suitability software application and describes the equations used by the System Suitability software.

**Millennium** subtext **PDA Software Getting Started Guide**: Describes the basics of how to use the Millennium subtext PDA software option to develop a PDA processing method and to review PDA results.

**Millennium** subtext **GPC Software Getting Started Guide**: Describes how to use the Millennium subtext GPC software option to develop a GPC processing method and to review GPC results.

**Millennium** subtext **GPCV Software Getting Started Guide**: Describes how to use the Millennium subtext GPCV software option to develop a GPCV processing method and to review GPCV results.

**Millennium** subtext **ZQ Mass Detector Software Getting Started Guide**: Describes installation, configuration, calibration, and tuning methods, as well as how to operate the ZQ Mass Detector with the Millennium subtext software.
**Millennium**\(^{32}\) Chromatographic Pattern Matching Software Getting Started Guide: Describes how to use the Chromatographic Pattern Matching software option to develop a pattern matching processing method and to review pattern match results.

**Millennium**\(^{32}\) Dissolution System Software Quick Start Guide: Describes how to operate the Alliance\(^{®}\) Dissolution System using Millennium\(^{32}\) software.

**Waters Integrity System Getting Started Guide:** Describes the features of the Waters Integrity\(^{®}\) System and provides step-by-step tutorials that guide a user through the use of the Millennium\(^{32}\) Mass Spectrometry (MS) software option.

**Millennium**\(^{32}\) Toolkit Programmer’s Reference Guide: Describes how to use the common-object-model, message-based protocol to communicate with the Millennium\(^{32}\) software from a third-party application.

**Millennium**\(^{32}\) Client/Server System Administrator’s Guide: Describes how to administer Millennium\(^{32}\) software client/server tasks in a client/server system.

**Millennium**\(^{32}\) WebServer Installation and Configuration Guide: Describes how to install and configure the Millennium\(^{32}\) WebServer application.

**Related Adobe Acrobat Reader Documentation**

For detailed information about using Adobe\(^{®}\) Acrobat\(^{®}\) Reader, refer to the Adobe Acrobat Reader Online Guide. This Online Guide covers procedures such as viewing, navigating, and printing electronic documentation from Adobe Acrobat Reader.

**Printing This Electronic Document**

Adobe Acrobat Reader lets you easily print pages, page ranges, or the entire document by selecting **Print** from the File menu. For optimum print quantity, Waters recommends that you specify a PostScript\(^®\) printer driver for your printer. Ideally, use a printer that supports 600 dpi print resolution.

**Documentation Conventions**

The following conventions may be used in this guide:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Purple</strong></td>
<td>Purple text indicates user action such as keys to press, menu selections, and commands. For example, “Click <strong>Next</strong> to go to the next page.”</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Italic indicates information that you supply such as variables. It also indicates emphasis and document titles. For example, “Replace <em>file_name</em> with the actual name of your file.”</td>
</tr>
</tbody>
</table>
**Notes**

Notes call out information that is helpful to the operator. For example:

*Note:* Record your results before you proceed to the next step.

**Attentions**

Attentions provide information about preventing possible damage to the system or equipment. For example:

*Attention:* To avoid damaging the detector flow cell, do not touch the flow cell window.

---

<table>
<thead>
<tr>
<th>Convention</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Courier</td>
<td>Courier indicates examples of source code and system output. For example, “The SVRMGR&gt; prompt appears.”</td>
</tr>
<tr>
<td>Courier Bold</td>
<td>Courier bold indicates characters that you type or keys you press in examples of source code. For example, “At the LSNRCTL&gt; prompt, enter set password oracle to access Oracle.”</td>
</tr>
<tr>
<td>Underlined blue</td>
<td>Indicates hypertext cross-references to a specific chapter, section, subsection, or sidehead. Clicking this topic using the hand symbol automatically brings you to this topic within the document. Right-clicking and selecting Go Back from the shortcut menu returns you to the originating topic. For example: If you want to install additional Oracle management tools or specify some settings, see Appendix A, Installing Custom Oracle Software.</td>
</tr>
<tr>
<td>Keys</td>
<td>The word <em>key</em> refers to a computer key on the keypad or keyboard. Screen keys refer to the keys on the instrument located immediately below the screen. For example, “The A/B screen key on the 2414 Detector displays the selected channel.”</td>
</tr>
<tr>
<td>...</td>
<td>Three periods indicate that more of the same type of item can optionally follow. For example, “You can store filename1, filename2, … in each folder.”</td>
</tr>
<tr>
<td>&gt;</td>
<td>A right arrow between menu options indicates you should choose each option in sequence. For example, “Select File &gt; Exit” means you should select File from the menu bar, then select Exit from the File menu.</td>
</tr>
</tbody>
</table>
Cautions

Cautions provide information essential to the safety of the operator. For example:

**Caution:** To avoid chemical or electrical hazards, always observe safe laboratory practices when operating the system.

**Caution:** To avoid possible electrical shock and injury, always turn off the detector and unplug the power cord before performing maintenance procedures.

**Caution:** To avoid possible burns, turn off the lamp at least 30 minutes before removing it for replacement or adjustment.
Chapter 1
Introduction

The Waters® Millennium®32 Chromatography Manager includes:

- Chromatographic instrumentation
- Chromatographic data acquisition and data processing computers
- Millennium32 software, a 32-bit data acquisition and management software application with advanced integrated database architecture

The system acquires, processes, reports, and manages chromatographic information. The Millennium32 Chromatography Manager offers easy-to-use technology and converts high-quality, accurate results into usable information while meeting security and regulatory compliance requirements. It is a complete chromatography and results management system that you can adapt to your individual chromatography requirements by using as many or as few Millennium32 software capabilities as you require.

1.1 Typical System Configurations

The Millennium32 Chromatography Manager can operate in the following configurations:

- Stand-alone workstation (see Figure 1-1)
- PowerStation® (see Figure 1-2)
- Millennium32 Client/Server System (see Figure 1-3)
Figure 1-1 shows a typical configuration for a stand-alone workstation.

![Typical Stand-Alone Workstation System Configuration](image)

Figure 1-2 shows a typical configuration for the PowerStation system.

![Typical PowerStation System Configuration](image)
Figure 1-3 shows a typical configuration for the Millennium\textsuperscript{32} Client/Server System.

1.2 Hardware and Software Requirements

Table 1-1 through Table 1-3 describe the major subsystems and the hardware and operating system configurations that are supported by the Millennium\textsuperscript{32} software.

Table 1-1 Requirements for Workstation, Secondary PowerStation, or Client

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer with keyboard and mouse</td>
<td>Windows NT\textsuperscript{®}: Intel\textsuperscript{®} Pentium\textsuperscript{®} II (or equivalent), 266 MHz</td>
</tr>
<tr>
<td></td>
<td>Windows\textsuperscript{®} 2000 Professional: Intel Pentium III (or equivalent), 500 MHz</td>
</tr>
<tr>
<td>Random access memory (RAM)</td>
<td>128 MB</td>
</tr>
<tr>
<td>Hard disk drive</td>
<td>4 GB</td>
</tr>
</tbody>
</table>
### Table 1-1 Requirements for Workstation, Secondary PowerStation, or Client (Continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disk drive</td>
<td>3.5-inch, 1.44 MB</td>
</tr>
<tr>
<td>CD-ROM drive</td>
<td>Required</td>
</tr>
<tr>
<td>Monitor</td>
<td>Required</td>
</tr>
<tr>
<td>Graphics capability</td>
<td>Minimum: 800 × 600, 256 colors</td>
</tr>
<tr>
<td></td>
<td>Recommended: 1024 × 768, 64K colors</td>
</tr>
<tr>
<td>Printer</td>
<td>Any printer supported by Windows NT 4.0 or</td>
</tr>
<tr>
<td></td>
<td>Windows 2000</td>
</tr>
<tr>
<td>Optional control card</td>
<td>Waters Bus Laboratory Acquisition and Control/</td>
</tr>
<tr>
<td></td>
<td>Environment (busLAC/E™) card or 8-port serial</td>
</tr>
<tr>
<td>Operating system and graphical</td>
<td>Windows NT 4.0 with Service Pack 6a (128-bit),</td>
</tr>
<tr>
<td>user interface</td>
<td>or Windows 2000 with Service Pack 2</td>
</tr>
<tr>
<td>Application software</td>
<td>Millennium³² software</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Internet Explorer 5.5 with</td>
</tr>
<tr>
<td></td>
<td>Service Pack 1</td>
</tr>
</tbody>
</table>

### Table 1-2 Requirements for Primary PowerStation

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer with keyboard and</td>
<td>Windows NT Server: Intel Pentium III, 733 MHz</td>
</tr>
<tr>
<td>mouse</td>
<td>(or equivalent)</td>
</tr>
<tr>
<td></td>
<td>Windows 2000 Server: Intel Pentium III, 733 MHz</td>
</tr>
<tr>
<td></td>
<td>(or equivalent)</td>
</tr>
<tr>
<td>Random access memory (RAM)</td>
<td>Windows NT Server: 256 MB</td>
</tr>
<tr>
<td></td>
<td>Windows 2000 Server: 512 MB</td>
</tr>
<tr>
<td>Hard disk drive</td>
<td>2 × 18 GB</td>
</tr>
<tr>
<td>Disk drive</td>
<td>3.5-inch, 1.44 MB</td>
</tr>
<tr>
<td>CD-ROM drive</td>
<td>Required</td>
</tr>
<tr>
<td>Tape backup</td>
<td>Required</td>
</tr>
<tr>
<td>Monitor</td>
<td>Required</td>
</tr>
<tr>
<td>Graphics capability</td>
<td>Minimum: 800 × 600, 256 colors</td>
</tr>
<tr>
<td></td>
<td>Recommended: 1024 × 768, 64K colors</td>
</tr>
<tr>
<td>Printer</td>
<td>Any printer supported by Windows NT 4.0 or</td>
</tr>
<tr>
<td></td>
<td>Windows 2000</td>
</tr>
</tbody>
</table>
### Table 1-2 Requirements for Primary PowerStation (Continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system and graphical</td>
<td>Windows NT 4.0 Server with Service Pack 6a</td>
</tr>
<tr>
<td>user interface</td>
<td>(128-bit), or</td>
</tr>
<tr>
<td></td>
<td>Windows 2000 Server with Service Pack 2</td>
</tr>
<tr>
<td>Application software</td>
<td>Millennium(^{32}) server software</td>
</tr>
<tr>
<td></td>
<td>Microsoft Internet Explorer 5.5 with Service Pack 1</td>
</tr>
<tr>
<td>Network interface card</td>
<td>Required</td>
</tr>
</tbody>
</table>

### Table 1-3 Requirements for Server

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer with keyboard and mouse</td>
<td>Windows NT Server: Intel Server Pentium II, 266 MHz</td>
</tr>
<tr>
<td></td>
<td>Windows 2000 Server: Pentium III, 500 MHz</td>
</tr>
<tr>
<td>Random access memory (RAM)</td>
<td>Windows NT Server: 256 MB</td>
</tr>
<tr>
<td></td>
<td>Windows 2000 Server: 512 MB</td>
</tr>
<tr>
<td>Hard disks (minimum size)</td>
<td>Four disks, 1 through 4; 4.0 GB, each disk</td>
</tr>
<tr>
<td>CD-ROM drive</td>
<td>Required</td>
</tr>
<tr>
<td>Disk drive</td>
<td>3.5-inch, 1.44 MB</td>
</tr>
<tr>
<td>Tape backup</td>
<td>Required</td>
</tr>
<tr>
<td>Monitor</td>
<td>Required</td>
</tr>
<tr>
<td>Graphics capability</td>
<td>Minimum: 800 × 600, 256 colors</td>
</tr>
<tr>
<td></td>
<td>Recommended: 1024 × 768, 64K colors</td>
</tr>
<tr>
<td>Printer</td>
<td>Any printer supported by Windows NT 4.0 or Windows 2000</td>
</tr>
<tr>
<td>Operating system and graphical</td>
<td>Windows NT Server 4.0 with Service Pack 6a</td>
</tr>
<tr>
<td>user interface</td>
<td>(128-bit), or Windows 2000 with Service Pack 2</td>
</tr>
<tr>
<td>Server software</td>
<td>Millennium(^{32}) server software</td>
</tr>
<tr>
<td></td>
<td>Microsoft Internet Explorer 5.5 with Service Pack 1</td>
</tr>
<tr>
<td>Network interface card</td>
<td>Required</td>
</tr>
</tbody>
</table>
1.3 Devices Supported by the System

The Millennium\textsuperscript{32} Chromatography Manager can support:

- Up to four busSAT/IN Modules through an I/O distribution box on the stand-alone Millennium\textsuperscript{32} workstations, PowerStations, and LAC/E\textsuperscript{32} Acquisition Servers.
- Multiple RS-232-based devices (such as gas chromatographs and detectors).
- Up to 14 IEEE-488-based devices using no more than 20 meters (65 feet) of cable in total, and no more than 4 meters (13 feet) of cabling between devices (Table 1-4).

Table 1-4 Maximum Cable Lengths for IEEE-488 Devices

<table>
<thead>
<tr>
<th>Number of Devices Connected</th>
<th>Maximum Total Cable Length (Meters)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>6</td>
</tr>
<tr>
<td>3</td>
<td>8</td>
</tr>
<tr>
<td>4</td>
<td>10</td>
</tr>
<tr>
<td>5</td>
<td>12</td>
</tr>
<tr>
<td>6</td>
<td>14</td>
</tr>
<tr>
<td>7</td>
<td>16</td>
</tr>
<tr>
<td>8</td>
<td>18</td>
</tr>
<tr>
<td>Greater Than 8</td>
<td>20</td>
</tr>
</tbody>
</table>

The Millennium\textsuperscript{32} Chromatography Manager supports the IEEE-488 devices in Table 1-5. Table 1-5 and Table 1-6 list the minimum firmware versions of the devices supported by Millennium\textsuperscript{32} software v. 4.0 at the time of release. Refer to the Millennium\textsuperscript{32} Software Release Notes for the most up-to-date list of supported firmware versions.

**Note:** If you purchased the Millennium\textsuperscript{32} Chromatography Manager from Waters, your Waters Technical Service Representative has already installed and configured your system for you.

**Attention:** Before you install an IEEE-488 device in the Millennium\textsuperscript{32} system, verify that the firmware of the device is the minimum version listed in Table 1-5.
Table 1-5  IEEE-488 Devices Supported by the Millennium Software

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Device</th>
<th>Minimum Firmware Version&lt;sup&gt;a&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Pumps</strong></td>
<td>Waters 600E Controller (CRT display), Fluid Handling Unit (FHU) = 600, 610, 600MS, or 625</td>
<td>2.1</td>
</tr>
<tr>
<td></td>
<td>Waters 600E Controller [Silk (CRT display)], FHU = 600MS</td>
<td>2.1</td>
</tr>
<tr>
<td></td>
<td>Waters 600 Controller (LP/LCD display, ac transformer), FHU = 600 or 610</td>
<td>3.5</td>
</tr>
<tr>
<td></td>
<td>Waters 600 Controller (LP/LCD display, dc power supply), FHU = 600 or 610</td>
<td>4.2</td>
</tr>
<tr>
<td></td>
<td>Waters 600S Controller (LP/LCD display, ac transformer), FHU = 616 or 626</td>
<td>4.2</td>
</tr>
<tr>
<td></td>
<td>Waters 600S Controller (LP/LCD display, dc power supply), FHU = 616 or 626</td>
<td>4.2</td>
</tr>
<tr>
<td></td>
<td>Waters 625 Controller [Silk (CRT display)], is not supported; runs if Silk is not uploaded</td>
<td>2.1</td>
</tr>
<tr>
<td></td>
<td>Waters PrepLC Controller 2000/4000</td>
<td>3.1</td>
</tr>
<tr>
<td></td>
<td>Waters 1525 and 1515 Pumps</td>
<td>2.2</td>
</tr>
<tr>
<td><strong>Interfaces and Accessories</strong></td>
<td>Waters Half-Size busLAC/E Card</td>
<td>Rev. B</td>
</tr>
<tr>
<td></td>
<td>Waters busLAC/E Card (ISA)</td>
<td>5.0</td>
</tr>
<tr>
<td></td>
<td>Waters PCI or PCI-x busLAC/E Card</td>
<td>Rev. A</td>
</tr>
<tr>
<td></td>
<td>Waters Temperature Control Module (TCM)</td>
<td>2.1</td>
</tr>
<tr>
<td></td>
<td>Waters Pump Control Module (PCM)</td>
<td>2.2</td>
</tr>
<tr>
<td><strong>Detectors</strong></td>
<td>Waters 410 Refractive Index Detector</td>
<td>4.20</td>
</tr>
<tr>
<td></td>
<td>Waters 2410 Refractive Index Detector (appears as 410)</td>
<td>5.1</td>
</tr>
<tr>
<td></td>
<td>Waters 2414 Refractive Index Detector (2410 emulation mode)</td>
<td>1.0</td>
</tr>
<tr>
<td></td>
<td>Waters 486 Tunable Absorbance Detector</td>
<td>4.10 or 4.20</td>
</tr>
<tr>
<td></td>
<td>Waters 2487 Dual λ Absorbance Detector</td>
<td>1.01</td>
</tr>
<tr>
<td></td>
<td>Waters 996 Photodiode Array Detector</td>
<td>Firmware 1.8 and Software 2.3</td>
</tr>
<tr>
<td></td>
<td>Waters 2996 Photodiode Array Detector</td>
<td>3.0</td>
</tr>
</tbody>
</table>
Table 1-5 IEEE-488 Devices Supported by the Millennium® Software (Continued)

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Device</th>
<th>Minimum Firmware Version&lt;sup&gt;a&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autosamplers</td>
<td>Waters UltraWISP 715 Autosampler (no adjustable parameters)</td>
<td>2.2</td>
</tr>
<tr>
<td></td>
<td>Waters 712 Autosampler (on IEEE-488)</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td>Waters 717plus Autosampler</td>
<td>3.1</td>
</tr>
<tr>
<td>Systems</td>
<td>Waters 2690 Separations Module</td>
<td>1.21 or 1.22</td>
</tr>
<tr>
<td></td>
<td>Waters 2695 Separations Module</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td>Waters 2690D Alliance Dissolution System (SR8plus)</td>
<td>1.41 or 1.31</td>
</tr>
<tr>
<td></td>
<td>Waters 2695D Separations Module</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td>Waters 2790 Separations Module</td>
<td>1.02 or 1.1</td>
</tr>
<tr>
<td></td>
<td>Waters 2795 Separations Module</td>
<td>2.0</td>
</tr>
<tr>
<td></td>
<td>Waters Integrity System (TMD)</td>
<td>1.1</td>
</tr>
<tr>
<td></td>
<td>Waters LC Module 1plus (LCM1); requires CPU Board Rev. C or D</td>
<td>2.2 or 2.3</td>
</tr>
<tr>
<td></td>
<td>Waters LC Module 1plus (LCM1) with Dual Detector Bench; requires CPU Board Rev. C or D</td>
<td>2.2 or 2.3</td>
</tr>
<tr>
<td></td>
<td>Waters LC Module1</td>
<td>2.2 or 2.3</td>
</tr>
<tr>
<td></td>
<td>Waters 600E</td>
<td>2.2 or 2.3</td>
</tr>
<tr>
<td></td>
<td>Waters 715</td>
<td>2.10</td>
</tr>
<tr>
<td></td>
<td>Waters 486 M1</td>
<td>2.30 or 2.20</td>
</tr>
<tr>
<td></td>
<td>Waters 486</td>
<td>2.30</td>
</tr>
</tbody>
</table>

<sup>a</sup> Find the firmware revision number on the instrument specification plate or front panel display.
The Millennium³² Chromatography Manager also supports the non-IEEE-488 devices listed in Table 1-6.

Table 1-6 Non-IEEE-488 Devices Supported by the Millennium³² Software

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Device</th>
<th>Minimum Firmware Version¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detectors</td>
<td>Waters 431/432 Conductivity Detector</td>
<td>Not controlled by Millennium³² software</td>
</tr>
<tr>
<td></td>
<td>Waters 470 Fluorescence Detector</td>
<td>Not controlled by Millennium³² software</td>
</tr>
<tr>
<td></td>
<td>Waters 474 Fluorescence Detector not equipped with optional RS-232C interface card</td>
<td>Not controlled by Millennium³² software</td>
</tr>
<tr>
<td></td>
<td>Waters 474 Fluorescence Detector equipped with optional RS-232C interface card (“Scan Mode” and “Not Restricted” are not supported)</td>
<td>2.02</td>
</tr>
<tr>
<td></td>
<td>Waters Quanta 4000E Detector</td>
<td>Not controlled by Millennium³² software</td>
</tr>
<tr>
<td></td>
<td>Waters Capillary Ion Analyzer (CIA) Detector</td>
<td>Not controlled by Millennium³² software</td>
</tr>
<tr>
<td>Systems</td>
<td>Waters ZQ™ 2000 and ZQ 4000 Mass Detectors with MassLynx™ 3.5 Embedded PC; Ethernet control and communication</td>
<td>Correct firmware version is installed by Millennium³² v. 4.0</td>
</tr>
<tr>
<td></td>
<td>Waters Alliance GPC 2000 and GPCV 2000 Series Systems</td>
<td>1.10</td>
</tr>
<tr>
<td></td>
<td>5890 and 5890 S Gas Chromatographs (S designates instrument on serial card)</td>
<td>3.02</td>
</tr>
<tr>
<td></td>
<td>6890 and 6890+ Gas Chromatographs</td>
<td>3.07</td>
</tr>
<tr>
<td></td>
<td>7673 and 7673 S Autosampler Controller (S designates instrument on serial card)</td>
<td>4.3</td>
</tr>
</tbody>
</table>
For both operating systems (Windows NT 4.0 with Service Pack 6a [128-bit] and Windows 2000 with Service Pack 2), Table 1-7 lists serial instrument support.

### Table 1-7 Serial Instrument Support

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Device</th>
<th>Minimum Firmware Version&lt;sup&gt;a&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Systems (cont'd.)</td>
<td>1100 Series Control Modules and components:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Pumps (isocratic, quaternary, and binary, with solvent switching)</td>
<td>3.81</td>
</tr>
<tr>
<td></td>
<td>- Column Compartment (thermostatted, with column switching valve)</td>
<td>3.80</td>
</tr>
<tr>
<td></td>
<td>- Detectors (RI, multiple wavelength UV, and variable wavelength UV)</td>
<td>3.80</td>
</tr>
<tr>
<td></td>
<td>- Autosamplers (standard and thermostatted)</td>
<td>3.80</td>
</tr>
<tr>
<td>Interfaces and Accessories</td>
<td>Waters SAT/IN or SAT/IN2 Module (2 designates instrument on Equinox card)</td>
<td>13.0 or 20.0</td>
</tr>
<tr>
<td></td>
<td>Equinox Serial Interface Card (Driver versions are listed, not firmware versions)</td>
<td>Windows NT: Drivers 4.16; Windows 2000: Drivers 5.1</td>
</tr>
</tbody>
</table>

<sup>a</sup> Find the firmware revision number on the instrument specification plate or front panel display.

For both operating systems (Windows NT 4.0 with Service Pack 6a [128-bit] and Windows 2000 with Service Pack 2), Table 1-7 lists serial instrument support.

### Table 1-6 Non-IEEE-488 Devices Supported by the Millennium<sup>32</sup> Software (Continued)

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Device</th>
<th>Minimum Firmware Version&lt;sup&gt;a&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>5890S, 7673S, 6890, and 6890+ GCs 1100 Module</td>
<td>Dual tower injections supported on serial card; dual tower not supported on busLAC/E Module.</td>
<td></td>
</tr>
<tr>
<td>Waters SAT/IN Module</td>
<td>Supported only on Equinox serial card.</td>
<td></td>
</tr>
<tr>
<td>Waters SAT/IN2 Module</td>
<td>Supported only on busLAC/E Module.</td>
<td></td>
</tr>
<tr>
<td>Waters 474 Detector</td>
<td>Unlike the busSAT/IN, both channels on the SAT/IN2 must be configured in one system. Can be set as a dual tower instrument via the Run Sample user customized preferences dialog box. Connects to PC COMs or serial card. Not supported on busLAC/E.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Connected to PC COMs or serial card. Not supported on busLAC/E.</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 2
Installing and Configuring the Hardware

Use this chapter to install and configure the hardware for the Waters Millennium\textsuperscript{32} Chromatography Manager.

For all configurations except a stand-alone workstation, a network is required in your facility so that the PowerStations and/or the Millennium\textsuperscript{32} Client/Server System can function. Waters personnel do not run or install network cabling.

\textbf{Note:} If your Waters Technical Service Representative has already installed and configured the system for you, proceed to \textit{Section 2.8, Starting Up the System}.

\begin{itemize}
  \item \textbf{Attention:} Before installing any hardware or software, perform a full backup of your hard drives (see the instructions provided by the manufacturer of your computer).
\end{itemize}

2.1 Selecting the Site

Locate the Millennium\textsuperscript{32} Chromatography Manager in a clean area, free from shock, vibration, and extremes of temperature and humidity.

\textbf{Environmental Requirements}

The Millennium\textsuperscript{32} Chromatography Manager is designed to operate within the following temperature and humidity ranges:

\begin{itemize}
  \item \textbf{Temperature} – 10 to 31 °C (50 to 88 °F)
  \item \textbf{Humidity} – 20 to 80\% relative humidity, noncondensing, maximum wet bulb of 25 °C and minimum dew point of 2 °C
\end{itemize}
Note: Acceptable temperature and humidity ranges vary according to the specific model of computer and printer.

Attention: Do not locate equipment in direct sunlight or near heat registers or air conditioning vents.

Bench Space

Allow sufficient bench space for the workstation, PowerStation, or client computers (keyboard, monitor, system unit, and printer) as recommended in the documentation supplied with the computer. You can place the computers on the lab bench or on a desktop near the chromatography instrumentation. The total bench space you require depends upon the number of devices you plan to configure (pumps, detectors, autosamplers, busSAT/IN Modules, and so on).

Cable Lengths

Arrange the components of your chromatographic system to minimize IEEE-488 and analog cable lengths. Ensure that you use minimal cable lengths to ensure proper signal transmission. Maximum cable lengths are listed in Table 1-4.

Instrument Arrangement

Make sure the ventilation slots on all instruments are not blocked. Allow at least six inches (15 cm) of space on all sides of each instrument to ensure adequate air flow.

For information on the best arrangement of your Millennium^32 Chromatography Manager and connected instruments, consult your Waters Technical Service Representative.

2.2 Installing and Configuring Computer Systems

This section describes the process for installing and configuring the Millennium^32 computer systems and other components.

2.2.1 Stand-Alone Millennium^32 Workstation

The stand-alone Millennium^32 workstation requires:

- A busLAC/E (IEEE-488 interface) card for connecting Waters IEEE-488 devices
- An I/O distribution box for connecting busSAT/IN Modules or 5890 GCs
- An optional 8-port serial card for connecting 6890 GCs or other supported serial instruments
To install and set up the Millennium\textsuperscript{32} workstation:

1. Unpack and place the workstation in the desired location.
2. Attach the keyboard, mouse, and monitor to the workstation.
3. To install other computer peripherals such as a printer or optional tape drive, see the installation documentation supplied with the device.
4. Ensure that the busLAC/E (IEEE-488 interface) card is installed in the workstation and is set up correctly (see the discussion “busLAC/E Card” in Section 2.2.4, Optional Interface Cards).
5. Connect the IEEE-488 chromatography instruments to the busLAC/E card in the workstation using the IEEE-488 cable (see Section 2.3, Connecting IEEE-488 Chromatographic Devices).
6. Connect and configure the serial devices (see Section 2.4, Connecting Non-IEEE-488 Chromatographic Devices, and Section 2.5, Installing Gas Chromatographs).
7. Power up the workstation (see Section 2.8, Starting Up the System).

2.2.2 Millennium\textsuperscript{32} PowerStation

The Millennium\textsuperscript{32} PowerStation requires a LAC/E\textsuperscript{32} Acquisition Server.

To install and set up the Millennium\textsuperscript{32} PowerStation:

1. Unpack and place the PowerStation in the desired location.
2. Attach the keyboard, mouse, and monitor to the PowerStation.
3. To install other computer peripherals such as a printer or optional tape drive, see the installation documentation supplied with the device.
4. Ensure that the network interface card is installed in the PowerStation and is set up correctly (see the discussion “Network Interface Card for a LAN” in Section 2.2.4, Optional Interface Cards).
5. Connect the PowerStation to the chromatography instruments using the LAC/E\textsuperscript{32} Acquisition Server on the network.

2.2.3 Millennium\textsuperscript{32} Client/Server System

The Millennium\textsuperscript{32} Client/Server System consists of a server, one or more clients, and a LAC/E\textsuperscript{32} Acquisition Server. Each computer in the Millennium\textsuperscript{32} Client/Server System requires a network interface card.
Chromatographic devices in a Millennium\textsuperscript{32} Client/Server System or PowerStation are connected to the LAC/E\textsuperscript{32} Acquisition Server. The LAC/E\textsuperscript{32} Acquisition Server provides distributed acquisition for the PowerStation and client/server configurations including:

- Data acquisition
- Instrument control
- Remote access to instruments
- Remote data processing in Run and Report modes

To install and set up the Millennium\textsuperscript{32} Client/Server System:

1. Unpack and place the server in the desired location.
2. Attach the keyboard, monitor, and mouse to the server.
3. To install other computer peripherals such as a printer or optional tape drive, see the installation documentation supplied with the device.
4. Ensure that the network interface card is installed in the server and is set up correctly (see Section 2.2.4, Optional Interface Cards).
5. Set up the clients:
   a. Unpack and place each client in the desired location.
   b. Attach the keyboard, mouse, and monitor to the computer.
   c. Ensure that the network interface card is installed in each client and is set up correctly.
   d. Repeat steps 5a through 5c for each client in the client/server system.
   e. Connect the clients to the network.
6. Set up the LAC/E\textsuperscript{32} Acquisition Server:
   a. Unpack and place the LAC/E\textsuperscript{32} Acquisition Server in the desired location.
   b. Install the LAC/E\textsuperscript{32} Acquisition Server.
   c. Ensure that the network interface card is installed in the LAC/E\textsuperscript{32} Acquisition Server and is set up correctly.
   d. Connect the LAC/E\textsuperscript{32} Acquisition Server to the network.
   e. Ensure that the network is configured and set up properly for all computers on the network.
   f. Connect the chromatographic instruments to the LAC/E\textsuperscript{32} Acquisition Server.
2.2.4 Optional Interface Cards

**Note:** Direct connection to the COM port on a stand-alone workstation or an acquisition client without a busLAC/E card is allowed when you are acquiring data from a SAT/IN2 Module and a 474 Detector.

**busLAC/E Card**

The Millennium\textsuperscript{32} stand-alone workstation uses a busLAC/E card to function with the Millennium\textsuperscript{32} software. Chromatographic devices connect to the busLAC/E card. The busLAC/E card performs two primary functions:

- Acquires data from a detector and transmits the data to the computer
- Controls chromatographic devices

**Note:** The half-size PCI busLAC/E card supersedes the PCI and PCI-x busLAC/E cards.

The busLAC/E card is a microprocessor-based interface card that allows the Millennium\textsuperscript{32} software to communicate with chromatography instruments. The busLAC/E card transmits commands from the Millennium\textsuperscript{32} software to detectors, autosamplers, pumps, and other devices over the IEEE-488 and custom interfaces using an IEEE-488 cable. Data from the devices are transmitted through the busLAC/E card to the computer for analysis.

To install the busLAC/E card in the computer, see the installation instructions provided with the busLAC/E card.

**Note:** The ISA busLAC/E card is not supported in Windows 2000 on the Compaq\textsuperscript{®} Deskpro\textsuperscript{®} EN 9100 because the Adaptec\textsuperscript{™} SCSI card, which is required for the hard drive, conflicts with the ISA busLAC/E card.

**8-Port Serial Card**

To interface the Millennium\textsuperscript{32} system with the 1100 Series system, 5890 GC/7673 Controller, 6890 Gas Chromatograph (GC), busSAT/IN Modules, or 474 Detector, an 8-port serial card is required in the stand-alone workstation or in the LAC/E\textsuperscript{32} Acquisition Server. A single port on the card is used for each 6890 GC, 5890 GC, 7673 Controller, 1100 Series system, SAT/IN2, or 474 Detector, connected by a serial cable.

The 8-port serial card transmits commands from the Millennium\textsuperscript{32} software to the serial instrument. Data from the chromatograph are transmitted through a single port on the 8-port serial card to the Millennium\textsuperscript{32} software for analysis.

To install the 8-port serial card in the computer, see the installation instructions provided with the 8-port serial card.
Network Interface Card for a LAN

Note: A TCP/IP address is required.

Network interface cards are needed for the Millennium<sup>32</sup> Client/Server System to interconnect the server, clients, and LAC/E<sup>32</sup> Acquisition Servers. A network interface card is also needed to interface a PowerStation to the LAC/E<sup>32</sup> Acquisition Server. The network interface card connects all computers over the network for the client/server configuration and for the PowerStation configuration.

All Millennium<sup>32</sup> components purchased from Waters Corp. have the network interface card preinstalled. However, additional setup at your site might be required.

Network cards usually use 10 Base T cables.

2.3 Connecting IEEE-488 Chromatographic Devices

Use this section to connect the IEEE-488 components of your chromatographic system to the busLAC/E card in a stand-alone workstation or a LAC/E<sup>32</sup> Acquisition Server.

2.3.1 busLAC/E Card Connections

The busLAC/E card connects to peripheral devices through two ports on the rear edge of the card as follows (Figure 2-1):

- **IEEE-488 Port** – Used for connecting to IEEE-488-controlled devices such as:
  - Waters 2690/2695 Separations Module
  - Waters 996/2996 PDA Detector
  - Waters 717plus Autosampler
  - Waters 2487 Dual λ Absorbance Detector
  - Waters LC Module 1plus

- **I/O Distribution Port** – Used for connecting to serial devices such as:
  - Waters busSAT/IN Module
  - 5890 Gas Chromatograph

Note: For a complete list of devices supported by the Millennium<sup>32</sup> system, see Section 1.3, Devices Supported by the System.
An IEEE-488 cable connects the 2690/2695 Separations Modules, 996/2996 PDA Detectors, 2487 Absorbance Detectors, and other IEEE-488 devices to the busLAC/E card (Figure 2-2).

An I/O distribution cable connects the I/O distribution box to the I/O distribution port of the busLAC/E card. Serial instruments and devices, including the busSAT/IN Module, connect to the busLAC/E card through the I/O distribution box.
2.3.2 Interface Overview

The IEEE-488 bus is an instrument interface that connects devices using one communication protocol. In the Millennium® system, the IEEE-488 interface connects Waters IEEE-488 chromatography devices to the busLAC/E card.

The busLAC/E card is an instrument controller, assigning the role of active talker or listener to each attached device on the IEEE-488 bus. Each instrument designated as an active talker supplies information to the other devices on the IEEE-488 bus. Each device designated as a listener receives information from an active talker device. Only one active talker is allowed at a time, but several listeners can be active simultaneously.
2.3.3 Interface Guidelines

According to IEEE-488 protocol specifications, use the following guidelines:

- Always keep all devices powered on while your system is in use.
- The maximum number of devices that can be connected together to form one interface system is 15 (14 instruments plus the busLAC/E card).
- The maximum total cable length to connect the devices and the busLAC/E card in one interface system is 2 meters (6.5 feet) times the number of devices, or 20 meters (65 feet), whichever is smaller (see Table 1-4).
- The maximum cable length between two devices is 4 meters (13 feet).
- The minimum cable length between two devices is 1 meter (3.25 feet).

**Attention:** Cable lengths greater than the maximum values or less than the minimum values can cause IEEE-488 communication failures. Use the minimal cable lengths to ensure proper signal transmission.

**Note:** For details on setting IEEE-488 device addresses, see Section 2.3.6, Setting IEEE-488 Device Addresses.

- Use addresses 2 through 29 for instruments.
- While a system is active on the IEEE-488 bus, do not power on or off any device on the bus.

**Note:** Powering on or off a 2487 Detector or LC Module 1plus while a system is active on the IEEE-488 bus interrupts communications. To reestablish communications after powering up a 2487 Detector or LC Module 1plus, use the Configure System window (see “Configuring a New Chromatographic System” in the MillenniumHelp).

2.3.4 Making Cable Connections

The Millennium system supports the Waters IEEE-488 devices in Table 1-5.

To connect IEEE-488 devices:

1. Connect the single-receptacle end of the IEEE-488 cable (supplied with the Millennium system) to the busLAC/E card (Figure 2-3).
2. Connect the other end of the IEEE-488 cable (with the stackable connector for daisy-chaining additional instruments) to the IEEE-488 connector on an instrument.

3. Use one end of another IEEE-488 cable to connect to the stackable connector on the first instrument. Connect the other end of the cable to the IEEE-488 port on the next instrument.

4. Repeat step 3 for each additional instrument, up to 14 IEEE-488 instruments. See Table 1-4 for cable-length limitations.

   Note: The order in which you connect IEEE-488 devices to the busLAC/E card is not important. For example, you can connect the injector either before or after the detector.

5. Ensure that all IEEE-488 cable connector screws are fastened finger tight.

2.3.5 Making Device Connections

PCM Connections

The Waters Pump Control Module (PCM) is an IEEE-488 device that controls the 500 Series Pumps. Connect the PCM to the IEEE-488 bus as described in Section 2.3.2. Interface Overview.
TCM Connections

The Waters Temperature Control Module (TCM) is an IEEE-488 device that regulates the temperature of up to three column heaters. Connect the TCM to the IEEE-488 bus as described in Section 2.3.2, Interface Overview.

Pump Connections

If you are using a 2690/2695 Detector, 600 Series Pump (Waters 600E, 616, 625 LC, 626, 650E, ActION Analyzer, Delta Prep 2000, Delta Prep 3000, Delta Prep 4000, and Prep LC 3000), or the LC Module 1plus system, you can connect to the busLAC/E card through the IEEE-488 port or to other IEEE-488 devices in a stacked configuration (see Section 2.3.2, Interface Overview).

**Note:** If you are using a PowerLine™/Gradient version of software on your 600 Series Multisolvend Delivery System or LC Module 1plus system, configure the controller software as a gradient controller through the front panel keypad (not through the Millennium™ software). See the appropriate operator's guide for information on configuring the controller.

Injector Connections

Detectors and system controllers that are not controlled by a Millennium™ system (for example, 2690/2695, 600 Series controller, and GC) require an inject start trigger signal (contact closure) from the injector as each injection occurs. The inject start trigger signal instructs detectors and system controllers to acquire data or run methods.

Waters autosamplers transmit the inject start signal either over the IEEE-488 bus or by trigger wire. If you connect a Waters 2690/2695, 715, 717, 717plus, or an LC Module 1plus to an IEEE-488 interface, you do not need to make any additional connections for an inject start signal.

When under IEEE-488 control, the 2690/2695 Sample Management System, 715 UltraWISP™, 717 and 717plus Autosamplers, and the LC Module 1plus system transmit the inject start signal directly over the IEEE-488 bus during data acquisition. All controlled devices are triggered simultaneously when an injection is made by these instruments. Trigger wires are not required when all instruments in a chromatographic system are controlled over the IEEE-488 bus and the busSAT/IN Module.

**Note:** Any instrument that is not controlled by the Millennium™ software requires an inject start trigger wire connection (see Section 2.4.4, Injectors).
Detector Connections

Detectors with an installed IEEE-488 interface can be connected directly to the busLAC/E card as described in Section 2.3.2, Interface Overview.

Detectors that do not include an IEEE-488 interface must be connected to a busSAT/IN Module for data collection. The busSAT/IN Module then connects to the I/O distribution box or IEEE-488 interface (see Section 2.4.1, I/O Distribution Box).

2.3.6 Setting IEEE-488 Device Addresses

You must set a unique address for each device connected on the IEEE-488 bus so that the busLAC/E card recognizes each device. Valid IEEE-488 instrument addresses are 2 through 29. Set the IEEE-488 addresses of the Waters instruments in your system through either the software or DIP switches (Figure 2-4) as indicated in Table 2-1.

Table 2-1 Setting DIP Switches

<table>
<thead>
<tr>
<th>Instrument</th>
<th>IEEE-488 Address Set By</th>
</tr>
</thead>
<tbody>
<tr>
<td>2487 Detector</td>
<td>Software (front panel of instrument)</td>
</tr>
<tr>
<td>486 Detector</td>
<td>Software (front panel of instrument)</td>
</tr>
<tr>
<td>717 Autosampler</td>
<td>Software (front panel of instrument)</td>
</tr>
<tr>
<td>717 plus Autosampler</td>
<td>Software (front panel of instrument)</td>
</tr>
<tr>
<td>LC Module 1 plus</td>
<td>Software (front panel of instrument)</td>
</tr>
<tr>
<td>600 Series Controller:</td>
<td></td>
</tr>
<tr>
<td>• RW 3D Controller</td>
<td>DIP switches</td>
</tr>
<tr>
<td>• 600E and 650E systems</td>
<td>Software (front panel of instrument)</td>
</tr>
<tr>
<td>(v. 3.0 or later)</td>
<td></td>
</tr>
<tr>
<td>• 616 and 626 systems</td>
<td>Software (front panel of instrument)</td>
</tr>
<tr>
<td>(v. 4.2 or later)</td>
<td></td>
</tr>
<tr>
<td>410, PCM, TCM, 712, 715,</td>
<td>DIP switches (see Table 2-2 or Table 2-3)</td>
</tr>
<tr>
<td>and 996/2996</td>
<td></td>
</tr>
</tbody>
</table>

Figure 2-4 shows the arrangement of DIP switches on a DIP switch block (on the rear panel of a device).
Setting IEEE-488 Addresses Using Software

To set an IEEE-488 address using software, set the address from the front panel of the device.

Note: See the operator’s guide for a particular device for detailed instructions on setting the IEEE-488 address.

Scanning the IEEE-488 Bus

After you set the IEEE-488 address for a device, the busLAC/E card must scan the IEEE-488 bus. To scan the IEEE-488 bus, see “Scanning the busLAC/E Card for Serial Instruments” in the Millennium® Help.

Note: For the LAC/E® Acquisition Server with the Millennium Service, the busLAC/E automatically scans the IEEE-488 bus on startup.

Setting IEEE-488 Addresses Using DIP Switches

To set an IEEE-488 address using DIP switches:

1. Ensure that no instruments are connected to the busLAC/E card.
2. Power off the IEEE-488 device.
3. Using the DIP switches on the rear panel of the device (see Figure 2-4), set a unique IEEE-488 address for the device.

Note: Although there are 28 valid addresses (2 through 29), IEEE-488 protocol allows up to 14 devices.
• To set the IEEE-488 address for a Waters 600 Series Controller, 410 Detector, 996/2996 Detector, PCM, or TCM, see Table 2-2.
• To set the IEEE-488 address for a Waters 715 Injector, see Table 2-3.

4. Power on the device.

Table 2-2 Settings for Waters 600, 410, 996, PCM, and TCM

<table>
<thead>
<tr>
<th>IEEE-488 Address</th>
<th>DIP Switch Settings8</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>3</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>4</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>5</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>6</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>7</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>8</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>9</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>10</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>11</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>12</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>13</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>14</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>15</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
</tr>
<tr>
<td>16</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>17</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>18</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>19</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>20</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>21</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>22</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>23</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>24</td>
<td>OFF</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>25</td>
<td>ON</td>
<td>OFF</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
</tr>
<tr>
<td>26</td>
<td>OFF</td>
<td>ON</td>
<td>OFF</td>
<td>ON</td>
<td>ON</td>
<td>ON</td>
</tr>
</tbody>
</table>
Table 2-2  Settings for Waters 600, 410, 996, PCM, and TCM (Continued)

<table>
<thead>
<tr>
<th>IEEE-488 Address</th>
<th>DIP Switch Settings*</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
</tr>
<tr>
<td>27</td>
<td>ON</td>
</tr>
<tr>
<td>28</td>
<td>OFF</td>
</tr>
<tr>
<td>29</td>
<td>ON</td>
</tr>
</tbody>
</table>

a. ON = Closed or 1. OFF = Open or 0.

Table 2-3  Settings for Waters 715 Injector

<table>
<thead>
<tr>
<th>IEEE-488 Address</th>
<th>DIP Switch Settings*</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>ON</td>
</tr>
<tr>
<td>3</td>
<td>OFF</td>
</tr>
<tr>
<td>4</td>
<td>ON</td>
</tr>
<tr>
<td>5</td>
<td>OFF</td>
</tr>
<tr>
<td>6</td>
<td>ON</td>
</tr>
<tr>
<td>7</td>
<td>OFF</td>
</tr>
<tr>
<td>8</td>
<td>ON</td>
</tr>
<tr>
<td>9</td>
<td>OFF</td>
</tr>
<tr>
<td>10</td>
<td>ON</td>
</tr>
<tr>
<td>11</td>
<td>OFF</td>
</tr>
<tr>
<td>12</td>
<td>ON</td>
</tr>
<tr>
<td>13</td>
<td>OFF</td>
</tr>
<tr>
<td>14</td>
<td>ON</td>
</tr>
<tr>
<td>15</td>
<td>OFF</td>
</tr>
<tr>
<td>16</td>
<td>ON</td>
</tr>
<tr>
<td>17</td>
<td>OFF</td>
</tr>
<tr>
<td>18</td>
<td>ON</td>
</tr>
<tr>
<td>19</td>
<td>OFF</td>
</tr>
<tr>
<td>20</td>
<td>ON</td>
</tr>
<tr>
<td>21</td>
<td>OFF</td>
</tr>
</tbody>
</table>
2.4 Connecting Non-IEEE-488 Chromatographic Devices

Some non-IEEE-488 devices produce analog output signals. A busSAT/IN Module converts the analog output signals to digital signals, then transmits those signals to the busLAC/E card. The busLAC/E card is connected to an I/O distribution box. Supported non-IEEE-488 chromatography devices connect through an I/O distribution box, a PC COM port, or an optional 8-port serial card.

2.4.1 I/O Distribution Box

The I/O distribution box connects to the busLAC/E card (Figure 2-5).

![Figure 2-5 I/O Distribution Box]

Table 2-3 Settings for Waters 715 Injector (Continued)

<table>
<thead>
<tr>
<th>IEEE-488 Address</th>
<th>DIP Switch Settings*</th>
</tr>
</thead>
<tbody>
<tr>
<td>22</td>
<td>ON OFF OFF ON OFF</td>
</tr>
<tr>
<td>23</td>
<td>OFF OFF OFF ON OFF</td>
</tr>
<tr>
<td>24</td>
<td>ON ON ON OFF OFF</td>
</tr>
<tr>
<td>25</td>
<td>OFF ON ON OFF OFF</td>
</tr>
<tr>
<td>26</td>
<td>ON OFF ON OFF OFF</td>
</tr>
<tr>
<td>27</td>
<td>OFF OFF ON OFF OFF</td>
</tr>
<tr>
<td>28</td>
<td>ON ON OFF OFF OFF</td>
</tr>
<tr>
<td>29</td>
<td>OFF ON OFF OFF OFF</td>
</tr>
</tbody>
</table>

a. ON = Closed or 1. OFF = Open or 0.
Non-IEEE-488 chromatography devices communicate with the busLAC/E card through the I/O distribution box over serial cables. The I/O distribution box allows you to connect:

- Up to four non-IEEE-488 devices
- Up to eight non-IEEE-488 detectors using busSAT/IN Modules

Follow the instructions in the *Waters busLAC/E Installation Guide* to unpack and install the I/O distribution box.

The I/O distribution box uses a specific I/O distribution cable to connect to the busLAC/E card (Figure 2-6).

![Figure 2-6: Connecting the I/O Distribution Box to the busLAC/E Card](image)

### 2.4.2 busSAT/IN Module

The busSAT/IN Module (Figure 2-7 and Figure 2-8) converts analog output signals from non-IEEE-488 chromatographic instruments to digital form and transmits those signals to the busLAC/E card. Non-IEEE-488 devices use analog output signals that must be converted to digital signals for use by the Millennium Chromatography Manager.
The busSAT/IN Module communicates with the busLAC/E card through the I/O distribution box (Figure 2-5). The I/O distribution box supports up to four busSAT/IN Modules. Each busSAT/IN Module supports up to two chromatographic detectors. Therefore, the I/O distribution box allows you to connect up to eight non-IEEE-488 detectors using busSAT/IN Modules.
The busSAT/IN Module can be connected to a busLAC/E card, 8-port serial card, or PC COM port (Table 2-4).

**Table 2-4 Non-IEEE Device Connections**

<table>
<thead>
<tr>
<th>Device</th>
<th>busLAC/E Card</th>
<th>8-Port Serial Card</th>
<th>PC COM Port</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAT/IN and busSAT/IN</td>
<td>Yes; split-channel operation is supported</td>
<td>Yes; split-channel operation is not supported</td>
<td>Yes; split-channel operation is not supported</td>
</tr>
<tr>
<td>474 Detector</td>
<td>No</td>
<td>Yes; PC must run Windows NT</td>
<td>Yes; PC must run Windows NT</td>
</tr>
<tr>
<td>5890/7673 GC and Controller</td>
<td>Yes • Requires two serial cables • Dual-tower configuration not supported</td>
<td>Yes • Requires two serial cables • Dual-tower configuration is supported</td>
<td>No</td>
</tr>
<tr>
<td>6890/6890+ GC</td>
<td>No</td>
<td>Yes • Dual-tower configuration is supported • Requires one serial cable</td>
<td>No</td>
</tr>
</tbody>
</table>

**Attention:** Do not power on the busSAT/IN Module until you perform all procedures described in the Waters busSAT/IN Module Installation Guide, or you may damage the unit and void the warranty.

Always disconnect the power cord of the busSAT/IN Module at either the wall outlet or the power supply before attaching or removing the power connection to the busSAT/IN Module. Failure to do so might damage the unit because the busSAT/IN Module does not have an On/Off switch.

To connect the busSAT/IN Module:

1. Follow the instructions in the *Waters busSAT/IN Module Installation Guide* to unpack and install the busSAT/IN Module.
2. Connect other non-IEEE devices, as described in the following sections:
   - **Section 2.4.3, Pumps**
   - **Section 2.4.4, Injectors**
   - **Section 2.4.5, Detectors**
3. To identify the serial instruments you connect to an acquisition server, access the properties of the acquisition server in Configuration Manager, then click the Serial Ports tab (see “Scanning the busLAC/E” in the Millennium32 Help).

2.4.3 Pumps

If you are using a Waters 500 Series pump with the PCM module, use a pump control cable to connect the pump to the PCM. The pump control cable transmits the pump control data to the pump.

Connect the pump control cable to the PUMP A, PUMP B, or PUMP C connector on the PCM and on the pump.

2.4.4 Injectors

Detectors and system controllers within a Millennium32 system require an inject start trigger signal (contact closure) from the injector as each injection occurs. The inject start trigger signal instructs detectors and system controllers to acquire data or run methods.

Autosamplers and manual injectors transmit the inject start signal either over the IEEE-488 bus or by trigger wire.

The following manual injectors and autosamplers require inject start trigger wire connections to external devices:

- U6K manual injector
- External manual injector or non-Waters autosampler
- GC autosampler
- 712 WISP Autosampler

The trigger wire connections for each type of injector appear in Table 2-5.

**Attention:** Be careful to maintain trigger wire polarity (for TTL trigger) between devices to avoid closing the inject start circuit. If you cross the trigger wires, some devices might not receive the inject start signal. When the injector starts the run, some devices might become active but others might not, causing the Millennium32 system to remain in the inject wait state. Also, if you cross the trigger wires, some devices might start when the instruments are set up, before an inject start signal is transmitted.
If you need to trigger multiple instruments with the inject start signal, connect the trigger wire from the injector to the inject start input terminal on each device using one of the following configurations:

- Attach trigger wires from the same terminal on the autosampler to each device.
- If the autosampler has more than one inject start terminal, attach each device to a separate inject start terminal. This eliminates the possibility of closing the inject start circuit.
- Attach the terminal from the autosampler to the inject start terminal on the first device, then jump the inject start terminal from the first device to that of the second device, and so on (stacking the devices).

If you are running the 712, 715 UltraWISP, 717, or 717plus Autosampler in stand-alone mode, connect the trigger wires from the Inject Start terminal on the 712, 715, 717, or 717plus terminal strip to the device terminals in Table 2-5.

If you are using the U6K or other external injector, connect trigger wires from the U6K or external injector (manual or autosampler) to the device connections in Table 2-5. Use either of the chart mark cables on the U6K.

Table 2-5  Autosampler Connections

<table>
<thead>
<tr>
<th>Device</th>
<th>Device Terminals</th>
</tr>
</thead>
<tbody>
<tr>
<td>410, 2410, 2414 Detector</td>
<td>Chart Mark and Dgnd</td>
</tr>
<tr>
<td>484, 486, 2487 Detector</td>
<td>Mark + and –</td>
</tr>
<tr>
<td>2690/2695 Separations Modules, 600 Series Pumps</td>
<td>Inj and Gnd</td>
</tr>
<tr>
<td>busSAT/IN Module</td>
<td>Events In for each channel used (Ch1 and/or Ch2)</td>
</tr>
<tr>
<td>PCM</td>
<td>Inj</td>
</tr>
<tr>
<td>TCM</td>
<td>No trigger wire required</td>
</tr>
</tbody>
</table>

### 2.4.5 Detectors

Detectors with an installed IEEE-488 interface can be connected directly to the busLAC/E card as described in Section 2.3.1, busLAC/E Card Connections.

Connect the non-IEEE-488 detectors to a busSAT/IN Module to control data collection (Table 2-6).
2.4.6 Alliance GPC 2000 Series Systems

The Waters Alliance GPC 2000 and GPCV 2000 Systems are delivered with the Millennium Chromatography Manager already installed on your system.

For detailed instructions, see the following sections in the Waters Alliance GPC 2000 Series System Installation and Maintenance Guide:

- Section 2.4, Making Signal Connections
- Section 2.5, Making I/O Card Connections

To connect the Alliance GPC 2000 Series systems to your facility’s network, open the solvent compartment door, then connect the Ethernet cable to the Ethernet connector (Figure 2-9).

Table 2-6 Detector Connections to busSAT/IN Module

<table>
<thead>
<tr>
<th>Module Terminal</th>
<th>Detector Terminal</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel 1 or Channel 2</td>
<td>490E: Integ and –</td>
</tr>
<tr>
<td>(Second detector connect to Chan 2)</td>
<td>484/486: 1 V/AU + and –</td>
</tr>
<tr>
<td></td>
<td>410: Int+ and Int–</td>
</tr>
</tbody>
</table>
2.4.7 150C plus and 150CV plus Systems

The Waters 150C plus and 150CV plus systems connect to a busSAT/IN Module for data acquisition.

Connect the 150C plus system to the busSAT/IN Module as specified in Table 2-7.

Table 2-7 150C plus Connections to busSAT/IN Module

<table>
<thead>
<tr>
<th>Module Connection</th>
<th>150C plus Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHANNEL 1</td>
<td>INT and GND</td>
</tr>
<tr>
<td>Red wire to Event In CH 1</td>
<td>Red wire to top INJ SW</td>
</tr>
<tr>
<td>(terminal strip position 1)</td>
<td></td>
</tr>
<tr>
<td>Black wire to Event In CH 1</td>
<td>Black wire to bottom INJ SW</td>
</tr>
<tr>
<td>(terminal strip position 2)</td>
<td></td>
</tr>
</tbody>
</table>
Connect the 150CV plus system to the busSA T/IN Module as specified in Table 2-8.

Table 2-8 150CV plus Connections to busSA T/IN Module

<table>
<thead>
<tr>
<th>Module Connection</th>
<th>150CV plus Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel 1</td>
<td>INT and GND</td>
</tr>
<tr>
<td>Channel 2</td>
<td>+2 and GND</td>
</tr>
<tr>
<td>Red wire to Event In CH 1 (terminal strip position 1)</td>
<td>Red wire to top INJ SW</td>
</tr>
<tr>
<td>Black wire to Event In CH 1 (terminal strip position 2)</td>
<td>Black wire to bottom INJ SW</td>
</tr>
<tr>
<td>Connect a wire between terminal strip positions 1 and 5</td>
<td></td>
</tr>
<tr>
<td>Connect a wire between terminal strip positions 2 and 6</td>
<td></td>
</tr>
</tbody>
</table>

2.5 Installing Gas Chromatographs

2.5.1 GC Instrument Control

The following GC instruments can be controlled by the Millennium\textsuperscript{32} software through the serial interface:

- 5890 GC
- 7673 GC Controller or G1512A Controller
- 6890 GC

These instruments constitute a GC system when connected to Millennium\textsuperscript{32} software through one of the following:

- 8-port serial control card
- I/O distribution box (busLAC/E control: 5890/7673 only)
- busSA T/IN Module (no control; data collection only)

*Note:* For specific communications information, see the operator’s guides for the GC instruments.
2.5.2 GC Data Overview

The gas chromatograph (GC) generates both analog and digital data. When controlled through Millennium™ software, the digital data is collected (see Section 2.5.3, Digital Output Configuration). You can also collect the analog data through a SAT/IN module with control of the GC through Millennium™ software (see Section 2.5.4, Analog Output Configuration). In addition, you can configure a system with a 5890 GC and a G1512A Controller emulating a 7673 Controller (see Section 2.5.5, Alternative Setup for a 5890 GC).

2.5.3 Digital Output Configuration

Millennium™ software communicates with the GC through an RS-232 card in the GC. One communication port (busLAC/E for 5890/7673 or 8-port serial card for all supported GCs) both sends control information to the GC and receives data back from the GC.

The following sections describe digital output configurations:

- 5890 GC, 7673 Controller, and busLAC/E Card
- 5890 GC, 7673 Controller, and 8-Port Serial Card
- 6890 GC, G1512A Controller, and 8-Port Serial Card
- 6890 Plus GC and 8-Port Serial Card
5890 GC, 7673 Controller, and busLAC/E Card

You can install a GC system consisting of a 5890 GC and 7673 Controller. Each GC system uses two serial ports on the I/O distribution box (one for each device) to communicate with the busLAC/E card.

To connect the 5890 GC and 7673 Controller to the Millennium\textsuperscript{32} System:

1. Using RS-232 cables, connect each GC device (5890 and 7673) to separate serial ports in the I/O distribution box (Figure 2-10). In this configuration, two 5890/7673 systems can be supported because each GC and each controller occupies its own I/O distribution box port.

![Figure 2-10 Connecting a 5890 GC and 7673 Controller to a busLAC/E Card](image)

Note: Do not allow these leads to come into direct contact with each other.
You can also connect a GC system consisting of a 5890 GC and 7673 Controller through an 8-port serial interface card (Figure 2-11). To connect the 5890 GC and 7673 Controller to the Millennium® System, use RS-232 cables to connect each GC device (5890 and 7673) to separate serial ports on the cables extending from the 8-port serial card. Each serial card cable is labeled with the corresponding port (1 – 8).

When the 5890 and 7673 are controlled through the 8-port serial card, they are referred to as 5890S and 7673S, respectively. The 8-port serial card should be installed starting at COM address 3 on the computer, so physical port 1 on the serial card gives a Millennium® instrument address of 3, port 2 gives 4, and so on.

**Note:** Do not allow these leads to come into direct contact with each other.

Figure 2-11 Connecting a 5890 GC and 7673 Controller to the Serial Card
6890 GC, G1512A Controller, and 8-Port Serial Card

The Millennium$^{32}$ System can communicate with a 6890 GC and a G1512A Controller through the 8-port serial card (Figure 2-12).

To connect the 6890 GC to the Millennium$^{32}$ System, use the RJ45 cable from the 8-port serial card in the LAC/E$^{32}$ Acquisition Server or the Millennium$^{32}$ workstation to connect to the 'modem' port (9-PIN) at the back of the 6890 GC.

Each GC system uses one serial port to both send and receive control data.

Figure 2-12  Connecting a 6890 GC and G1512A Controller to the Serial Card
6890 Plus GC and 8-Port Serial Card

The Millennium\(^{32}\) System can communicate with a 6890 Plus GC through an 8-port serial card.

To connect the 6890 Plus GC to the Millennium\(^{32}\) System, use the RJ45 cable from the 8-port serial card in the LAC/E\(^{32}\) Acquisition Server or the Millennium\(^{32}\) workstation to connect to the ‘modem’ port (9-PIN) at the back of the 6890 GC (Figure 2-13). Each GC system uses one serial port to both send and receive control data.

![Figure 2-13 Connecting a 6890 Plus GC to the Serial Card](image)

2.5.4 Analog Output Configuration

The busSAT/IN Module can be used to convert analog output from the GC detector to digital data for processing by the Millennium\(^{32}\) System. The busSAT/IN Module can reside on the busLAC/E or an 8-port serial card. Figure 2-14 shows a busLAC/E 5890 set up for control through Millennium\(^{32}\) software (digital data) as well as collection of the GC analog data.

The busSAT/IN Module, when used, occupies an additional (third) port on the I/O distribution box. In this configuration, each Millennium\(^{32}\) workstation can support one GC system. As an example, this section describes the 5890/7673 with a SAT/IN through a busLAC/E.

*Note:* A SAT/IN can also be used to collect analog data from a 5890 GC or a 6890 GC configured on an 8-port serial card.
Figure 2-14 shows the cable connections for a 5890 GC and a 7673 Controller with analog data acquisition through a busSAT/IN Module.
Connect inject start trigger cables and analog output cables as follows:

- Connect the inject start trigger cables as indicated in Table 2-9. Both the GC and the busSAT/IN Module require an inject start signal. The controller provides the inject start trigger signal over the remote cable. The GC trigger cable connects to the injector input terminals on the busSAT/IN Module.

- If you are using the analog data output of the GC, connect the analog cables between the GC and the busSAT/IN Module as specified in Table 2-9.

Table 2-9  Analog Data Output Connections

<table>
<thead>
<tr>
<th>busSAT/IN Module Connection</th>
<th>5890 GC</th>
<th>7673 Controller</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAN 1 and COM (–)</td>
<td>Signal 1</td>
<td>N/A</td>
</tr>
<tr>
<td>CHAN 2 and COM (–)</td>
<td>Signal 2 (if optional board is installed)</td>
<td>N/A</td>
</tr>
<tr>
<td>EVENTS CH 1 IN (trigger signal)</td>
<td>REMOTE</td>
<td>Y-cable from REMOTE TTL board</td>
</tr>
</tbody>
</table>

**Note:** The jumper wires shown on the busSAT/IN Module events connector block are required to allow data collection on both analog channels using one trigger input (see Figure 2-10). Connect the black wire on the trigger cable to the positive (+) terminal on the busSAT/IN Module, and connect the red wire to the negative (–) terminal on the busSAT/IN Module.
2.5.5 Alternative Setup for a 5890 GC

To interface a 5890 GC and a G1512A Controller to the Millennium™ system, connect the cables as shown in Figure 2-15. This configuration allows the G1512A Controller to emulate a 7673 Controller.

![Figure 2-15 Connecting a 5890 GC and G1512A Controller](image)

2.6 Installing 1100 Series Instruments

To interface the 1100 Series instruments to the Millennium™ System:

1. Identify the module with the highest data rate to serve as the control module:
   - If your 1100 Series System includes a variable wavelength (VW) or multi-wavelength (MW) detector, use the detector as the controller, and make connections to the detector.
   - If your 1100 Series System does not include a VW or MW detector, the pump acts as the controller, and you make connections to the pump.

2. With the power off, connect the cables as shown in Figure 2-16.

   *Note:* The Equinox card has eight connectors. Write down the number of the connector that you use to connect to the instrument. The connector number is necessary when you configure the acquisition server.
3. Set the baud rate information by changing the DIP switches on the rear of the modules to the following settings:
   Down, Up, Up, Down, Up, Down, Down

   **Note:** You can also set the baud rate information using the Hand-Held Control Module. For each module, select Configure > Serial from the Systems window, then select the following values:

   - **Baud Rate** – 19200
   - **Bits** – 8
   - **Parity** – None

   The new settings take effect when you power on the modules (see Section 2.8, Starting Up the System).

   For more information, see the “Millennium" v. 4.0 Control of 1100 Series Modules” document included with the 1100 Option Kit.
2.7 Installing ZQ Mass Detectors

**Attention:** The ZQ 2000 and ZQ 4000 Mass Detectors require a PCI busLAC/E card; an ISA card is not supported.

You can connect a ZQ 2000 or ZQ 4000 Mass Detector to a stand-alone Millennium\(^{32}\) workstation or an acquisition client (a client connected directly to a chromatographic system(s)). The computer requires two network cards:

- ZQ network card, such as the Intel PRO/100 VM Network Connection, for connecting the ZQ Mass Detector to the computer.
- Network card, such as the Intel PRO/100+ Management Adapter, for connecting to your facility’s network.

If you obtain the computer (workstation or acquisition client) from Waters Corp., the network cards are installed and configured before shipment to you. If you installed your own network cards, use these instructions as a guideline.

**Attention:** The ZQ 2000 and ZQ 4000 Mass Detectors cannot be connected to a LAC/E\(^{32}\) Acquisition Server.

*Note:* Examples in this section reflect the current system configuration. The specific type of network card that is shipped from Waters Corp. is subject to change at any time.

2.7.1 Installing Hardware

To connect a ZQ 2000 or ZQ 4000 Mass Detector to the Millennium\(^{32}\) system:

1. Locate the computer within 16 feet (5 m) of the ZQ Mass Detector.
2. Ensure that the computer has two network cards:
   - ZQ network card
   - Network card for connecting to your facility’s network
3. Connect one end of the network cable to the network port (no label) on the rear panel of the ZQ Mass Detector (**Figure 2-17**).
4. Connect the other end of the network cable to the port labeled ZQ on the rear panel of the workstation.
5. Start up the system (see Section 2.8, Starting Up the System).
6. Do one of the following:
   - If you have Windows NT, continue with Section 2.7.2, Configuring the ZQ Mass Detector in Windows NT.
   - If you have Windows 2000, continue with Section 2.7.3, Configuring the ZQ Mass Detector in Windows 2000.

### 2.7.2 Configuring the ZQ Mass Detector in Windows NT

Use this section to create the Micromass® user account and set the network addresses for Windows NT.

*Note: If you obtain the workstation from Waters Corp., the network cards are configured before shipment to you.*

#### Creating the Micromass User Account

To create the Micromass user account:

1. Select Start > Programs > Administrative Tools > User Manager.
2. At the User Manager window, select User > New User.
3. Clear User must change password at next login, then select User cannot change password and Password never expires.
4. Type Micromass for the user name and analysis for the password.
**Note:** The user name and password entries are case-specific. Enter them exactly as shown above.

5. Click **Groups**.
6. Click **Administrators** on the right side, click **Add**, then click **OK**.
7. At the New User dialog box, click **OK**.
8. Select **User > Exit** to close the User Manager window.

### Setting Network Addresses

To set the network addresses for the network cards:

1. Ensure that the IRQ and addresses for the network cards are appropriate and that other cards (such as a sound card) do not interfere.
2. Select **Start > Settings > Control Panel**, then click **Network**.
3. Ensure that Simple TCP/IP Services is available:
   a. Click the **Services** tab.
   b. At the Network Services list (Figure 2-18), verify that Simple TCP/IP Services is available.
   c. If not, click **Add**.
   d. Select **Simple TCP/IP Services**, then click **OK**. You may need to insert the Windows NT CD in the CD-ROM drive.
4. Ensure that the TCP/IP Protocol is available:
   a. Click the **Protocols** tab.
   b. At the Network Protocols list, verify that the TCP/IP Protocol is available.
   c. If not, click **Add**.
   d. Select **TCP/IP Protocol**, then click **OK**.

---

67  **Installing and Configuring the Hardware**
e. At the Do you wish to use DHCP? message, click No.
f. At the Copy Files message, click Continue.

5. Right-click Network Neighborhood, then select Properties.

6. Set the properties for the network as follows:
   a. At the Network dialog box, click the Protocols tab.
   b. Verify that the TCP/IP Protocol is available (Figure 2-19).

![Figure 2-19 Verifying TCP/IP Protocol](image)

   c. Click the Adapters tab, and verify that two network cards are listed in Network Adapters.

**Example:**
(1) Intel(R) PRO/100 VM Network Connection
(2) Intel(R) PRO/100+ Management Adapter with Alert on LAN

d. If the second network card is not listed, then click Add.
e. Click Have Disk, then insert the network card disk or CD.
f. At the Insert Disk dialog box, enter the path to the drivers, then click OK.
g. At the Network Card dialog box, click OK. The drivers are copied.
h. Click Close.

7. At the Microsoft TCP/IP Properties dialog box (Figure 2-20), select the first adapter:
   (1) Intel(R) PRO/100 VM Network Connection

**Note:** The ZQ instrument is attached to the Ethernet Pro100 VM adapter embedded in the motherboard. A ZQ label appears next to the network connector. The ZQ instrument requires an IP address of 64.1.1.1 for this adapter. Connect the ZQ to the embedded network card whenever possible.
8. Click **Specify an IP address**, then enter the following:
   - **IP Address** – 64.1.1.1
   - **Subnet Mask** – 255.0.0.0
   - **Default Gateway** – (none)

9. Configure the second network adapter for the network in your facility, according to the proper settings defined by your network administrator. Here is an example:
   a. Select the second adapter (Figure 2-21):
      (2) Intel(R) PRO/100+ Management Adapter with Alert on LAN

      **Note:** The Ethernet Pro100+ adapter in slot 2 is for use with your facility’s network. Because the network configuration is unknown (to Waters Corp.), the DHCP protocol is specified in this example. Substitute your facility’s network address (see your network administrator for the correct network address).

   b. If a DHCP server is used for addressing the network, select **DHCP server**.
   c. At the **Enable DHCP** message, click **Yes**, then click **OK**.
d. If static IP addressing is used, click Specify an IP address, enter the IP Address, Subnet Mask and Default Gateway for your network, then click OK (Figure 2-21).

Figure 2-21 Microsoft TCP/IP Properties Dialog Box, Second Adapter

e. At the Restart the Computer message, click Yes.

Attention: You must install Millennium™ software before you perform the procedure in the next section, “Configuring Microsoft Peer Web Server.” Continue with the appropriate section for your system:

Section 3.2, Installing the Millennium™ Software for a stand-alone workstation

Section 5.3, Installing the Client Software for a client

Configuring Microsoft Peer Web Server

To configure Microsoft Peer Web Server:

1. Click the Services tab in Network Properties.
2. At the Services list, verify that the Microsoft Peer Web Server is available.
3. If not, click Add.
4. Select **Microsoft Peer Web Server**, then click **OK**. You may need to insert the Windows NT CD in the CD-ROM drive. The Microsoft Peer Web Services Setup wizard starts.

5. At the **Welcome** message, click **OK**.

6. At the Setup Options page, select **Internet Service Manager** and **FTP Service** *(Figure 2-22)*. Clear the other options, then click **OK**.

   **Note:** It is important to select only the two options listed above.

   Figure 2-22  Setup Options Page for Peer Web Services

7. At the **Directory** message, click **Yes**.

   **Note:** The Millennium$^32$ software must be installed or the millennium\zq directory will not be available.

8. Click **Browse** and find the millennium\zq directory, then click **OK**.

9. At the **Complete Success** message, click **OK**.

10. At the Network Properties dialog box, click **Close**.

---

71  **Installing and Configuring the Hardware**
Configuring FTP Service Properties

To configure FTP service properties:

1. Select Start > Programs > Microsoft Peer Web Services (Common) > Internet Service Manager.
2. Right-click the name of the workstation that has the FTP service, then select Service Properties.
3. At the Service tab of the FTP Service Properties dialog box (Figure 2-23), clear Allow only anonymous connections.
4. Click OK to close the FTP Service Properties dialog box.
5. Select Properties > Exit to close Internet Service Manager.
6. Continue with Section 2.7.4, Testing the Network Connection.
2.7.3 Configuring the ZQ Mass Detector in Windows 2000

Use this section to create the Micromass user account, configure the ZQ network, enter TCP/IP settings for the workstation network connection, install Internet Information Services (IIS), and set IIS properties for FTP Service and default FTP site properties for Windows 2000.

*Note:* If you obtain the workstation from Waters Corp., the network cards are configured before shipment to you.

**Creating the Micromass User Account**

To create the Micromass user account:

1. Right-click the My Computer icon and select Manage.
2. Click the + in front of Local Users and Groups, then click Users.
3. Select Action > New User (Figure 2-24).

![Creating a New User](image)

Figure 2-24 Creating a New User

4. At the New User dialog box (Figure 2-25), do the following:
   - Type Micromass (as shown) in the User name field.
   - Type analysis (lowercase) in the Password field.
   - Clear the User must change password on next logon check box.
5. Click **Create**.

6. Click **Close** to close the New User dialog box.

7. At the Computer Management window, double-click the newly created **Micromass** account.

8. Click the **Member Of** tab, then click **Add**.

9. Select **Administrators**, click **Add**, then click **OK**.

10. Verify that **Administrators** appears in the Member Of box, then click **OK** to close the Properties dialog box.


### Configuring the ZQ Network

To configure the ZQ network:

1. Right-click the **My Network Places** icon and select **Properties**.

2. At the Network and Dial-up Connections dialog box, right-click **Local Area Connection**, then select **Properties**. The Local Area Connection Properties dialog box appears (Figure 2-26).
3. Verify that **NetBEUI Protocol** is installed. If not:
   a. Click **Install > Protocol > Add**.
   b. Click **Microsoft > NetBEUI Protocol > OK**.

4. Verify that **Internet Protocol (TCP/IP)** is installed. If not:
   a. Click **Install > Protocol > Add**.
   b. Click **Microsoft > Internet Protocol (TCP/IP)**, then click **OK**.

5. Set the Internet Protocol properties:
   a. Click **Internet Protocol (TCP/IP) > Properties**.
   b. Click **Use the following IP address**: then set the IP address and Subnet Mask as follows:
      - **IP Address**: 64.1.1.1
      - **Subnet Mask**: 255.0.0.0

6. Click **OK** to close the Internet Protocol (TCP/IP) Properties dialog box.

7. At the Local Area Connection Properties dialog box, click **Configure**.

8. At the General tab, verify that **This device is working properly**.

9. At the Power Management tab, clear both **Allow this device to bring this computer out of standby**, and **Allow the computer to turn off this device to save power** (Figure 2-27).
10. Click **OK** to close the PCI Adapter Properties dialog box.
11. Click **OK** to close the Local Area Connection Properties window.

### Entering TCP/IP Settings

To enter TCP/IP settings for the workstation network connection:

1. Double-click **Local Area Connection 2** to open the Properties dialog box.
2. Click **Internet Protocol (TCP/IP) > Properties**. If a DHCP server is being used for addressing, then select **Obtain an IP Address automatically**. If not, enter the workstation’s static IP address and subnet mask.
3. Click **OK** to close the Internet Protocol TCP/IP Properties dialog box. The Local Area Connection Properties page appears.
4. At the Local Area Connection 2 Properties page, click **Configure**.
5. At the General tab, verify that **This device is working properly**.
6. At the Power Management tab, clear both **Allow this device to bring this computer out of standby** and **Allow the computer to turn off this device to save power**.
7. Click **OK** to close the Adapter Properties dialog box.
8. Click **OK** to close the Local Area Connection Properties page.
9. If a message asks if you want to restart your computer now, click **Yes**.
10. Select **File > Close** to exit the Network and Dial-up Connections dialog box.

**Installing Internet Information Services**

To install Internet Information Services (IIS):

1. Select **Start > Settings > Control Panel > Add/Remove Programs**.
2. Click **Add/Remove Windows Components** on the left side. (Figure 2-28).

![Add/Remove Programs Window](image)

*Figure 2-28  Add/Remove Programs Window*

3. Select **Internet Information Services (IIS)**, then click **Next** (Figure 2-29).

    *Note*: Verify that the Networking Services check box is selected.
5. Insert the Windows 2000 CD if requested. Files are copied for several minutes.
7. Select File > Close to close Control Panel.

STOP

Attention: You must install Millennium™ software before you perform the procedure in the next section, “Setting Default FTP Site Properties.”

Continue with the appropriate section for your system:
Section 3.2, Installing the Millennium™ Software for a stand-alone workstation
Section 5.3, Installing the Client Software for a client

Setting Default FTP Site Properties

To set the default FTP site properties:

1. Right-click the My Computer icon, and select Manage.
2. Click Services and Applications.
3. Click Internet Information Services.
4. Right-click Default FTP Site, then select Properties.
5. At the Security Accounts tab, under Allow Anonymous Connections, ensure that the Allow only anonymous connections check box is clear, then click OK (Figure 2-30).
6. Click the **Home Directory** tab.

   *Note: The Millennium software must be installed or the millennium\zq directory will not be available.*

7. Click **Browse**, and find the millennium\zq directory.

8. Click **OK** to close the Browse folder.

9. At the Home Directory tab, ensure that the Local Path is `drive letter:\millennium\zq`. Ensure that Read and Write are selected. Clear Log visits (Figure 2-31).
10. Click OK to save the changes, then close the Computer Management window.
11. Restart the PC.
12. Continue with Section 2.7.4, Testing the Network Connection.

2.7.4 Testing the Network Connection

To verify the network connection, use the Ping command as follows:

1. Open a Command Prompt window.
2. Type ping 64.1.1.2, then press Enter.
3. The following indicates a successful ping:

Pinging 64.1.1.2 with 32 bytes of data:

Reply from 64.1.1.2: bytes=32 time <10ms TTL=128
Reply from 64.1.1.2: bytes=32 time <10ms TTL=128
Reply from 64.1.1.2: bytes=32 time <10ms TTL=128

Note: This is the ZQ instrument IP address. Success indicates that the network adapter is functioning, the network cable is good, and hardware communication between the ZQ Detector and the workstation is successful.
The following indicates an unsuccessful ping:

Pinging 64.1.1.2 with 32 bytes of data:
Request timed out
Request timed out
Request timed out

2.8 Starting Up the System

This section contains the startup sequence for the Millennium\textsuperscript{32} Chromatography System and its peripheral equipment.

\textbf{Note:} For information on starting up the Millennium\textsuperscript{32} Client/Server System, see the Millennium\textsuperscript{32} Client/Server System Administrator's Guide.

\textbf{Attention:} Ensure that the computer power supply is set correctly for your site. If it is set incorrectly, your computer may be damaged.

For proper operation of the Millennium\textsuperscript{32} System, power on equipment as follows:

1. Power on all equipment that is controlled through the IEEE-488 bus. Wait until any internal diagnostic tests finish.

   \textbf{Note:} You cannot run methods or method sets, or use Run Samples, unless all devices on the IEEE-488 bus that are assigned to a system on the Millennium\textsuperscript{32} System are powered up and have passed any calibration tests.

   \textbf{Note:} Do not power on or off any instruments connected to a bus running any systems. Power on the pumps of an LC system first to establish a flow before powering up the detectors. Also, ensure that the carrier gas is flowing before powering up GC instruments.

2. Power on all equipment controlled by the Millennium\textsuperscript{32} System that is not under IEEE-488 control, that is, all equipment controlled through the I/O distribution box (busSAT/IN Modules, connected analog detectors, and GC instruments).

3. Power on all equipment not controlled by the Millennium\textsuperscript{32} System (for example, computer peripherals such as printers).

4. Power on the computers.
Chapter 3
Installing a Stand-Alone Workstation

Use this chapter to install the Millennium\textsuperscript{32} Chromatography Manager software v. 4.0 on a stand-alone workstation.

\textbf{Attention:} Before installing any hardware or software, perform a full backup of your hard drives (see the instructions provided by the manufacturer of your computer).

\subsection*{3.1 Requirements}

Before you begin the installation:

1. Ensure that the workstation has the required hardware and software (Table 1-1).
2. Log in to an account with administrator privileges.
3. Back up and defragment your hard drive (see the Microsoft documentation and Help system) to ensure smooth installation of and optimum performance from the Millennium\textsuperscript{32} software.
4. Close all applications, then restart the workstation.
5. Verify that your disk drive has enough disk space to install the Millennium\textsuperscript{32} software (Table 3-1). The software can be installed on one or more drives.

\textbf{Note:} The default database numbers are set high so that users with large databases can upgrade easily using the Millennium\textsuperscript{32} Setup wizard. If your disk space is restricted, you can lower the maximum sizes. Especially in the case of minimum disk sizes, check the disk space usage occasionally.

The minimum total disk size is 4.0 GB for a stand-alone workstation running Windows 2000 with Service Pack 2, Internet Explorer 5.5 with Service Pack 1, and Millennium\textsuperscript{32} v. 4.00 (Stand-alone) software.
3.2 Installing the Millennium\textsuperscript{32} Software

The Millennium\textsuperscript{32} Chromatography Manager software is installed from the Millennium\textsuperscript{32} CD. You can perform a typical installation to install the software on the C: drive or default location, or a custom installation to specify the drives. Allow approximately 30 minutes to install the software.

\textbf{Attention:} If you are performing an upgrade, do not continue with this procedure. See the Millennium\textsuperscript{32} System Upgrade and Configuration Guide for upgrade procedures.

### 3.2.1 Starting the Installation

To install the Millennium\textsuperscript{32} software:

1. Insert the Millennium\textsuperscript{32} CD into the CD-ROM drive. Allow approximately 30 seconds for the Setup wizard to load. The splash screen appears momentarily.
2. At the Welcome page of the Millennium\textsuperscript{32} Setup wizard (Figure 3-1), click Next.

\textbf{Note:} If the setup procedure does not start automatically, select Start > Run. Enter the CD drive letter, then type :\setup.exe and press Enter.

---

Table 3-1 Minimum Disk Space Requirements

<table>
<thead>
<tr>
<th>Purpose</th>
<th>Minimum Free Space</th>
<th>Drive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temporary Install Files</td>
<td>200 MB</td>
<td>System-drive</td>
</tr>
<tr>
<td>Permanent Oracle Files</td>
<td>15 MB</td>
<td>System-drive</td>
</tr>
<tr>
<td>Millennium\textsuperscript{32} Program Files</td>
<td>750 MB</td>
<td>Program-drive</td>
</tr>
<tr>
<td>Millennium\textsuperscript{32} Raw Data Files</td>
<td>200 MB</td>
<td>RawData-drive</td>
</tr>
<tr>
<td>Millennium\textsuperscript{32} Database</td>
<td>250 MB</td>
<td>Database-drive</td>
</tr>
</tbody>
</table>
3. At the License Agreement page, read the agreement, then click Yes to accept the agreement.

4. At the Information page, read the Read Me First text, then click Next.

5. At the Installation Type page (Typical or Custom), do one of the following:
   - Click Typical if you want to install the Millennium32 software on the default drive.
   - Click Custom if you want to install the Millennium32 software on different drives.

6. At the Minimum System Requirements message, ensure that your system’s specifications match or exceed the requirements, then click OK.

7. **For Windows NT only:** At the Install Common System DLLs dialog box (Figure 3-2), click Yes to install all common system files (recommended).
8. At the Product Support Registration page of the Millennium™ Setup wizard (Figure 3-3), enter your name in the User Name text box, your company name in the Company Name text box, and the plan ID number (on the Total Assurance Plan) in the Serial Number text box, then click Next.

**Note:** If you want to install only some common system files, click No. The Upgrade Common System DLLs dialog box appears. Click Yes to upgrade only older system DLLs to newer versions.
9. At the Registration Confirmation dialog box, if the information is correct, click Yes.

10. At the BusLAC/E Driver Installation page (Figure 3-4), select the BusLAC/E driver that corresponds to your busLAC/E, then click Next.

![BusLAC/E Driver Installation Page](image)

11. At the Re-Ask BusLAC/E Driver Installation dialog box, if the selected busLAC/E is correct, click Yes.

12. At the Add ZQ Option dialog box, do one of the following:
   - If your system does not include a ZQ 2000 or ZQ 4000 Mass Detector, click No.
   - If your system includes a ZQ 2000 or ZQ 4000 Mass Detector, click Yes. At the ZQ Installation dialog box, select ZQ2000 or ZQ4000, then click Next.

13. At the Add Desktop Shortcut dialog box, do one of the following:
   - If you want to add a Millennium³² shortcut to your desktop, click Yes.
   - If not, click No.

   *Note: If you are performing a custom installation, continue with Section 3.2.2, Finishing a Custom Installation.*
14. At the Import a Millennium Database dialog box (Figure 3-5), click No to install a new database.

**Note:** If you click Yes, the workstation searches for an existing database on the local and mapped drives.

![Figure 3-5 Import a Millennium Database Dialog Box](image)

15. The Millennium 32 Setup installs the Millennium 32 and Oracle program files on the hard drive. When the Installation is Complete page appears (Figure 3-6), click Yes, I want to restart my computer now, then click Finish.

![Figure 3-6 Installation is Complete Page](image)

**Note:** If you get messages that at least one event or driver could not be found, close them. The event viewer message "The description of event (21) in source (Buslace) could not be found." is generated by Windows NT with the PCI busLAC/E drivers, and the PCI busLAC/E drivers are not affected.

16. Continue with Section 3.2.3, Installing the Millennium 32 Workstation License.
3.2.2 Finishing a Custom Installation

To finish a custom installation (if you selected Custom in step 5 of Section 3.2.1, Starting the Installation):

1. At the Program Directory page (Figure 3-7), select the drive on which to install the Millennium™ program files, then click Next.

![Program Directory Page](image)

Figure 3-7  Program Directory Page
2. At the Data Directory page (Figure 3-8), select the drive on which to install the data files, then click Next.

![Figure 3-8 Data Directory Page]

3. At the Database Directory page (Figure 3-9), select the drive on which to install the database files, then click Next.

![Figure 3-9 Database Directory Page]
4. At the Import a Millennium Database dialog box (Figure 3-10), click No to install a new database.

*Note:* If you select Yes, the workstation searches for an existing database on the local and mapped drives.

![Figure 3-10 Import a Millennium Database Dialog Box](image)

5. The Millennium\textsuperscript{32} Setup installs the Millennium\textsuperscript{32} and Oracle program files on the hard drive.

6. At the Installation is Complete page, click Yes, I want to restart my computer now, then click Finish.

### 3.2.3 Installing the Millennium\textsuperscript{32} Workstation License

To install the Millennium\textsuperscript{32} Workstation License on a workstation:

1. Log in to the workstation.
2. Insert the 3.5-inch Millennium\textsuperscript{32} Workstation key disk into the disk drive.

**Attention:** Do not write protect key disks.

**STOP**

*Do not uninstall the Millennium\textsuperscript{32} software until you uninstall the options, or the options become unusable.*

4. At the Run dialog box, type the disk drive letter, followed by :\textasciitilde\textit{Setup.exe}, then click OK.
5. At the Millennium\textsuperscript{32} Option Setup dialog box (Figure 3-11), click OK to install the Millennium\textsuperscript{32} Workstation License.

\textit{Note:} Allow several minutes for the Millennium\textsuperscript{32} Option Setup dialog box to appear while the Millennium\textsuperscript{32} Key disk is being read onto your hard disk.

![Figure 3-11 Millennium\textsuperscript{32} Option Setup Dialog Box](image)

6. When installation is complete, the Millennium\textsuperscript{32} Option message box appears. Click OK to close the message box.

\textit{Note:} The possible maximum size of the database files (from the default settings for tablespaces) may exceed the capacity of a 4 GB disk drive. Review the size of the hard drive and compare those values to the maximum size as displayed in Database Properties in the Configuration Manager. Monitor the amount of space being used by the database on a regular basis. See the Millennium\textsuperscript{32} Help to modify tablespace values for the database.

3.2.4 Verifying Installed Files

The Millennium\textsuperscript{32} Setup creates a Millennium\textsuperscript{32} program folder in the Start menu Programs folder. The Millennium\textsuperscript{32} program folder contains the following program items:

- \textbf{Oracle} – Contains Oracle Net8 Configuration Assistant.
- \textbf{File Verification Results} – Contains a log of the file verification process results.
- \textbf{Installation Log} – Contains information about the current installation.
- \textbf{Millennium\textsuperscript{32} Help} – Opens the \textit{Millennium\textsuperscript{32} Help}.
- \textbf{Millennium\textsuperscript{32} Login} – Starts the Millennium\textsuperscript{32} software and displays the Millennium\textsuperscript{32} Login dialog box. After you log in, the program allows you to select one of six Millennium\textsuperscript{32} applications. For details, refer to the Login topic in the \textit{Millennium\textsuperscript{32} Help}.
- \textbf{ReadMe!} – Contains up-to-date information about the current release of the Millennium\textsuperscript{32} software (can be viewed at the beginning of the installation process).
- **Register Acquisition Server Printers** – Registers printers for Millennium\(^{32}\) run and process mode or run and report mode.

- **Verify Files** – Verifies the integrity of the Millennium\(^{32}\) software files on your hard disk.

**Viewing the Read Me Text**

The Read Me entry in the Millennium\(^{32}\) Program folder includes information related to the current release of the Millennium\(^{32}\) software.

To view the Read Me file:

1. Select **Start > Programs > Millennium\(^{32}\) > ReadMe!**.
2. Review the contents of the file. You can print a copy by selecting **File > Print**.
3. Select **File > Exit**.

**Viewing the Installation Log**

The Installation Log contains information about your Millennium\(^{32}\) installations. You can read the log file to review your installation choices. In case of a partial or unsuccessful installation, you can review the Install Log to check for errors.

To view the Installation Log:

1. Select **Start > Programs > Millennium\(^{32}\) > Installation Log**. The program displays the Milenium32.log file in Notepad.
2. Review the contents of the Installation Log file. The most recent installation is at the end of the file.
3. Select **File > Exit**.

**Using the File Verification Utility**

The File Verification utility checks the integrity of the installed Millennium\(^{32}\) program, data files, and database files. After installation, use the File Verification utility to verify the Millennium\(^{32}\) program and data files only (not the database files):

- As part of your installation qualification if you purchased the Millennium\(^{32}\) Qualification option
- To ensure that the Millennium\(^{32}\) files have not changed since installation

To run the File Verification utility:

1. Select **Start > Programs > Millennium\(^{32}\) > Verify Files**.
2. The File Verification utility compares the installed Millennium\(^{32}\) files checksum with a previously stored checksum number, creates a File Verification Results log, and opens the Checksum.txt file in a WordPad window.
Note: If the file does not appear, select Start > Programs > Millennium\textsuperscript{32} > File Verification Results. If a message states that the file is too large for Notepad and asks if you want to use WordPad to view the file, select Yes. The WordPad window appears with the File Verification Results text.

3. Review the contents of the file. You can print a copy by selecting File > Print.
4. Select File > Exit.

### 3.3 Installing Millennium\textsuperscript{32} Options

Before you install Millennium\textsuperscript{32} options, ensure that Millennium\textsuperscript{32} software is installed (see Section 3.2, Installing the Millennium\textsuperscript{32} Software).

#### 3.3.1 About Millennium\textsuperscript{32} Options on Key Disks

Millennium\textsuperscript{32} software options are installed from 3.5-inch key disks onto the workstation where the Millennium\textsuperscript{32} software resides. A separate CD contains the option sample project files, which you need to restore after installing the options.

Ensure that key disks and CD(s) are stored in an accessible but secure location. Key disks are required for installation, uninstallation, and reinstallation of the Millennium\textsuperscript{32} options on the workstations. If you need to transfer an option from one computer to another, you must place the appropriate key disk(s) in the originating computer during software removal, then in the recipient computer during software installation.

In a stand-alone configuration, you can install a Millennium\textsuperscript{32} software option on only one workstation per license. If you remove an option from one stand-alone workstation using the original disk, you can install it on another.

**Attention:** Do not write protect disks.

The option disks become unusable unless you uninstall the options before uninstalling the Millennium\textsuperscript{32} software.

**Note:** You cannot install an option intended for a client/server system on a stand-alone workstation, nor can you install an option intended for a stand-alone workstation on a client/server system.

Once you have installed an option using the procedures in this section, the option is enabled for all projects. You may disable the option for specific projects (see “Configuring Millennium\textsuperscript{32} Software Options” in the Millennium\textsuperscript{32} Help).
3.3.2 Installing Millennium\textsuperscript{32} Options

\textbf{Note}: If you previously created an alias to a client/server server from a stand-alone workstation, then deleted the alias, when you subsequently go to install an option disk on the local workstation, the drop-down list will be empty (when it used to say local). Click \textbf{OK} to install the option, and it will be installed successfully. If you keep the default installation, the dialog box will say local. This is due to the fact that when you delete the last alias, Oracle deletes the tnsnames.ora file.

To install the Millennium\textsuperscript{32} options:

1. Insert the Millennium\textsuperscript{32} Option key disk into the disk drive.
2. Select \textbf{Start} > \textbf{Run}.
3. At the Run dialog box, type the disk drive letter, followed by :\textbackslash Setup.exe, then click \textbf{OK}.
4. After a few minutes, the Millennium\textsuperscript{32} Option Setup dialog box appears. Ensure that the name of the option that is being installed is correct, then click \textbf{OK}.
5. Do one of the following:
   - If the option was not previously installed, a Millennium\textsuperscript{32} Option message box appears after successful installation. Click \textbf{OK} to close the message box.
   - If the option is already installed on your workstation, a Millennium\textsuperscript{32} Option message box appears. Click \textbf{Cancel} to close the message box.
   - If the option is already installed on a different workstation, a Setup message box appears. Click \textbf{OK} to close the message box. To remove the option from a workstation, continue with Section 3.3.3, Uninstalling Millennium\textsuperscript{32} Options.
6. Repeat steps 1 through 5 for each option.

3.3.3 Uninstalling Millennium\textsuperscript{32} Options

If an option is currently installed on a different workstation and you want to transfer the option to this workstation, you must first uninstall the option from its current workstation using the appropriate option key disk.

\textbf{Attention}: \textit{Do not write protect key disks.}
\textit{Do not uninstall the Millennium\textsuperscript{32} software until you uninstall the options, or the options become unusable.}

To uninstall an option:

1. Insert the appropriate Millennium\textsuperscript{32} Option key disk into the disk drive of the workstation that currently has the option.
2. Select \textbf{Start} > \textbf{Run}. 
3. At the Run dialog box, type the disk drive letter, followed by `\Setup.exe`, then click OK.
4. At the Millennium Option Setup dialog box, click OK.
5. At the Option Already Installed message box, click OK.
6. At the Setup message box, click OK to close the message box, then remove the key disk.
7. Continue with Section 3.3.2, Installing Millennium\textsuperscript{32} Options.

### 3.3.4 Restoring an Option Sample Project

To restore an option sample project from the Millennium\textsuperscript{32} CD, see “Restoring a Project Using the Wizard” in the Millennium\textsuperscript{32} Help. You can use the option sample project files as a template.

This completes the Millennium\textsuperscript{32} software installation procedure for a stand-alone workstation.
Chapter 4
Installing a Client/Server or Primary PowerStation

Use this chapter to install the Millennium\textsuperscript{32} Chromatography Manager software v. 4.0 on the server in a Millennium\textsuperscript{32} Client/Server System or on a primary PowerStation.

The Waters CDs contain Oracle\textsuperscript{®} software (Oracle8i\textsuperscript{™}, release 3, v. 8.1.7) and Millennium\textsuperscript{32} software (v. 4.0). You have the following installation options:

- If you want to install Oracle software and Millennium\textsuperscript{32} software without changing the default settings, perform the procedures in this chapter.
- If you want to specify some or all settings for Oracle software or Millennium\textsuperscript{32} software, see Appendix A, Installing Custom Oracle Software, and Appendix B, Building a Custom Millennium\textsuperscript{32} Database.

\textbf{Attention:} Before installing any hardware or software, perform a full backup of your hard drives (see the instructions provided by the manufacturer of your computer).

4.1 Server Planning

4.1.1 Overview

The database server runs two applications:

- **Millennium Server** – Responsible for writing raw data files from acquisition servers, copying raw data from project to project (through the Millennium\textsuperscript{32} application), and creating new projects.

- **Oracle Database** – Stores methods, audit trails, and specific raw data files parameters (the data points are stored as external files controlled by Millennium Service). During the server installation, you will be asked a number of questions related to overall sizing information and where to install the various components.
Millennium version 4.00 can install Oracle during the typical Millennium\textsuperscript{32} installation. If you plan to use Oracle tools that are not part of a typical installation (for example, Enterprise Manager), see Appendix A, Installing Custom Oracle Software, to install Oracle before running the Millennium\textsuperscript{32} installation.

The Millennium\textsuperscript{32} Server installation program reads the amount of memory that your system contains, then configures the Oracle initialization parameters based on three sizes (Table 4-1).

Table 4-1 Oracle Initialization Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>256 to 511 MB</th>
<th>512 to 1023 MB</th>
<th>More Than 1 GB</th>
</tr>
</thead>
<tbody>
<tr>
<td>db_block_size</td>
<td>4096</td>
<td>8192</td>
<td>8192</td>
</tr>
<tr>
<td>db_block_buffers</td>
<td>12000</td>
<td>12000</td>
<td>24000</td>
</tr>
<tr>
<td>db_file_multiblock_read_count</td>
<td>16</td>
<td>8</td>
<td>8</td>
</tr>
<tr>
<td>shared_pool_size</td>
<td>8000000</td>
<td>12000000</td>
<td>16000000</td>
</tr>
<tr>
<td>dml_locks</td>
<td>100</td>
<td>200</td>
<td>500</td>
</tr>
<tr>
<td>sort_area_size</td>
<td>256000</td>
<td>512000</td>
<td>1024000</td>
</tr>
</tbody>
</table>

The installation program assumes that the server will be exclusively used as the Millennium\textsuperscript{32} database server. If other applications will be running on the server, adjust the initialization parameters accordingly.

### 4.1.2 Memory Considerations

The server in a client/server system or primary PowerStation requires sufficient memory for Oracle8i and Millennium\textsuperscript{32} software to operate. The amount of required memory depends on the number of applications, users, and the operating system. The largest quantity of memory is used by Oracle. When Oracle initializes, it creates a space in memory for most of the Oracle functions, called the SGA (for more information about the SGA, refer to Oracle documentation or your database administrator). The server must have adequate memory, and the memory must be configured correctly. The amount of required memory depends on the number of client and LAC/E\textsuperscript{32} computers, users, chromatograms per project, and number of integrated peaks per channel.
4.1.3 Disk Space Considerations

Each PowerStation (Table 1-2) or client/server system (Table 1-3) requires sufficient disk space for Oracle8i (database) and Millennium\textsuperscript{32} software (Table 4-2).

Table 4-2 Minimum Disk Space Requirements

<table>
<thead>
<tr>
<th>Purpose</th>
<th>Minimum Free Space</th>
<th>Drive</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temporary Install Files</td>
<td>200 MB</td>
<td>System-drive</td>
</tr>
<tr>
<td>Permanent Oracle Files</td>
<td>15 MB</td>
<td>System-drive</td>
</tr>
<tr>
<td>Millennium\textsuperscript{32} Program Files</td>
<td>750 MB\textsuperscript{a}</td>
<td>Program-drive</td>
</tr>
<tr>
<td>Millennium\textsuperscript{32} Raw Data Files</td>
<td>200 MB</td>
<td>RawData-drive</td>
</tr>
<tr>
<td>Millennium\textsuperscript{32} Database</td>
<td>1.3 GB\textsuperscript{b}</td>
<td>Database-drive</td>
</tr>
</tbody>
</table>

\textsuperscript{a} If you use the Waters CD to install Oracle, 750 MB are required. If your server already has Oracle, 125 MB are required.

\textsuperscript{b} This assumes 20 users and a small database.

The various software components should be installed on multiple drives to maximize performance and the ability to recover from disk failures. Table 4-2 contains the minimum requirements at installation. However, you must also account for additional disk space when the system is operational.

The following considerations should be made when sizing drives for future use.

**Millennium\textsuperscript{32} Program Files**

- **Millennium and Oracle application files** – Fixed size at installation; approximately 750 MB.
- **Archive log files** – 10 MB each; based on the number of database changes (new chromatograms, results, calibration curves, methods or changes to existing methods). The number of archive log files maintained on the server depends on how often a database is backed up and the overall activity.

**Millennium\textsuperscript{32} Raw Data Files**

- **Default project raw data files** – Fixed size at installation; approximately 200 MB.
- **Chromatography raw data files** – Variable; based approximately on sample rate times run time times number of samples. PDA and MS files are bigger because wavelength/mass range must be included. The total space requirement is based on how often you archive and how many systems are creating raw data files.
Millennium³² Database

Initial database datafile sizes are based on two parameters that you choose during installation:

- **Database size** – Small, medium, or large
- **Number of expected users** – Fixed size at installation

The database datafiles are configured to autoextend. As projects, raw data files, and results are created, the initial database datafile must autoextend to store all information. Use Table 4-3 through Table 4-5 to calculate the approximate database size. These tables list the space that is required for each database datafile to increment. The database datafile will autoextend by the value in the **Next** column, up to the value in the **Max** column.

Table 4-3 Small Server Database

<table>
<thead>
<tr>
<th>Database Datafile</th>
<th>Initial (MB)</th>
<th>Next (MB)</th>
<th>Max (MB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>200</td>
<td>200</td>
<td>600</td>
</tr>
<tr>
<td>User</td>
<td>500</td>
<td>500</td>
<td>2000</td>
</tr>
<tr>
<td>Temp</td>
<td>100</td>
<td>100</td>
<td>500</td>
</tr>
<tr>
<td>Index</td>
<td>250</td>
<td>250</td>
<td>1000</td>
</tr>
</tbody>
</table>

Table 4-4 Medium Server Database

<table>
<thead>
<tr>
<th>Database Datafile</th>
<th>Initial (MB)</th>
<th>Next (MB)</th>
<th>Max (MB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>200</td>
<td>200</td>
<td>800</td>
</tr>
<tr>
<td>User</td>
<td>800</td>
<td>800</td>
<td>3200</td>
</tr>
<tr>
<td>Temp</td>
<td>200</td>
<td>200</td>
<td>600</td>
</tr>
<tr>
<td>Index</td>
<td>400</td>
<td>400</td>
<td>1600</td>
</tr>
</tbody>
</table>
Most information stored in the database consists of results. The actual tablespace used for each result is based on the number of integrated peaks (named or unknowns). Additional space is required when the suitability or pattern match option is enabled, or the data is from a 3D detector and additional processing is requested (for example, a PDA channel with multi-pass purity enabled).

If you have any questions on these recommendations, consult your Waters data specialist.

### 4.2 Installing the Millennium$^{32}$ Software

**Attention:** If you are performing an upgrade, do not continue with this procedure. See the Millennium$^{32}$ System Upgrade and Configuration Guide for upgrade procedures.

Waters supplies Oracle software and Millennium$^{32}$ v. 4.0 software on CDs. Procedures in this chapter assume that you want to install Oracle automatically using default settings. Allow approximately 30 minutes to install the software.

As alternatives, you can do either or both of the following:

- If you want to install additional Oracle management tools or specify some settings, see Appendix A, Installing Custom Oracle Software.
- If you want to specify some or all settings for the Millennium$^{32}$ database, see Appendix B, Building a Custom Millennium$^{32}$ Database.

<table>
<thead>
<tr>
<th>Database Datafile</th>
<th>Initial (MB)</th>
<th>Next (MB)</th>
<th>Max (MB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>400</td>
<td>400</td>
<td>1200</td>
</tr>
<tr>
<td>User</td>
<td>1000</td>
<td>1000</td>
<td>4000</td>
</tr>
<tr>
<td>Temp</td>
<td>200</td>
<td>200</td>
<td>800</td>
</tr>
<tr>
<td>Index</td>
<td>500</td>
<td>500</td>
<td>2000</td>
</tr>
</tbody>
</table>

Table 4-5  Large Server Database
4.2.1 Starting the Installation

To start the installation using the wizard:

1. Insert the Millennium CD into the CD-ROM drive. The splash screen appears momentarily, then Figure 4-1 appears.

2. Click Next.
3. At the License Agreement page, read the agreement, then click Yes to accept the agreement.
4. At the Information page, read the Read Me First text, then click Next.
5. **For Windows NT only:** At the Install Common System DLLs dialog box (Figure 4-2), click Yes (recommended).

![Figure 4-2 Install Common System DLLs Dialog Box](image)

**Note:** If you want to install only some common system files, click No. The Upgrade Common System DLLs dialog box appears. Click Yes to upgrade only older system DLLs to newer versions.
6. At the Product Support Registration page (Figure 4-3), enter your name in the User Name text box, your company name in the Company Name text box, and the plan ID number (on the Total Assurance Plan) in the Serial Number text box, then click Next.

7. If the information in the Registration Confirmation dialog box is correct, click Yes.
8. At the Select Oracle SID Name page (Figure 4-4), select an Oracle SID name from the list (MILn), then click Next.
Note: For the Oracle SID name, you can use MILn, where n can be numbers 0 through 9 or letters A through Z.

9. At the Number of Users page (Figure 4-5), enter the anticipated number of users (from 1 to 250), then click Next.

Note: Rollback Initial (MB) is calculated as \((2 \times \# \text{ users}) \times 4\) + 100 MB. Next is the same as Initial. Max is 4200 MB. Even if you enter less than 20 users, the calculation uses 20 as the minimum number of users.

![Figure 4-5 Number of Users Page](image)

10. At the Database Size page (Figure 4-6), select a database size (Small, Medium, or Large), then click Next.
11. At the Program Directory page (Figure 4-7), select the disk drive on which to install the Millennium\textsuperscript{32} program files, then click Next.

12. At the Data Directory page (Figure 4-8), select the disk drive on which to install the Millennium\textsuperscript{32} raw data files, then click Next.
13. At the Database Directory page (Figure 4-9), select the disk drive for the Millennium® database (project tablespace) files, then click Next.

14. At the Select the Archive Directory Path page (Figure 4-10), do one of the following:
   - To accept the default setting, click Next.
   - To specify a different location for your archive files, browse or type the location, then click Next.
Note: If the path does not exist, one is created for you.

Attention: Network paths are not supported for archive log destinations.

Make the archive log destination to a local drive only. You cannot enable archivelog mode if a network destination file is specified.

Figure 4-10 Select the Archive Directory Path Page

15. At the Build Database message (Figure 4-11), do one of the following:

Figure 4-11 Build Database Message

- If your server has two physical drives and you install the database and raw data on the same physical drive, continue with Section 4.2.2, Configuration for a Server with Two Physical Drives (PowerStation).

Attention: If your server has two physical drives and you install the database and raw data on the same physical drive, do not click Yes or No until you have completed Section 4.2.2, Configuration for a Server with Two Physical Drives (PowerStation).
If your server does not have two physical drives and/or you install the database and raw data on different physical drives, AND you want to use script files to build the database manually using your own settings, click *No*, then continue with Appendix B, *Building a Custom Millennium 32 Database*.

If your server does not have two physical drives and/or you install the database and raw data on different physical drives, AND you want the installation wizard to build the database automatically using the default settings, click *Yes*.

16. The Millennium 32 Setup screen displays progress indicators while it installs the Millennium 32 and Oracle files on the selected drive(s). When the Installation is Complete page appears, select *Yes, I want to restart my computer now* to complete the installation.

### 4.2.2 Configuration for a Server with Two Physical Drives (PowerStation)

If your server has two physical drives (such as a PowerStation Primary PC) and you install the database and raw data on the same physical drive, use this section to move the location of the mirrored files to a separate physical drive.

**Attention:** If your server has two physical drives and you install the database and raw data on the same physical drive (regardless of whether it is configured as two or more logical drives), Waters Corp. recommends that you change the location of the mirrored control and redo logs files. The installation wizard assumes that the database drive and the raw data drive are separate drives. If you do not move the location of the mirrored files, the database recovery may be incomplete or in some cases impossible.

Paths that you enter, such as in step 2, must already exist.

1. To initialize Millennium instance, open the file `database_drive:\millennium\database\initmil3.ora` in Notepad and locate the line starting `control_files =` compatible = 8.1.7.0.0
db_name = milenium

**Attention:** The service_names parameter in the initmil3.ora file (located on the database_drive:\millennium database) does not include the DNS name. The default name is sid.machine_name.domain. To define your database for a naming service, you will want to put the DNS name on the server, sid.machine_name.domain.dns.

**Attention:** If your server or PowerStation is in a workgroup rather than a domain, the service name appears to be sid.machine_name.machine_name because, when you are in a workgroup, the domain name defaults to the machine name.
instance_name = MIL3
service_names = MIL3.your server name.your domain
db_files = 1020
processes = 500
control_files = ("E:\millennium\database\ctl1MIL3.ora",
"E:\millennium\ctl2MIL3.ora")

2. Edit the path for the second control file in the line starting with control_files = ...
   For example, change RawData_drive to Program_drive as follows:
   Change "RawData_drive:\millennium\ctl2mil3.ora"
   To "Program_drive:\millennium\ctl2mil3.ora"

3. To create the MILENIUM database in the MIL? instance, open the file
   Program_drive:\millennium\script\cs_mil3ins.sql in Notepad and
   locate the lines starting ALTER DATABASE ADD LOGFILE MEMBER:
spool D:\millennium\script\cs_mil3ins.log
set echo on
connect INTERNAL/oracle
shutdown
startup nomount pfile=E:\millennium\database\initMIL3.ora
CREATE DATABASE milenium
LOGFILE 'E:\millennium\database\redo01.log' SIZE 10M,
LOGFILE 'E:\millennium\database\redo02.log' SIZE 10M,
LOGFILE 'E:\millennium\database\redo03.log' SIZE 10M,
LOGFILE 'E:\millennium\database\redo04.log' SIZE 10M
MAXLOGFILES 32
MAXLOGMEMBERS 4
MAXLOGHISTORY 1
DATAFILE 'E:\millennium\database\system01.dbf' SIZE 200M
REUSE
MAXDATAFILES 500
MAXINSTANCES 5
CHARACTER SET WE8ISO8859P1;
ALTER DATABASE DATAFILE
'E:\millennium\database\system01.dbf' AUTOEXTEND ON;

ALTER DATABASE ADD LOGFILE MEMBER 'F:\MILLENNIUM\redo01.log'
TO GROUP 1;
ALTER DATABASE ADD LOGFILE MEMBER 'F:\MILLENNIUM\redo02.log'
TO GROUP 2;
ALTER DATABASE ADD LOGFILE MEMBER 'F:\MILLENNIUM\redo03.log'
TO GROUP 3;
ALTER DATABASE ADD LOGFILE MEMBER 'F:\MILLENNIUM\redo204.log' TO GROUP 4;

4. Edit the path for the second set of redo logs ALTER DATABASE ADD LOGFILE MEMBER for all four lines. For example, change RawData_drive to Program_drive as follows:

Change ALTER DATABASE ADD LOGFILE MEMBER 'RawData_drive:\redo201.log' TO GROUP 1;

To ALTER DATABASE ADD LOGFILE MEMBER 'Program_drive:\redo201.log' TO GROUP 1;

5. Edit the backup files to account for the changed location of the redo and control files.

6. Do one of the following at the Build Database message:
   - If you want to use script files to build the database manually using your own settings, click No, then continue with Appendix B, Building a Custom Millennium³² Database.
   - If you want the installer to build the database automatically using the default settings, click Yes.

7. The Millennium³² Setup screen displays progress indicators while it installs the Millennium³² and Oracle files on the selected drive(s). When the Installation is Complete page appears, select Yes, I want to restart my computer now to complete the installation.

   Note: After the restart, log in to the server using an account with administrator privileges.

### 4.2.3 Verifying That the Millennium³² Database is Running

To verify that the Millennium³² database is running:

1. Open a Command Prompt window and enter the following commands:
   
   C:\> svrmgr1
   
   SVRMGR> connect system
   
   Password:

2. Enter the password (manager is the default password).

3. When you see the Connected. message, enter the following command:

   SVRMGR> select file_name, tablespace_name, bytes, status from dba_data_files;

4. Verify that the STATUS column shows AVAILABLE.
4.2.4 Starting Database Archiving

To start archiving the database:

1. Use Notepad to edit `database-drive:\Millennium\database\initmiln.ora`. Remove the comment symbol (#) from the following command:
   
   ```
   #log_archive_start = true
   ```

2. Save the `initmiln.ora` file and exit.

3. To enable archive logging:
   a. Enter the following commands:
      ```
      C:\> svrmgrl
      SVRMGR> connect internal
      ```
   b. Enter the password (*oracle* is the default password)
   c. Enter the commands:
      ```
      SVRMGR> shutdown transactional
      SVRMGR> startup mount
      pfile=tablespace-drive:\millennium\database\initmiln.ora;
      ```
   
   **Note:** For the Oracle SID name (*initmiln.ora*), *n* can be numbers 0 through 9 or letters A through Z.

   d. Enter the commands:
      ```
      SVRMGR> alter system archive log start;
      SVRMGR> alter database archivelog;
      SVRMGR> alter database open;
      SVRMGR> archive log list
      ```
   e. Verify that database log mode is Archive Mode and that Automatic Archival is enabled.
   f. At the `SVRMGR` prompt, enter `alter system switch logfile;`
   g. In the Oracle home directory (or wherever you defined the log archive destination in the `initmiln.ora` file), in `Database\Archive`, look for an archive file (.arc) corresponding to the time that you completed step 3f. Existence of an .arc file at the correct time verifies that all previous commands worked. You can customize the location of this directory.

4. At the `SVRMGR` prompt, enter `exit`
4.2.5 Configuring the Millennium§ Projects Directory

The procedure to configure the Millennium§ projects directory is described first for Windows NT, then for Windows 2000.

Attention: Configuring the Millennium§ Projects directory by setting Mill_projects$ file access (to Read-Only Access for Everyone and Full Access for the System, or the account that you configured Millennium Service to “Log on as...”) is critical for security.

Windows NT

To configure the Millennium§ Projects directory in Windows NT:

1. Using Windows Explorer, select the \Millennium\Projects folder from the data drive, right-click, then select Sharing.
2. At the Projects Properties dialog box, set the permissions as follows:
   a. Click the Sharing tab.
   b. Click Shared As.
   c. Type Mill_projects$ in the Share Name text box (Figure 4-12).

Note: If you choose a different share name, you must configure NullSessionShares (see Section 7.4, Creating Another Share).

![Figure 4-12 Projects Properties Dialog Box, Sharing Tab]
d. Click the **Security** tab, then click **Permissions**.

3. At the Directory Permissions dialog box (Figure 4-13), select **Replace Permissions on Subdirectories** and **Replace Permissions on Existing Files** to ensure that all current files in the directories have the appropriate permissions.

![Figure 4-13 Directory Permissions Dialog Box](image)

4. Ensure that the Mill_projects$ file has **Read-Only Access** for Everyone and **Full Control Access** for the System.

5. If you want to add a user:
   a. Click **Add**.
b. At the Add Users and Groups dialog box (Figure 4-14), select **System** or **Everyone**.

![Add Users and Groups Dialog Box](image)

**Figure 4-14 Add Users and Groups Dialog Box**

*Note: If the Millennium\(32\) server is not the domain controller, then select the local machine name from the List Names From drop-down list.*

c. Click **Add**.
d. From the Type of Access drop-down list, select the appropriate permissions for the user you selected, then click **OK**.

6. At the Directory Permissions dialog box, click **OK**.

7. At the Windows message box, click **Yes**.

8. After the server applies permissions to the subdirectories and files, click **OK** to close the Projects Properties dialog box.

**Windows 2000**

To configure the Millennium\(32\) Projects directory in Windows 2000:

1. Using Windows Explorer, select the `\Millennium\Projects` folder from the data drive, right-click, then select **Sharing**.
2. At the Sharing page of the Projects Properties dialog box, select **Share this folder**, enter **Mill_Projects$** in the Share Name text box (Figure 4-15), then click **Apply**.

![Figure 4-15 Project Properties Dialog Box, Sharing Tab](image)

3. Set the security settings as follows:
   a. Click the **Security** tab.
b. Clear **Allow inheritable permissions from parent to propagate to this object** (Figure 4-16), then click **Apply**.

![Figure 4-16 Project Properties Dialog Box, Security Tab](image)

Figure 4-16  Project Properties Dialog Box, Security Tab

c. At the **Security** message box, click **Copy** (Figure 4-17).

![Figure 4-17 Security Message Box](image)

d. Select **Everyone** from the Name box and clear all permissions except **Read & Execute, List Folder Contents**, and **Read**.

e. Select **System** from the Name box and enable all permissions.

4. If System is not listed, add it as a user:

   a. Click **Add**.

   b. Scroll down the Name box and select **System** (if it is not already listed in the Name box of the Security page) (Figure 4-18).
117 Installing a Client/Server or Primary PowerStation

Figure 4-18  Select Users, Computers, or Groups Dialog Box

*Note:* If the Millennium\textsuperscript{32} server is not the domain controller, then select the local machine name from the Look in drop-down list.

c. Click **Add**, then click **OK**.

d. At the Security page of the Project Properties dialog box, select **System** from the Name box and enable all permissions.

5. Apply the security settings to all Projects subdirectories as follows:

a. At the Security page of the Project Properties dialog box (Figure 4-16), click **Advanced**.
b. At the Access Control Settings for Projects dialog box (Figure 4-19), click the Permissions tab, then select Reset permissions on all child objects and enable propagation of inheritable permissions.

![Access Control Settings for Projects Dialog Box]

Figure 4-19  Access Control Settings for Projects Dialog Box

c. Ensure that Allow inheritable permissions from parent to propagate to this object is clear, then click Apply.

d. At the Security message, click Yes. The permissions are applied to all subdirectories of the Project directory.

e. Click OK to save the changes and close the Access Control Settings for Projects dialog box.

f. Click OK to exit the Project Properties dialog box.

4.2.6 Setting Up the Millennium\textsuperscript{32} Client Directory

To allow the Millennium\textsuperscript{32} clients to download the directories, set up the client stack (\textbackslash Millennium\textbackslash client) in the program-drive to be shared. The procedure to configure the Millennium\textsuperscript{32} client directory is described first for Windows NT, then for Windows 2000.

Note: After client and LAC/E\textsuperscript{32} installations are finished, the Millennium\textsuperscript{32} Client Directory can be unshared.
Windows NT

To configure the client stack in Windows NT:

1. Using Windows Explorer, select the \Millennium\Client subdirectory from the program-drive, right-click the subdirectory, then select Sharing.
2. At the Client Properties dialog box, click Share As, then click Apply.
3. Click the Security tab, then click Permissions.
4. At the Directory Permissions dialog box (Figure 4-20), select Replace Permissions on Subdirectories and Replace Permissions on Existing Files to ensure that all current files in the directories have the appropriate permissions.

![Figure 4-20 Directory Permissions Dialog Box](image)

5. Select Everyone from the Name box, select Read from the Type of Access drop-down list, then click OK.
6. At the warning message, click Yes.
7. Click OK to save the changes and exit the Client Properties dialog box.

Windows 2000

To configure the client stack in Windows 2000:

1. Using Windows Explorer, select the \Millennium\Client subdirectory from the program-drive, right-click the subdirectory, then select Sharing.
2. At the Client Properties Sharing dialog box, select Share this folder, then click Apply.
3. Set the security settings as follows (Figure 4-16):
   a. Click the Security tab.
b. Clear **Allow inheritable permissions from parent to propagate to this object**.

c. At the **Security** message, click **Copy**.

d. Select **Everyone** from the Name box and clear all permissions except **Read & Execute, List Folder Contents**, and **Read**.

4. Apply the security settings to all Client subdirectories and files as follows:

   a. At the Security page, click **Advanced**.

   b. At the Access Control Settings for Projects dialog box (**Figure 4-19**), click the **Permissions** tab, then select **Reset permissions on all child objects and enable propagation of inheritable permissions**.

   c. Ensure that **Allow inheritable permissions from parent to propagate to this object** is clear, then click **Apply**.

   d. At the **Security** message, click **Yes**. The permissions are applied to all subdirectories and files of the Client directory.

   e. Click **OK** to save the changes and close the Access Control Settings for Projects dialog box.

   f. Click **OK** to save the changes and exit the Client Properties Sharing dialog box.

### 4.2.7 Verifying the Installed Files

The Millennium\(^{32}\) Setup creates a Millennium\(^{32}\) program folder in the Start menu Programs folder. The Millennium\(^{32}\) program folder contains the following program items:

- **File Verification Results** – Contains a log of the file verification process results.
- **Installation Log** – Contains information about the current installation.
- **ReadMe!** – Contains up-to-date information about the current release of the Millennium\(^{32}\) software (can be viewed at the beginning of the installation process).
- **Verify Files** – Verifies the integrity of the Millennium\(^{32}\) software files on your hard disk.

#### Viewing the Read Me Text

The Read Me entry in the Millennium\(^{32}\) program folder includes information related to the current release of the Millennium\(^{32}\) software.

To view the Read Me file:

1. Select **Start > Programs > Millennium\(^{32}\) > ReadMe!**.
2. Review the contents of the file. You can print a copy by selecting **File > Print**.
3. Select **File > Exit**.
Viewing the Install Log Text

The Install Log contains information about your Millennium\textsuperscript{32} installation. You can use the log file to review your installation choices. In case of partial or unsuccessful installations, you can view the Install Log to check for errors.

To view the Install Log:

1. Select Start > Programs > Millennium\textsuperscript{32} > Installation Log. The program displays the millennium.log file in Notepad.
2. Review the contents of the file. You can print a copy by selecting File > Print.

Using the File Verification Utility

The File Verification utility checks the integrity of the installed Millennium\textsuperscript{32} program, data, and database files. Use the File Verification utility to verify the Millennium\textsuperscript{32} program and data files only (not the database files):

- As part of your installation qualification if you purchased the Millennium\textsuperscript{32} Qualification option
- To ensure that the Millennium\textsuperscript{32} files have not changed since installation

To use the File Verification utility:

1. Select Start > Programs > Millennium\textsuperscript{32} > Verify Files. The File Verification utility compares the installed Millennium\textsuperscript{32} files’ checksum with a previously stored checksum number, then creates a File Verification Results log.
2. Select Start > Programs > Millennium\textsuperscript{32} > File Verification Results. If an error message box appears stating that the file is too large for Notepad and asks if you want to use WordPad to view the file, select Yes. The WordPad window appears with the File Verification Results text.
3. Review the contents of the file. You can print a copy by selecting File > Print.
4. Select File > Exit.

This completes the Millennium\textsuperscript{32} software installation procedure on a Millennium\textsuperscript{32} server or primary PowerStation.

Continue with Chapter 5, Installing a Client.
Chapter 5
Installing a Client

Use this chapter to install the Millennium³² software on a client in a Millennium³² Client/Server System or a PowerStation.

If the client has a Windows NT operating system, continue with Section 5.1, Preparing a Windows NT Client. If the client has a Windows 2000 operating system, continue with Section 5.2, Preparing a Client on Windows 2000.

Note: See the Microsoft website (www.microsoft.com) or the relevant product CD-ROM for software and upgrades.

STOP
Attention: Before installing any hardware or software, perform a full backup of your hard drives (see the instructions provided by the manufacturer of your computer).

5.1 Preparing a Windows NT Client

The Millennium³² software on a client with the Windows NT operating system requires (see Section 1.2, Hardware and Software Requirements):

- Windows NT v. 4.0 with Service Pack 6a (128-bit)
  
  Note: Install Service Pack 6a (128-bit) for Windows NT v. 4.0, even if the client appears to have Service Pack 6a.

- Microsoft Internet Explorer v. 5.5 with Service Pack 1

Use the following procedures to prepare a client:

- Updating the Equinox driver (Section 5.1.1)
- Disabling Dr. Watson error-checking software (Section 5.1.2)
- Changing the page file size (Section 5.1.3)
5.1.1 Updating the Equinox Driver

If the client has an Equinox 8-port serial interface card, check the driver version and install v. 4.16 if needed.

To install Equinox driver v. 4.16 for Windows NT:

1. On the desktop, right-click Network Neighborhood, then select Properties.
2. Click the Adapters tab (Figure 5-1).

![Network Adapters Properties Sheet](image)

Figure 5-1 Network Adapters Properties Sheet

3. Select Equinox SST Adapter, then click Update.
4. At the Enter Path dialog box of Windows NT Setup, enter the path to the driver, then click Continue. Equinox v. 4.16 driver is installed.
5. At the Network Adapters properties sheet, click Close.
6. When the message to restart your computer appears, click Yes.

5.1.2 Disabling Error-Checking Software

To eliminate false error messages and to ensure that Millennium performs correctly, disable the Dr. Watson error-checking software as follows:

1. From Windows Explorer, double-click DRWTSN32.exe in the WINNT\system32 directory (Figure 5-2).
2. Clear all selections in the Options section.
3. Click OK.

5.1.3 Changing the Page File Size

To change the page file size in Windows NT:
1. Select Control Panel > System.
2. At the System Properties dialog box, click the **Performance** tab (Figure 5-3).

![System Properties Dialog Box, Performance Tab](image)

Figure 5-3 System Properties Dialog Box, Performance Tab

3. Click **Change** under Virtual Memory.
4. At the Virtual Memory dialog box (Figure 5-4), under Paging File Size for Selected Drive, enter 500 MB in Initial Size and enter 500 MB in Maximum Size, then click Set.

![Virtual Memory Dialog Box](image)

Figure 5-4  Virtual Memory Dialog Box

5. When the System Settings Change dialog box asks if you want to restart the computer, click No.

6. Continue with Section 5.3, Installing the Client Software.

### 5.2 Preparing a Client on Windows 2000

The Millennium software on a client with the Windows 2000 operating system requires (see Section 1.2, Hardware and Software Requirements):

- Windows 2000 with Service Pack 2
- Microsoft Internet Explorer v. 5.5 with Service Pack 1

Use the following procedures to prepare a client:

- Updating the Equinox driver (Section 5.2.1)
- Changing the page file sizes (Section 5.2.2)
5.2.1 Updating the Equinox Driver

Millennium for Windows 2000 supports only Equinox Driver v. 5.10.2.2. If the workstation has an Equinox 8-port serial interface card, during the first power-up after installing the serial card, Windows 2000 detects the new hardware and automatically installs a driver for the Equinox card. Check the driver version and install v. 5.10.2.2 if needed.

To install the Equinox driver v. 5.10.2.2 for Windows 2000:

1. Right-click the My Computer icon on the desktop, then select Properties.
2. Select the Hardware tab, then click Device Manager.
3. At the Device Manager window (Figure 5-5), select the + to the left of Multi-port serial adapters.
4. Right-click Equinox SST-8P PCI Adapter, then select Properties.
5. If the Driver Version is not 5.10.2.2 (Figure 5-6), select Update Driver.
6. At the Welcome page of the Upgrade Device Driver wizard (Figure 5-7), click **Next**.

---

Figure 5-6  Equinox Adapter Properties, Driver Tab

Figure 5-7  Welcome Page of Upgrade Device Driver Wizard
7. At the Install Hardware Device Drivers page (Figure 5-8), select **Search for a suitable driver**, then click **Next**.

![Figure 5-8 Install Hardware Device Drivers Page](image)

*Note:* Plan to put the files in a location that is logical and easy to find.

8. At the Locate Driver Files page (Figure 5-9), click **Specify a location**, then click **Next**.
Preparing a Client on Windows 2000

9. At the message to insert the installation disk (Figure 5-10), type `c:\EQN`, then click **OK**.

10. At the Driver Files Search Results page (Figure 5-11), ensure that **Install one of the other drivers** is selected, then click **Next**.
11. At the Driver Files Found page (Figure 5-12), scroll to the right and select the Equinox driver in c:\eqn\asynceqn.inf, then click Next.

12. If a Digital Signatures Not Found dialog box appears (Figure 5-13), click Yes to continue the installation.
Note: Although not digitally signed for this release of Windows 2000, Equinox driver v. 5.10.2.2 is the correct driver for Millennium v. 4.0.

13. At the Completing the Upgrade Device Driver Wizard page (Figure 5-14), click Finish.
14. At the Equinox SST-8P PCI Adapter Properties dialog box (Figure 5-15), click Close.

![Figure 5-15 Equinox SST-8P PCI Adapter Properties Dialog Box](image)

15. Restart the computer.

5.2.2 Changing the Page File Size

To change the page file size in Windows 2000:

1. Select Control Panel > System.
2. At the System Properties dialog box, click the Advanced tab (Figure 5-16).
3. Click Performance Options, then click Change under Virtual Memory in the Performance Options dialog box.

4. At the Virtual Memory dialog box (Figure 5-17), under Paging File Size for Selected Drive, enter **500 MB** in Initial Size and **500 MB** in Maximum Size, then click Set.
5. Click **OK** to exit the Virtual Memory dialog box.
6. Click **OK** to the System Control Panel Applet message.
7. Click **OK** to close the Performance Options dialog box.
8. Click **OK** to close the System Properties dialog box.
9. When the System Settings Change dialog box asks if you want to restart the computer, click **No**.

### 5.3 Installing the Client Software

The Millennium\textsuperscript{32} Chromatography Manager software is installed on the client from the shared client directory on the Millennium\textsuperscript{32} Client/Server System server. Allow approximately 10 to 15 minutes to install the software.

You can perform a *typical* installation to install the software on the C: drive or default location, or a *custom* installation to specify the drives.
5.3.1 Starting the Installation

To install the Millennium\textsuperscript{32} Chromatography Manager software on a client:

1. Using Windows Explorer at the client, map a drive letter to the client shared directory on the Millennium\textsuperscript{32} server.
2. Select the mapped drive, then double-click setup.exe to start the Millennium\textsuperscript{32} Setup program. The splash screen appears momentarily.
3. At the Installation Type dialog box (Client or LAC/E 32 Acquisition Server), select Client.
4. At the Welcome page of the Millennium\textsuperscript{32} Setup wizard (Figure 5-18), click Next.

![Figure 5-18 Welcome to the InstallShield Wizard for Millennium\textsuperscript{32} Page](image)

5. At the License Agreement page, read the License Agreement, then click Yes.
6. At the Information page, read the Read Me First text, then click Next.
7. At the Installation Type page (Typical or Custom), do one of the following:
   - Click Typical if you want to install the Millennium\textsuperscript{32} software on the C: drive or default location.
   - Click Custom if you want to specify different drives.
8. The Minimum System Requirements message reminds you of the requirements. Ensure that your system's specifications match or exceed the requirements, then click OK.
9. **For Windows NT only:** At the Install Common System DLLs dialog box (Figure 5-19), click *Yes* to install all common system files (recommended).

![Install Common System DLLs Dialog Box](image)

*Figure 5-19 Install Common System DLLs Dialog Box*

**Note:** If you want to install only some common system files, click *No*. The Upgrade Common System DLLs dialog box appears. Click *Yes* to upgrade only older system DLLs to newer versions.
10. At the Product Support Registration page of the Millennium Setup wizard (Figure 5-20), enter your name in the User Name text box, your company name in the Company Name text box, and the plan ID number (on the Total Assurance Plan) in the Serial Number text box, then click Next.

![Figure 5-20 Product Support Registration Page](image)

11. At the Registration Confirmation dialog box, click Yes.

12. At the BusLAC/E Driver Installation page (Figure 5-21), select the BusLAC/E driver that corresponds to your busLAC/E, then click Next.

![Figure 5-21 BusLAC/E Driver Installation Page](image)

13. At the Re-Ask BusLAC/E Driver Installation dialog box, if the information is correct, click Yes.
14. At the Add ZQ Option dialog box, do one of the following:
   - If your system does not include a ZQ 2000 or ZQ 4000 Mass Detector, click No.
   - If your system includes a ZQ 2000 or ZQ 4000 Mass Detector, click Yes. At the ZQ Installation page, select ZQ2000 or ZQ4000, then click Next.

15. At the Add Desktop Shortcut dialog box, do one of the following:
   - If you want to add a Millennium\textsuperscript{32} shortcut to your desktop, click Yes.
   - If not, click No.

   \textit{Note: If you are performing a custom installation, continue with Section 5.3.2, Finishing a Custom Installation.}

16. The Millennium\textsuperscript{32} Setup installs the Millennium\textsuperscript{32} and Oracle program files on the hard drive. When the Installation is Complete page appears (Figure 5-22), click Yes, I want to restart my computer now, then click Finish.

![Figure 5-22 Installation is Complete Page](image)

17. After the computer restarts, log in using an account with administrator privileges.

   \textit{Note: To complete the installation, you must log in again using an account with administrator privileges.}

18. If a Command window and a Registry Editor message box appear, click OK to close the message box.
5.3.2 Finishing a Custom Installation

To finish a custom installation (if you selected Custom in step 7):

1. At the Program Directory page (Figure 5-23), select the drive on which to install the Millennium\textsuperscript{32} software, then click Next.

![Figure 5-23 Program Directory Page](image)

2. The Millennium\textsuperscript{32} Setup installs the Millennium\textsuperscript{32} and Oracle program files on the hard drive. When the Installation is Complete page appears, click Yes, I want to restart my computer now, then click Finish.

3. After the computer restarts, log in using an account with administrator privileges.

   Note: To complete the installation, you must log in again using an account with administrator privileges.

4. If a Command Prompt window and a Registry Editor message box appear, click OK to close the message box.
5.4 Configuring a Database Service Name

To connect to the Millennium\(^{32}\) database, a database or net service name (previously called a database alias) must be configured on each client.

To configure the database service name:

1. Select Start > Programs > Millennium\(^{32}\) > Oracle > Oracle Net8 Configuration Assistant.
2. At the Welcome page of the Oracle Net8 Configuration Assistant wizard (Figure 5-24), click Local Net Service Name configuration, then click Next.

![Figure 5-24 Welcome Page of the Oracle Net8 Configuration Assistant](image)

3. At the Net Service Name Configuration page, ensure that Add is selected, then click Next.

Note: Millennium\(^{32}\) v. 4.0 does not support Distributed File System (DFS, part of the Windows 2000 Server operating system) with the Millennium Service.

Note: The LAC/E\(^{32}\) Acquisition Server and the clients must use the same net service name, which includes the Domain Name Service (DNS) for Windows 2000 naming convention (for example, service_name.domain_name.internet_domain_name).
4. At the Database Version page (Figure 5-25), do one of the following:
   - To use Oracle 8i naming convention (database service names), select Oracle 8i database or service. At the Service Name page, enter the service name of the Millennium\textsuperscript{32} database, then click Next.

   \textit{Note:} This name is in the initmiln.ora file on the line that states service_names =.

   - To use Oracle 8 or 7 naming convention (database SID names), select Oracle8 release 8.0 or Oracle 7 database or service, then click Next. At the Database SID page, enter MILn in the Database SID field, then click Next.

   \textit{Note:} \textit{n} refers to the character in the Oracle SID name. This character is typically 3, although valid characters are 0 through 9 and A through Z. Use the same Oracle SID name that was installed on the Millennium\textsuperscript{32} server.

5. At the Select Protocols page (Figure 5-26), ensure that TCP is selected, then click Next.
6. At the TCP/IP Protocol page (Figure 5-27), enter either the host name or the TCP/IP address of the server where the Millennium database resides in the Host Name field, ensure that **Use the standard port number of 1521** is selected, then click **Next**.
7. At the Test page, perform the test as follows:
   a. Select **Yes, perform a test**, then click **Next**. The test is automatically performed and will fail on the initial attempt due to the default user name and password, which must changed.
   b. Click **Change Login**.
   c. Enter **system** for the user name and **manager** for the password, then click **OK**.
   d. The test should succeed. If not, review the entries and network connection and correct any errors, then repeat steps 7a through 7c.
   e. Click **Next**.
8. At the Net Service Name page (Figure 5-28), enter a name in the Net Service Name field, then click **Next**.

   **Note:** The name that you enter appears in the Database field of the Millennium™ Login dialog box. In general, this name can be any alphanumeric string. However, when using a client in conjunction with a LAC/E32™ Acquisition Server, the client and the LAC/E32™ Acquisition Server must use the same net service name.

   ![Figure 5-28 Net Service Name Page](image)

9. At the Another Net Service Name? page, select **No**, then click **Next**.
10. Click **Next** until the Done page of the Net8 Configuration Assistant wizard appears, then click **Finish**.
5.5 Installing Millennium\textsuperscript{32} Licenses and Options

Before you install Millennium\textsuperscript{32} options (for example, System Suitability), ensure that:

- The Millennium\textsuperscript{32} software is installed (see Section 5.3, Installing the Client Software).
- A database service name is available on the client to point to the correct database (see Section 5.4, Configuring a Database Service Name).

5.5.1 About Millennium\textsuperscript{32} Licenses and Options on Key Disks

Millennium\textsuperscript{32} software licenses and options are installed on the database server from a client using 3.5-inch key disks. Many options are available. Ensure that key disk(s) and CD(s) are stored in an accessible but secure location.

Key disks are required for installation, uninstallation, and reinstallation of the Millennium\textsuperscript{32} licenses and options. If you need to transfer a license or option from one Millennium\textsuperscript{32} server to another, you must uninstall it from the original client/server system before you install it in a new client/server system. In a new installation, licenses and options must be installed in the following order:

- Base key
- Licenses
- Concurrent Users (PowerStation only)
- Options

The number of allowed named users in the database is based on the number of Named User Licenses you have purchased. You can create a number of accounts equal to the number of Named User Licenses you have purchased. You install the licenses from any client, then install all options, then set up your named accounts (up to the total number of Named User Licenses).

Attention: Do not write protect key disks.
Do not uninstall the Millennium\textsuperscript{32} software until you uninstall the options, or the options become unusable.

Note: You cannot install an option intended for a Millennium\textsuperscript{32} Client/Server System or PowerStation on a stand-alone workstation, nor can you install an option intended for a stand-alone workstation on a Millennium\textsuperscript{32} Client/Server System or PowerStation.

Once you have installed an option using the procedures in this section, the option is enabled for all projects. You may disable the option for specific projects (see “Configuring Millennium\textsuperscript{32} Software Options” in the Millennium\textsuperscript{32} Help).
5.5.2 Installing a Millennium\textsuperscript{32} License or Option

Install the Client/Server or PowerStation key disk first, then the options.

\textbf{Note:} To install a Millennium\textsuperscript{32} option or license from a client, the Millennium\textsuperscript{32} software must already be installed on the client. You must also be able to contact the database. To ensure successful installation, Waters strongly recommends that the Millennium\textsuperscript{32} software not be running during installation.

To install a Millennium\textsuperscript{32} option:

1. Insert the Millennium\textsuperscript{32} Client/Server, PowerStation, or Option key disk into the disk drive on a client.
2. Select \textit{Start} > \textit{Run}.
3. At the Run dialog box, type the disk drive letter, then `:\Setup.exe`, then click \textit{OK}.
4. At the Millennium\textsuperscript{32} Option Setup dialog box, ensure that the name of the option that is being installed is correct, then click \textit{OK}.

\textbf{Note:} Allow a few minutes for the Millennium\textsuperscript{32} Option Setup dialog box to appear.

5. Do one of the following:
   - If a Millennium\textsuperscript{32} Option message box appears after successful installation because the option was not previously installed, click \textit{OK} to close the message box.
   - If a Millennium\textsuperscript{32} Option message box appears because the option is already installed on your client/server system, click \textit{Cancel} to close the message box.
   - If a \textit{Setup} message box appears because the option is already installed on a different Millennium\textsuperscript{32} Client/Server System, click \textit{OK} to close the message box. To remove the option from a Millennium\textsuperscript{32} Client/Server System, continue with Section 5.5.3, Uninstalling a Millennium\textsuperscript{32} License or Option.
6. Repeat steps 1 through 5 for each option.

5.5.3 Uninstalling a Millennium\textsuperscript{32} License or Option

If you want to transfer a Millennium\textsuperscript{32} option from one server to another, you must first uninstall the option from its current server using the appropriate option key disk. Licenses and options must be uninstalled in the following order:

- Options
- Concurrent Users (PowerStation only)
• Licenses
• Base key

**Attention:** Do not write protect key disks.

Do not uninstall the Millennium\textsuperscript{32} software until you uninstall the options, or the options become unusable.

To uninstall an option:

1. Log on from a client.
2. Insert the appropriate Millennium\textsuperscript{32} Option key disk into the client that has a service name that points to the correct server.
3. Select **Start > Run**.
4. At the Run dialog box, type the disk drive letter, then `:\Setup.exe`, then click **OK**.
5. At the Millennium Option Setup dialog box, click **OK**.
6. At the Option Already Installed message box, click **OK**.
7. At the Setup message box, click **OK** to close the message box.
8. Remove the disk.
9. Continue with Section 5.5.2, *Installing a Millennium\textsuperscript{32} License or Option*.

### 5.6 Restoring the Option Sample Project

If you install a new option, you can restore the option sample project files from the Millennium\textsuperscript{32} CD (see “Restoring a Project Using the Wizard” in the *Millennium\textsuperscript{32} Help*).

You can use the option sample project files as a template.
5.7 Registering Acquisition Server Printers

To register printers for Millennium<sup>32</sup> reports from a client:

1. Select Start > Programs > Millennium<sup>32</sup> > Register Acquisition Server Printers.

2. At the Register Acquisition Server Printers dialog box (Figure 5-29), review the list of printers that are currently registered.

![Figure 5-29 Register Acquisition Server Printers Dialog Box](image)

3. If you need to register additional printers, click Get Printers, select the printer(s), then click OK.

   **Note:** The Register Acquisition Server Printers dialog box only shows printers that are added using the Printers control panel. To add new printers, select Start > Settings > Printers.

4. Click OK to accept the printers and close the dialog box.

This completes the Millennium<sup>32</sup> software installation procedure for a client.
Chapter 6
Installing an Acquisition Server

Use this chapter to install the Millennium\textsuperscript{32} Chromatography Manager software v. 4.0 on a Waters LAC/E\textsuperscript{32} Acquisition Server and/or an acquisition client.

Each LAC/E\textsuperscript{32} Acquisition Server requires the hardware and software in Table 1-3. The software is normally installed by Waters Corp. before the system is shipped to you.

If the client has a Windows NT operating system, continue with Section 6.1, Preparing a Windows NT Acquisition Server. If the client has a Windows 2000 operating system, continue with Section 6.2, Preparing a Windows 2000 Acquisition Server.

**Attention:** If you plan to change the computer name of an acquisition server or acquisition client, Waters Corp. recommends that you change the name before installing Millennium\textsuperscript{32} software.

### 6.1 Preparing a Windows NT Acquisition Server

The Millennium\textsuperscript{32} software on a LAC/E\textsuperscript{32} Acquisition Server and/or an acquisition client with the Windows NT operating system requires the hardware and software in Section 1.2. Ensure that the following software and service packs are installed:

- Microsoft Internet Explorer v. 5.5 with Service Pack 1
- Windows NT v. 4.0 with Service Pack 6a (128-bit)

**Note:** Install Service Pack 6a (128-bit) for Windows NT v. 4.0, even if the LAC/E\textsuperscript{32} Acquisition Server or acquisition client appears to have Service Pack 6a.

**Note:** To install Microsoft service packs on a LAC/E\textsuperscript{32} Acquisition Server or an acquisition client, refer to the Microsoft documentation.
Use the following procedures to prepare a LAC/E³² Acquisition Server and/or an acquisition client:

- Connecting remotely for a LAC/E³² Acquisition Server (see Appendix C, Connecting Remotely to a LAC/E³² Acquisition Server)
- Updating the Equinox driver (see Section 6.1.1)
- Disabling Dr. Watson error-checking software (see Section 6.1.2)
- Changing the page file size (see Section 6.1.3)

### 6.1.1 Updating the Equinox Driver

If the LAC/E³² Acquisition Server has an Equinox 8-port serial interface card, check the driver version and install v. 4.16 if needed from the Millennium³² CD.

To install Equinox driver v. 4.16 for Windows NT:

1. On the desktop, right-click **Network Neighborhood**, then select **Properties**.
2. Click the **Adapters** tab (Figure 6-1).

![Network Adapters Properties Sheet](image)

Figure 6-1  Network Adapters Properties Sheet

3. Select **Equinox SST Adapter**, then click **Update**.
4. At the Enter Path dialog box of Windows NT Setup, enter the path to the driver, then click **Continue**. Equinox v. 4.16 driver is installed.
5. At the Network properties sheet, click **Close**.
6. At the message to restart your computer, click **Yes**.
6.1.2 Disabling Dr. Watson Error-Checking Software

To eliminate false error messages and to ensure that Millennium performs correctly, disable the Dr. Watson error-checking software as follows:

1. From Windows Explorer, double-click DrWtsn32.exe in the WINNT\system32 directory (Figure 6-2).

2. Clear all selections in the Options section.

3. Click OK.

6.1.3 Changing the Page File Size

To change the page file size in Windows NT:

1. Select Control Panel > System.

2. At the System Properties dialog box, click the Performance tab.

3. At the Performance tab (Figure 6-3), click Change under Virtual Memory.
4. At the Virtual Memory dialog box (Figure 6-4), under Paging File Size for Selected Drive, enter 500 MB in Initial Size and enter 500 MB in Maximum Size, then click Set.

Figure 6-3 Performance Tab of System Properties

Figure 6-4 Virtual Memory Dialog Box
5. When the System Settings Change dialog box asks if you want to restart the computer, click **No**.
6. Continue with **Section 6.3, Installing the Millennium\(^{32}\) Software**.

## 6.2 Preparing a Windows 2000 Acquisition Server

The Millennium\(^{32}\) software on an acquisition server with the Windows 2000 operating system requires (see **Section 1.2, Hardware and Software Requirements**):

- Windows 2000 with Service Pack 2
- Microsoft Internet Explorer v. 5.5 with Service Pack 1

Use the following procedures to prepare an acquisition server:

- Updating the Equinox driver (**Section 6.2.1**)
- Changing the page file sizes (**Section 6.2.2**)

### 6.2.1 Updating the Equinox Driver

Millennium\(^{32}\) for Windows 2000 supports only Equinox Driver v. 5.10.2.2. If the acquisition client has an Equinox 8-port serial interface card, during the first power-up after installing the serial card, Windows 2000 detects the new hardware and automatically installs a driver for the Equinox card. Check the driver version and install v. 5.10.2.2 if needed.

To install the Equinox driver v. 5.10.2.2 for Windows 2000:

1. Right-click the **My Computer** icon on the desktop, then select **Properties**.
2. Select the **Hardware** tab, then click **Device Manager**.
3. At the Device Manager window (**Figure 6-5**), select the + to the left of Multi-port serial adapters.
4. Right-click **Equinox SST-8P PCI Adapter**, then select **Properties**.

5. If the Driver Version is not 5.10.2.2 (**Figure 6-6**), select **Update Driver**.

![Figure 6-5 Locating Equinox Driver in Device Manager](image)

![Figure 6-6 Equinox Adapter Properties, Driver Tab](image)
6. At the Welcome page of the Upgrade Device Driver wizard (Figure 6-7), click Next.

![Figure 6-7 Welcome Page of Upgrade Device Driver Wizard](image)

7. At the Install Hardware Device Drivers page (Figure 6-8), select Search for a suitable driver, then click Next.

![Figure 6-8 Install Hardware Device Drivers Page](image)

*Note: Plan to put the files in a location that is logical and easy to find.*
8. At the Locate Driver Files page (Figure 6-9), click Specify a location, then click Next.

![Figure 6-9 Locate Driver Files Page](image1)

9. At the message to insert the installation disk (Figure 6-10), type c:\EQN, then click OK.

![Figure 6-10 Insert Disk Message](image2)

10. At the Driver Files Search Results page (Figure 6-11), ensure that Install one of the other drivers is selected, then click Next.
11. At the Driver Files Found page (Figure 6-12), scroll to the right and select the Equinox driver in c:\eqn\asynceqn.inf, then click Next.

12. If a Digital Signatures Not Found dialog box appears (Figure 6-13), click Yes to continue the installation.
Note: Although not digitally signed for this release of Windows 2000, Equinox driver v. 5.10.2.2 is the correct driver for Millennium v. 4.0.

Figure 6-13 Digital Signature Not Found

13. At the Completing the Upgrade Device Driver Wizard page (Figure 6-14), click Finish.

Figure 6-14 Completing the Upgrade Device Driver Wizard Page
14. At the Equinox SST-8P PCI Adapter Properties dialog box (Figure 6-15), click Close.

![Figure 6-15  Equinox SST-8P PCI Adapter Properties Dialog Box](image)

15. Restart the computer.

### 6.2.2 Changing the Page File Size

To change the page file size in Windows 2000:

1. Select Control Panel > System.
2. At the System Properties dialog box, click the Advanced tab (Figure 6-16).
3. Click **Performance Options**, then click **Change** under Virtual Memory in the Performance Options dialog box.

4. At the Virtual Memory dialog box (**Figure 6-17**), under Paging File Size for Selected Drive, enter **500 MB** in Initial Size and **500 MB** in Maximum Size, then click **Set**.

---

**Figure 6-16** System Properties Dialog Box, Advanced Tab
5. Click OK to exit the Virtual Memory dialog box.
6. Click OK to the System Control Panel Applet message.
7. Click OK to close the Performance Options dialog box.
8. Click OK to close the System Properties dialog box.
9. When the System Settings Change dialog box asks if you want to restart the computer, click No.

6.3 Installing the Millennium\textsuperscript{32} Software

The Millennium\textsuperscript{32} Chromatography Manager is installed from the shared client directory on the Millennium\textsuperscript{32} server. Allow approximately 10 to 15 minutes to install the software.

\textbf{Note:} For an acquisition client, follow the same procedure, but select Client in step 3.

To install the Millennium\textsuperscript{32} software v. 4.0 on the LAC/E\textsuperscript{32} Acquisition Server:

1. Using Windows Explorer, map a drive letter on the LAC/E\textsuperscript{32} Acquisition Server to the client shared directory on the Millennium\textsuperscript{32} server.
2. Select the mapped drive, then double-click setup.exe to start the Millennium\textsuperscript{32} Setup program. The splash screen appears momentarily.
3. At the Installation Type dialog box (Client or LAC/E 32 Acquisition Server), select LAC/E 32 Acquisition Server.

    Note: For an acquisition client, select Client.

4. At the Welcome page of the Millennium³² Setup wizard (Figure 6-18), click Next.

![Figure 6-18 Welcome to the InstallShield Wizard for Millennium³² Page](image)

5. At the License Agreement page, read the License Agreement, then click Yes.
6. At the Information page, read the Read Me First text, then click Next.
7. At the Installation Type page (Typical or Custom), do one of the following:
   - Click Typical if you want to install the Millennium³² software on the C: drive or default location.
   - Click Custom if you want to specify different drives.
8. The Minimum System Requirements message reminds you of the requirements. Ensure that your system's specifications match or exceed the requirements, then click OK.
9. **For Windows NT Only:** At the Install Common System DLLs dialog box (Figure 6-19), click **Yes** to install all common system files (recommended).

![Install Common System DLLs Dialog Box](image)

**Figure 6-19 Install Common System DLLs Dialog Box**

*Note:* If you want to install only some common system files, click **No**. The Upgrade Common System DLLs dialog box appears. Click **Yes** to upgrade only older system DLLs to newer versions.
10. At the Product Support Registration page of the Millennium Setup wizard (Figure 6-20), enter your name in the User Name text box, your company name in the Company Name text box, and the plan ID number (on the Total Assurance Plan) in the Serial Number text box, then click Next.

![Figure 6-20 Product Support Registration Page](image)

11. At the Registration Confirmation dialog box, click Yes.

12. At the BusLAC/E Driver Installation page (Figure 6-21), select the BusLAC/E driver that corresponds to your busLAC/E, then click Next.

![Figure 6-21 BusLAC/E Driver Installation Page](image)

13. At the Re-Ask BusLAC/E Driver Installation dialog box, click Yes.
14. At the Add ZQ Option dialog box, do one of the following:
   - If this is a LAC/E³² Acquisition Server (no ZQ Mass Detector), click No.
   - If this is an acquisition client connected to a ZQ Mass Detector, click Yes.
15. At the Add Desktop Shortcut dialog box, do one of the following:
   - If you want to add a Millennium³² shortcut to your desktop, click Yes.
   - If not, click No.
16. For a custom installation only: At the Program Directory page, select the drive on which to install the Millennium³² software, then click Next.
17. The Millennium³² Setup installs the Millennium³² and Oracle program files on the LAC/E³² Acquisition Server or acquisition client. After approximately 10 to 15 minutes, the Installation is Complete page appears (Figure 6-22).

![Figure 6-22 Installation is Complete Page](image)

18. Click Yes, I want to restart my computer now, then click Finish.
19. After the computer restarts, log in using an account with administrator privileges.
   
   **Note:** To complete the installation, you must log in again using an account with administrator privileges.
20. If a Command Prompt window and a Registry Editor message box appear, click OK to close the message box.
6.4 Configuring a Database Service Name

To connect to the Millennium\textsuperscript{32} database, a database or net service name (previously called a database alias) must be configured on a LAC/E\textsuperscript{32} Acquisition Server and/or an acquisition client.

To configure the database service name:

1. Select Start > Programs > Millennium\textsuperscript{32} > Oracle > Oracle Net8 Configuration Assistant.

2. At the Welcome page of the Oracle Net8 Configuration Assistant wizard (Figure 6-23), click Local Net Service Name configuration, then click Next.

3. At the Net Service Name Configuration page, ensure that Add is selected, then click Next.

Note: The LAC/E\textsuperscript{32} Acquisition Server and the clients must use the same net service name, which includes the Domain Name Service (DNS) for Windows 2000 naming convention. For example:

\texttt{service_name.domain_name.internet_domain_name}
4. At the Database Version page (Figure 6-24), do one of the following:
   - To use Oracle 8i naming convention (database service names), click Oracle 8i database or service. At the Service Name page, enter the Service Name of the Millennium database, then click Next.

   **Note:** This name is in the initmiln.ora file on the Millennium Server in the databasedrive:imillenniumdatabase directory on the line that states service_names =.

   - To use Oracle 8 or 7 naming convention (database SID names), click Oracle8 release 8.0 or Oracle 7 database or service, then click Next. At the Database SID page, enter MILn in the Database SID field, then click Next.

   **Note:** n refers to the character in the Oracle SID name. This character is typically 3, although valid characters are 0 through 9 and A through Z.
5. At the Select Protocols page (Figure 6-25), ensure that TCP is selected, then click Next.

6. At the TCP/IP Protocol page (Figure 6-26), enter either the host name or the TCP/IP address of the computer where the Millennium database resides in the Host Name field. Ensure that Use the standard port number of 1521 is selected, then click Next.
7. At the Test page, perform the test as follows:
   a. Click **Yes, perform a test**, then click **Next**.
   b. The test is automatically performed and will fail on the initial attempt due to the default user name and password, which must changed.
   c. Click **Change Login**.
   d. Enter **system** for the user name and **manager** for the password, then click **OK**.
   e. The test should succeed. If not, review the entries and network connection and correct any errors, then repeat steps 7a through 7d.
   f. Click **Next**.

8. At the Net Service Name page (Figure 6-27), enter a name in the Net Service Name field, then click **Next**.

![Figure 6-27 Net Service Name Page](image)

9. At the Another Net Service Name? page, select **No**, then click **Next**.

   **Note:** The name that you enter appears in the Database field of the Millennium32 Login dialog box. In general, this name can be any alphanumeric string. However, when using a client in conjunction with a LAC/E32 Acquisition Server, the client and the LAC/E32 Acquisition Server must use the same net service name.

10. When the Done page of the Net8 Configuration Assistant wizard appears, click **Finish**.
6.5 Registering Acquisition Server Printers

To register printers for Millennium\textsuperscript{32} reports:

1. Select Start > Programs > Millennium\textsuperscript{32} > Register Acquisition Server Printers.

2. At the Register Acquisition Server Printers dialog box (Figure 6-28), review the list of printers that are currently registered.

![Register Acquisition Server Printers Dialog Box](image)

Figure 6-28  Register Acquisition Server Printers Dialog Box

3. If you need to register additional printers, click Get Printers, select the printer(s), then click OK.

   \textit{Note:} The Register Acquisition Server Printers dialog box only shows printers that are added using the Printers control panel. To add a new printer, select Start > Settings > Printers.

4. Click OK to save the changes and close the dialog box.

6.6 Disabling AutoLogon

The LAC/E\textsuperscript{32} Acquisition Server is configured with Windows AutoLogon software. By default, the LAC/E\textsuperscript{32} AutoLogon utility logs in to the operating system as the Local Administrator. After installation and configuration of the LAC/E\textsuperscript{32} Acquisition Server is complete, use the following procedure to disable the Windows AutoLogon utility.

To disable the Windows AutoLogon utility:

1. Select Start > Run.
2. Type `drive:\millennium\bin\Autologon.exe` in the Open text box, then click OK.
3. Ensure that the Enable AutoLogon check box is clear (Figure 6-29).

![AutoLogon Dialog Box](image)

Figure 6-29 AutoLogon Dialog Box

4. Click OK to save the changes and close AutoLogon.
5. Log off the LAC/E³² Acquisition Server.

This completes the Millennium³² software installation procedure on a LAC/E³² Acquisition Server or an acquisition client.
Chapter 7
Installing the Millennium Service

Use this chapter to install the Millennium Service as a separate service on a computer other than the Millennium database server to provide file services for Millennium clients on the network.

**Attention:** Before installing any hardware or software, perform a full backup of your hard drives (see the instructions provided by the manufacturer of your computer).

**Note:** A server that has Millennium software v. 4.0 already has the Millennium Service.

**Note:** Millennium v. 4.0 does not support Distributed File System (DFS, part of the Windows 2000 Server operating system) with the Millennium Service.

**Note:** The InstrumentServer directory can be protected from tampering by setting it to Full Control for whatever the Millennium Service runs as (usually Local System) and Read Only for everyone else.

### 7.1 Considerations and Requirements

**Considerations**

The Millennium Service allows specific computers that are running the Millennium Service to have raw data shares configured for them in Millennium and users can store project raw data on these file shares.

The Millennium Service runs as a Windows NT or Windows 2000 Service to provide secure access to Millennium raw data files through the Millennium application. While the operating system permissions on the files can be set to read-only for Millennium users, these same users can have write privileges through the Millennium Service when running Millennium software.
Requirements

- Network
- Windows NT or Windows 2000 PC on the same network domain as the database server

7.2 Installing the Millennium Service on a Server

To install the Millennium Service on a server that does not currently have Millennium software:

1. Insert the Millennium CD into the CD-ROM drive of the server.
2. If Millennium AutoLogin starts, select No, Do Not Install Millennium.
3. Using Windows Explorer, navigate to the Millennium Service folder on the Millennium CD, then double-click Setup.exe.
4. At the Welcome to the InstallShield Wizard for Millennium page, click Next.
5. At the License Agreement page, read the agreement, then click Yes.
6. At the Information page, read the Read Me First text, then click Next.
7. The Choose Destination Location page allows you to select the destination of the program files. You can select the default destination, Millennium\Bin, or you can browse to your C: drive and create a new folder (for example, MillService), then click Next.
8. At the Millennium Raw Data Share Name page, you can select the default name, Mill_Projects$, or you can customize the name, then click Next.

*Note: If you customize the name, you must use the same share name for the raw data files share in Section 7.3.*

9. The Setup Status dialog box shows the progress of the installation. When a message tells you that the system needs to be restarted, click OK.
10. When the Registry Editor appears, asking you to confirm that you want to restart, click Yes, then click OK to finish the installation.
7.3 Configuring the Raw Data Directory

The Windows NT procedure is described first, then the Windows 2000 procedure.

Windows NT

To configure the raw data directory:

1. From Windows Explorer, create a new folder for the raw data files (for example, D:\millennium\projects). You must share it using the share name from step 7 in Section 7.2.
2. Right-click the new folder, select Properties, then click the Sharing tab.
3. Select Shared As, then enter the Millennium Raw Data Share Name (from step 8 in Section 7.2) in the Share Name field.
4. Click the Security tab, then click Permissions.
5. Select Replace Permissions on Subdirectories and Replace Permissions on Existing Files.
6. Ensure that the Mill_projects$ file has Read-Only Access for Everyone and Full Control Access for the System, then click OK.
7. Click OK to save the changes and close the Properties dialog box.

Windows 2000

To configure the raw data directory in Windows 2000:

1. Using Windows Explorer, select the \Millennium\Projects folder from the data drive, right-click, then select Sharing.
2. At the Sharing page of the Projects Properties dialog box, select Share this folder, enter Mill_Projects$ in the Share Name text box, then click Apply.
3. Set the security settings as follows:
   a. Click the Security tab.
   b. Clear Allow inheritable permissions from parent to propagate to this object, then click Apply.
   c. At the Security message box, click Copy.
   d. Select Everyone from the Name box and clear all permissions except Read & Execute, List Folder Contents, and Read.
   e. Select System from the Name box and enable all permissions.
4. If System is not listed, add it as a user:
   a. Click Add.
b. Scroll down the Name box and select System (if it is not already listed in the Name box of the Security page).

*Note:* If the Millennium\(^32\) server is not the domain controller, then select the local machine name from the Look in drop-down list.

c. Click Add, then click OK.

d. At the Security page of the Project Properties dialog box, select System from the Name box and enable all permissions.

5. Apply the security settings to all Projects subdirectories as follows:
   a. At the Security page of the Project Properties dialog box, click Advanced.
   b. At the Access Control Settings for Projects dialog box, click the Permissions tab, then select Reset permissions on all child objects and enable propagation of inheritable permissions.
   c. Ensure that Allow inheritable permissions from parent to propagate to this object is clear, then click Apply.
   d. At the Security message, click Yes. The permissions are applied to all subdirectories of the Project directory.
   e. Click OK to save the changes and close the Access Control Settings for Projects dialog box.
   f. Click OK to exit the Project Properties dialog box.

7.4 Creating Another Share

If you want to create another share on the same computer (for example, for another department or user group), you must manually edit the NullSessionShares entry to add a new share.

**Attention:** Before editing the registry, ensure that you have an updated Emergency Repair Disk available.

**Changing the NullSessionShares Registry Entry**

The Millennium\(^32\) service installation procedure modifies a NullSessionShares Windows NT or Windows 2000 registry entry. You must add the name of the new share name to the registry entry NullSessionShares.

To edit the NullSessionShares registry entry:

1. Open a Command Prompt window, then enter the command `C:\> REGEDT32`
2. In the tree, double-click to open folders HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Services, LanmanServer, and Parameters, then double-click the NullSessionShares icon. The Multi-String Editor dialog box appears (Figure 7-1).

![Figure 7-1 Multi-String Editor Dialog Box](image)

3. Type the new share name directly in the Data field of the Multi-String Editor dialog box (for example, Mill_Projects$), then click OK.

4. Click Registry, then click Exit.

This completes the installation of the Millennium Service as a separate service on a computer other than the Millennium32 database server to provide file services for Millennium32 clients on the network.
Appendix A
Installing Custom Oracle Software

You can install Oracle® software on the server in a Millennium® 32 Client/Server System or on a primary PowerStation® by specifying your own settings for Oracle software and by configuring a listener.

Note: To install Oracle automatically using default settings, see Chapter 4, Installing a Client/Server or Primary PowerStation.

A.1 Performing a Custom Oracle Installation

To perform a custom Oracle software installation:

1. Insert the Oracle CD into the CD-ROM drive of the Millennium® 32 server or primary PowerStation.
2. At the Oracle8i Autorun dialog box (Figure A-1), click Install/Deinstall Products.

![Oracle8i Autorun Dialog Box](image)

*Figure A-1  Oracle8i Autorun Dialog Box*

*Note: If the setup procedure does not start automatically, select Start > Run. Enter cd-drive:\setup.exe and press Enter.*
3. The Oracle Universal Installer wizard starts. At the Welcome page (Figure A-2), click **Next**.

![Figure A-2 Welcome Page](image-url)
4. At the File Locations page (Figure A-3), enter the file locations for the source file, the Oracle Home name, and the destination, then click Next.

![File Locations Page](image)

Figure A-3 File Locations Page

**Note:** Items that have a gray checkmark (for example, the first row in Figure A-4, Oracle 8.1.7.0.0) are required. You cannot clear them.

5. At the Available Product Components page (Figure A-4), select the following components, then click Next:
   - Oracle 8i Server 8.1.7.0.0
   - Net8 Products 8.1.7.0.0
     - Net8 Client 8.1.7.0.0
     - Net8 Server 8.1.7.0.0
     - Oracle Names 8.1.7.0.0 (optional)
   - Oracle Utilities 8.1.7.0.0
     - Oracle Performance Monitor for Windows NT® 8.1.7.0.0 (optional)
     - Oracle Database Utilities 8.1.7.0.0
     - SQL*Plus® 8.1.7.0.0
   - Oracle Configuration Assistants 8.1.7.0.0 and Oracle Database Configuration Assistant 8.1.7.0.0
   - Oracle Enterprise Manager Products 8.1.7.0.0 (optional)
   - Oracle Enterprise Manager Client 2.2.0.0.0 (optional)
• Oracle DBA Management Pack 2.2.0.0.0
  Oracle Schema Manager 2.2.0.0.0
  Oracle Storage Manager 2.2.0.0.0
  Oracle Security Manager 2.2.0.0.0
  Oracle Instance Manager 2.2.0.0.0 (optional)
• Oracle Installation Products 8.1.7.0.0 and Oracle Universal Installer 1.7.1.9.0
• Oracle Administration Assistant for Windows NT 8.1.7.0.0 (optional)
• Oracle8i Windows Documentation 8.1.7.0.0 (optional)

Figure A-4 Available Product Components Page
6. At the Component Locations page (Figure A-5), click Next.

![Component Locations Page](image)

**Figure A-5  Component Locations Page**

7. At the Create Database page (Figure A-6), click No.

![Create Database Page](image)

**Figure A-6  Create Database Page**

182  *Installing Custom Oracle Software*
8. At the Summary page (Figure A-7), review the summary of items to be installed, then click Install.

![Figure A-7 Summary Page]

9. After the selected files are installed (Figure A-8), click Next.

![Figure A-8 Install Page]
10. The Configuration Tools page appears and the Net8 Configuration Assistant automatically starts (Figure A-9).

11. At the Welcome page of the Net8 Configuration Assistant wizard (Figure A-10), ensure that Perform typical configuration is clear (not selected), then click Next.
12. At the Directory Service Access page (Figure A-11), ensure that No, I want to defer... is selected, then click Next.

![Figure A-11 Directory Service Access Page](image1)

13. At the Listener Configuration, Listener Name page (Figure A-12), click Next to use the default name, LISTENER.

![Figure A-12 Listener Configuration, Listener Name Page](image2)
14. At the Listener Configuration, Select Protocols page (Figure A-13), ensure that TCP is in the Selected Protocols list, then click Next.

![Figure A-13 Listener Configuration, Select Protocols Page](image1)

15. At the Listener Configuration, TCP/IP Protocol page (Figure A-14), ensure that Use the standard port number of 1521 is selected, then click Next.

![Figure A-14 Listener Configuration, TCP/IP Protocol Page](image2)
16. At the Listener Configuration, More Listeners? page (Figure A-15), click **No**, then click **Next**.

![Figure A-15 Listener Configuration, More Listeners? Page](image)

**Note:** Waters recommends allowing 20 users for each listener, where each listener gets its own port and you evenly distribute port numbers among your clients. If you have more users, complete the Oracle installation, then see *Appendix D, Adding a Listener Service*.

17. At the Listener Configuration Done page, click **Next**.
18. At the Naming Methods Configuration page (Figure A-16), click No, I do not want to change..., then click Next.

![Figure A-16 Naming Methods Configuration Page](image)

19. At the Done page (Figure A-17), click Finish.

![Figure A-17 Net8 Configuration Assistant Done Page](image)
20. At the Configuration Tools page (Figure A-18), click Next.

![Configuration Tools Page](image)

21. At the End of Installation page of the Oracle Universal Installer (Figure A-19), click Exit, then click Yes to close the Oracle Universal Installer.

![End of Installation Page](image)
22. **For Windows 2000 only:** Edit the sqlnet.ora file to change the sqlnet.authentication_services parameters as follows:
   a. Use Notepad to edit Oracle_home\network\admin\sqlnet.ora.
   b. Change (NTS) to (NONE) for the parameter SQLNET.AUTHENTICATION_SERVICES=
   c. Save the sqlnet.ora file and exit.

### A.2 Installing the Oracle Patch

The Oracle8i Patch Set v. 8.1.7.1.1 is intended for the Oracle Server for Windows NT and Windows 2000. You can install the patch set interactively or silently (see the Oracle instructions). This procedure uses the interactive installation.

To install the Oracle patch:

1. Log on to the system as a user with administrative privileges.
2. Unzip the downloaded patch set file into a new directory.
3. In the Oracle Home in which you want to install the patch set, stop any existing Oracle Server instances with normal or immediate priority, and stop any other Oracle-specific services that are running from the chosen Oracle Home.
4. Start the Oracle Universal Installer:
   a. Run the setup executable located at the root of the unzipped patch set installation area.
   b. At the Welcome page, click **Next**.
   c. At the File Locations page, ensure that the default location for the Source... entry field is the **products.jar** file.
   d. Select the Oracle Home in which you want to install the patch set from the drop-down list of Oracle Homes or Oracle Home Names, then click **Next**.
   e. After the installer displays the projects to be installed, verify the list, then click **Install**.
   f. At the **End of Installation** message, click **Exit**, then click **Yes**, to exit the installer.
5. Open a Command Prompt window and enter the following commands:
   a. `C:\> SVRMGR
   b. SVRMGR> connect internal/oracle
   c. SVRMGR> @%oracle_home%\rdbms\admin\catalog.sql
   d. SVRMGR> @%oracle_home%\rdbms\admin\catproc.sql

190 Installing Custom Oracle Software
e. Enter the following command only if you are running Oracle Replication:
   `SVRMRG> @%oracle_home%\rdbms\admin\catrep.sql`

f. Enter the following command if you want to recompile all PL/SQL packages
   (optional): `SVRMRG> @%oracle_home%\rdbms\admin\utlirp.sql`

g. `SVRMRG> exit`

6. If you have previously installed the Oracle HTTP Server, then update the following
   configuration file manually as follows:
   a. Edit the file `%ORACLE_HOME%\Apache\Jserv\etc\jserv.properties`
      (where `%ORACLE_HOME%` is the path to the Oracle Home in which the patch set is
      installed).
   b. Search for the `XSQLConfig.xml File Location` string.
   c. Modify the parameter `wrapper.classpath` on the line immediately following
      the string to read `%ORACLE_HOME%\oracore\admin`
   d. Save the file.
Perform the procedures in this appendix to use script files to build the Millennium\textsuperscript{32} database manually using your own settings. This procedure is for use on a client/server or primary PowerStation. It assumes that you have completed Section 4.2.1, Starting the Installation, through the step where you are asked Would you like to build the SERVER database now?, and you clicked No.

Four script files are used to create the Millennium\textsuperscript{32} database (Table B-1).

Table B-1  Script Files

<table>
<thead>
<tr>
<th>Script File</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>cs_builddb.bat</td>
<td>Creates the Millennium\textsuperscript{32} database tablespaces.</td>
</tr>
<tr>
<td>millenniumusers.bat</td>
<td>Creates the Millennium\textsuperscript{32} users and roles.</td>
</tr>
<tr>
<td>newdefaults.bat</td>
<td>Creates the Defaults project.</td>
</tr>
<tr>
<td>share.bat</td>
<td>Registers the name of the Projects directory in the database.</td>
</tr>
</tbody>
</table>

\textbf{STOP} Attention: If you plan to customize the Millennium\textsuperscript{32} configuration, edit the script files and make the changes before you run the scripts.

B.1 Using Script Files

To create a new database using script files:

1. Log in to the server using an account with administrator privileges.
2. Open a Command Prompt window and enter the following command:

   \texttt{C: \> WINDOWS> program drive:}
3. At the program drive prompt, enter the following commands to build the cs_build.db script:

```
cd millennium\script
program drive: \> Millennium\Script> cs_build.db.bat
```

**Note:** The cs_build.db script takes 15 to 30 minutes to complete. The script produces output in the Command Prompt window and a log file.

4. To verify that the Millennium database is running:
   a. Enter the following commands in the Command Prompt window:
      ```
      C:\> svrmgrl
      SVRMGR> connect internal
      Password:
      ```
   b. Enter the password (oracle is the default password).
   c. When you see the Connected. message, enter the following command:
      ```
      SVRMGR> select file_name, tablespace_name, bytes, status
             from dba_data_files;
      ```
   d. Verify that the STATUS column shows AVAILABLE.
   e. Type Exit to close the Server Manager utility.

5. Enter the following command to run the millenniumusers script:

```
program drive: \> Millennium\Script> millenniumusers.bat
```

6. Enter the following command to run the newdefaults script:

```
program drive: \> Millennium\Script> newdefaults.bat
```

7. Enter the following command to run the share script:

```
program drive: \> Millennium\Script> share.bat
```

The new database is created and configured.

## B.2 Starting the Oracle 8i Listener

Use this section to start and configure the Oracle8i listener service.

To start the Oracle Listener and advertise the MILn SID:

1. Open a Command Prompt window, and enter the following commands:
   a. C:\> lsnrctl
   b. LSNRCTL> set password oracle
   c. LSNRCTL> stop
   d. LSNRCTL> start
2. Set the listener service to automatically start whenever the computer is restarted. (The Windows NT procedure is described first, then the Windows 2000 procedure.)

**Windows NT**

a. Select Control Panel > Services.
b. Select OracleOraHome81TNSListener, then click Startup.
c. Select Automatic under Startup Type, then click OK.
d. Click Close to exit the Services dialog box.

**Windows 2000**

b. Right-click OracleOraHome81TNSListener, then select Properties.
c. At the OracleOraHome81TNSListener Properties dialog box, click the General tab.
d. Select Automatic from the Startup Options drop-down menu, then click OK.

### B.3 Starting Database Archiving

To start archiving the database:

1. Use Notepad to edit `database-drive:\Millennium\database\initmiln.ora`. Remove the comment symbol (#) from the following command:
   ```
   #log_archive_start = true
   ```
2. Save the `initmiln.ora` file and exit.
3. To enable archive logging:
   a. Enter the following commands:
      ```
      C:\> svrmgrl
      SVRMGR> connect internal
      ```
   b. Enter the password (oracle is the default password)
   c. Enter the commands:
      ```
      SVRMGR> shutdown transactional
      SVRMGR> startup mount
      pfile=tablespace-drive:\millennium\database\initmiln.ora;
      ```

*Note: For the Oracle SID name (initmiln.ora), n can be numbers 0 through 9 or letters A through Z.*
d. Enter the commands:
   
   SVRMGR> alter system archive log start;
   SVRMGR> alter database archivelog;
   SVRMGR> alter database open;
   SVRMGR> archive log list

   e. Verify that database log mode is Archive Mode and that Automatic Archival is enabled.
   
   f. At the SVRMGR prompt, enter alter system switch logfile;
   
   g. In the Oracle home directory (or wherever you defined the log archive destination in the initmiln.ora file), in Database\Archive, look for an archive file (.arc) corresponding to the time that you completed step 6. Existence of an .arc file at the correct time verifies that all previous commands worked. You can customize the location of this directory.

   4. At the SVRMGR prompt, enter exit

### B.4 Configuring the Millennium\(^{32}\) Projects Directory

The procedure to configure the Millennium\(^{32}\) projects directory is described first for Windows NT, then for Windows 2000.

**Attention:** Configuring the Millennium\(^{32}\) Projects directory by setting Mill_projects$ file access (to Read-Only Access for Everyone and Full Access for the System, or the account that you configured Millennium Service to “Log on as...”) is critical for security.

#### B.4.1 Configuring the Projects Directory in Windows NT

To configure the Millennium\(^{32}\) Projects directory in Windows NT:

1. Open Windows Explorer, select the \Millennium\Projects folder on the data drive, right-click, then select Sharing.
2. At the Projects Properties dialog box, set the permissions as follows:
   a. Click the Sharing tab.
   b. Click Shared As.
   c. Type Mill_projects$ in the Share Name text box (Figure B-1).

**Note:** If you choose a different share name, you must configure NullSessionShares (see Section 7.4, Creating Another Share).
3. Click the **Security** tab, then click **Permissions**.

4. At the Directory Permissions dialog box (**Figure B-2**), select **Replace Permissions on Subdirectories** and **Replace Permissions on Existing Files** to ensure that all current files in the directories have the appropriate permissions.

5. Ensure that the Mill_projects$ file has **Read-Only Access** for Everyone and **Full Control Access** for the System.
6. If you want to add a user:
   a. Click Add.
   b. At the Add Users and Groups dialog box (Figure B-3), select System or Everyone.
   c. Click Add.
   d. From the Type of Access drop-down list, select the appropriate permissions for the user you selected, then click OK.

7. At the Directory Permissions dialog box, click OK.
8. At the Windows message box, click Yes.
9. After the server applies permissions to the subdirectories and files, click OK to close the Projects Properties dialog box.

**B.4.2 Configuring the Projects Directory in Windows 2000**

To configure the Millennium Projects directory in Windows 2000:

1. Using Windows Explorer, select the \Millennium\Projects folder from the data drive, right-click, then select Sharing.
2. At the Sharing page of the Projects Properties dialog box, select **Share this folder**, enter **Mill_Projects$** in the Share Name text box (Figure B-4), then click **Apply**.

![Figure B-4 Project Properties Dialog Box, Sharing Tab](image)

3. Set the security settings as follows:
   a. Click the **Security** tab.
b. Clear Allow inheritable permissions from parent to propagate to this object (Figure B-5), then click Apply.

![Figure B-5 Project Properties Dialog Box, Security Tab](image)

Figure B-5  Project Properties Dialog Box, Security Tab

c. At the Security message box, click Copy (Figure B-6).

![Figure B-6 Security Message Box](image)

d. Select Everyone from the Name box and clear all permissions except Read & Execute, List Folder Contents, and Read.

e. Select System from the Name box and enable all permissions.

4. If System is not listed, add it as a user:
   a. Click Add.
   b. Scroll down the Name box and select System (if it is not already listed in the Name box of the Security page) (Figure B-7).
Note: If the Millennium\textsuperscript{32} server is not the domain controller, then select the local machine name from the Look in drop-down list.

c. Click Add, then click OK.

d. At the Security page of the Project Properties dialog box, select System from the Name box and enable all permissions.

5. Apply the security settings to all Projects subdirectories as follows:

a. At the Security page of the Project Properties dialog box (Figure B-5), click Advanced.
b. At the Access Control Settings for Projects dialog box (Figure B-8), click the Permissions tab, then select Reset permissions on all child objects and enable propagation of inheritable permissions.

![Access Control Settings for Projects Dialog Box](image)

Figure B-8  Access Control Settings for Projects Dialog Box

c. Ensure that Allow inheritable permissions from parent to propagate to this object is clear, then click Apply.

d. At the Security message, click Yes. The permissions are applied to all subdirectories of the Project directory.

e. Click OK to save the changes and close the Access Control Settings for Projects dialog box.

f. Click OK to exit the Project Properties dialog box.
B.5 Setting Up the Millennium\textsuperscript{32} Client Directory

To allow the Millennium\textsuperscript{32} clients to download the directories, set up the client stack (\textbackslash Millennium\textbackslash client) in the \textit{program-drive} to be shared. The procedure to configure the Millennium\textsuperscript{32} client directory is described first for Windows NT, then for Windows 2000.

\textbf{Note:} After client and LAC/E\textsuperscript{32} installations are finished, the Millennium\textsuperscript{32} Client Directory can be unshared.

B.5.1 Configuring the Client Stack in Windows NT

To configure the client stack in Windows NT:

1. Using Windows Explorer, select the \textbackslash Millennium\textbackslash Client subdirectory from the \textit{program-drive}, right-click the subdirectory, then select \textit{Sharing}.
2. At the Client Properties dialog box, click \textit{Share As}, then click \textit{Apply}.
3. Click the \textit{Security} tab, then click \textit{Permissions}.
4. At the Directory Permissions dialog box (Figure B-9), select \textit{Replace Permissions on Subdirectories} and \textit{Replace Permissions on Existing Files} to ensure that all current files in the directories have the appropriate permissions.

![Figure B-9 Directory Permissions Dialog Box](image)

5. Select \textbf{Everyone} from the Name box, select \textbf{Read} from the Type of Access drop-down list, then click \textbf{OK}.
6. At the warning message, click \textbf{Yes}.
7. Click \textbf{OK} to save the changes and exit the Client Properties dialog box.
B.5.2 Configuring the Client Stack in Windows 2000

To configure the client stack in Windows 2000:

1. Using Windows Explorer, select the \Millennium\Client subdirectory from the program-drive, right-click the subdirectory, then select Sharing.
2. At the Client Properties Sharing dialog box, select Share this folder, then click Apply.
3. Set the security settings as follows (Figure B-5):
   a. Click the Security tab.
   b. Clear Allow inheritable permissions from parent to propagate to this object.
   c. At the Security message, click Copy.
   d. Select Everyone from the Name box and clear all permissions except Read & Execute, List Folder Contents, and Read.
4. Apply the security settings to all Client subdirectories and files as follows:
   a. At the Security page, click Advanced.
   b. At the Access Control Settings for Projects dialog box (Figure B-8), click the Permissions tab, then select Reset permissions on all child objects and enable propagation of inheritable permissions.
   c. Ensure that Allow inheritable permissions from parent to propagate to this object is clear, then click Apply.
   d. At the Security message, click Yes. The permissions are applied to all subdirectories and files of the Client directory.
   e. Click OK to save the changes and close the Access Control Settings for Projects dialog box.
   f. Click OK to save the changes and exit the Client Properties Sharing dialog box.
B.6 Verifying the Installed Files

The Millennium\(^{32}\) Setup creates a Millennium\(^{32}\) program folder in the Start menu Programs folder. The Millennium\(^{32}\) program folder contains the following program items:

- **File Verification Results** – Contains a log of the file verification process results.
- **Installation Log** – Contains information about the current installation.
- **ReadMe!** – Contains up-to-date information about the current release of the Millennium\(^{32}\) software (can be viewed at the beginning of the installation process).
- **Verify Files** – Verifies the integrity of the Millennium\(^{32}\) software files on your hard disk.

### Viewing the Read Me Text

The Read Me entry in the Millennium\(^{32}\) program folder includes information related to the current release of the Millennium\(^{32}\) software.

To view the Read Me file:

1. Select Start > Programs > Millennium\(^{32}\) > ReadMe!.
2. Review the contents of the file. You can print a copy by selecting File > Print.

### Viewing the Install Log Text

The Install Log contains information about your Millennium\(^{32}\) installation. You can use the log file to review your installation choices. In case of partial or unsuccessful installations, you can view the Install Log to check for errors.

To view the Install Log:

1. Select Start > Programs > Millennium\(^{32}\) > Installation Log. The program displays the millennium.log file in Notepad.
2. Review the contents of the file. You can print a copy by selecting File > Print.
Using the File Verification Utility

The File Verification utility checks the integrity of the installed Millennium® program, data, and database files. Use the File Verification utility to verify the Millennium® program and data files only (not the database files):

- As part of your installation qualification if you purchased the Millennium® Qualification option
- To ensure that the Millennium® files have not changed since installation

To use the File Verification utility:

1. Select Start > Programs > Millennium® > Verify Files. The File Verification utility compares the installed Millennium® files’ checksum with a previously stored checksum number, then creates a File Verification Results Log.
2. Select Start > Programs > Millennium® > File Verification Results. If an error message box appears stating that the file is too large for Notepad and asks if you want to use WordPad to view the file, click Yes. The WordPad window appears with the File Verification Results text.
3. Review the contents of the file. You can print a copy by selecting File > Print.
4. Select File > Exit.

This completes the custom build of a Millennium® database on a client/server or a PowerStation.

Continue with Chapter 5, Installing a Client.
Appendix C
Connecting Remotely to a LAC/E$^{32}$ Acquisition Server

Use this appendix to install remote administration software on a viewer client or server computer and to control a LAC/E$^{32}$ Acquisition Server remotely.

The software is already installed on the LAC/E$^{32}$ Acquisition Server.

C.1 Installing the Software

To install ControlIT® Remote Administration software on a viewer computer:

1. Log on to the viewer client or server computer as its local Administrator.
2. Insert the ControlIT Advanced Edition CD into the CD-ROM drive.
   
   If the ControlIT Setup wizard does not start automatically, select Start > Run. Type `<cd drive>\intel\setup.exe`, then press Enter.
3. At the Initial Install page (Figure C-1), click ControlIT.

![ControlIT Initial Install Page](image)

Figure C-1 ControlIT Initial Install Page
4. At the License Agreement page, click I Agree.

**Attention:** To use the ControlIT procedures as written in this guide, ensure that you select **Install Non-Managed Viewer and Host Components**. If you do not, ControlIT installs many additional tools and options.

5. At the Select the Type of ControlIT Environment page, select **Install Non-Managed Viewer and Host Components**, then click **Next**.

6. At the Welcome to ControlIT Installation wizard page (**Figure C-2**), use the default selections, then click **Next**.

![Figure C-2: Welcome to ControlIT Installation Wizard Page](image)

---

207 Connecting Remotely to a LAC/E³² Acquisition Server
7. At the Emergency Repair Disk page (Figure C-3), leave the check box cleared, then click **Next**.

![Figure C-3 Emergency Repair Disk Page](image)

8. At the ControlIT Directory Selection page (Figure C-4), use the default directory, then click **Next**.

![Figure C-4 ControlIT Directory Selection Page](image)
9. At the Create ControlIT Program Icon page (Figure C-5), use the default selection, then click **Next**.

![Figure C-5 Create ControlIT Program Icon Page](image)

10. At the Ready to Install Files page (Figure C-6), click **Finish**.

![Figure C-6 Ready to Install Files Page](image)

11. The files are copied, the ControlIT Program group is created, and the message **ControlIT Installation is complete** appears. Click **OK**.
12. At the message Your system must be restarted. Restart now?, click Yes.

13. Remove the ControlIT CD-ROM from the CD-ROM drive.

14. After the system has restarted, log on as local Administrator.

15. Close the ControlIT Program group window.

16. Click ControlIT in the taskbar to maximize ControlIT.

### C.2 Setting Preferences

To set the preferences:

1. At the ControlIT Main window, select File > Preferences.

   ![Change Preferences Dialog Box](image)

   Figure C-7 Change Preferences Dialog Box

2. At the Change Preferences dialog box (Figure C-7), set the Viewer preferences as follows:

   a. Double-click Viewer in the Preferences list to expand it, then scroll down the list and select Disable Host keyboard, Disable Host mouse, and Start in full screen mode.

   b. Clear Hide application during Host session (Figure C-8).
3. Set the Host preferences as follows:
   a. Double-click Host in the Preferences list to expand it, then clear Hide application during Host session (Figure C-9).
   b. For the viewer computer, clear Enable Host Mode.

4. Set the Internet (TCP/IP) preferences as follows:
   a. Double-click Internet (TCP/IP) in the Preferences list to expand it.
   b. Select Allow incoming calls.
   c. Verify that Multiple incoming connections is also selected (Figure C-10).
5. Set the General preferences as follows:

   a. Double-click **General** in the Preferences list to expand it.

   b. If you want the ControlIT software to automatically start at each logon, then click **Start before login** (Figure C-11).

   c. If TCP/IP is not already configured on the viewer client or the LAC/E² Acquisition Server, then select **NetBIOS/NetBEUI**.

   ![Figure C-10 Setting Internet (TCP/IP) Preferences](image)

   ![Figure C-11 Setting General Preferences](image)
d. Near the bottom of the General Preferences list, verify that **Listen on startup** is selected (**Figure C-12**).

![Figure C-12 Setting Other General Preferences](image)

e. Select **Set computer name** so that ControlIT can read the computer name and use it when communicating with other computers.

f. If NetBIOS/NetBEUI is selected in the General Preferences list, then scroll down the list and double-click **NetBIOS/NetBEUI** (**Figure C-13**).

![Figure C-13 Setting NetBIOS/NetBEUI Preferences](image)

g. Select **Allow incoming calls**.

h. Verify that **Multiple incoming connections** is selected.

i. Click **OK** to save the changes. The ControlIT Main window appears.
6. If you cleared Enable Host Mode, then click Yes at the message to restart the system.

7. Log on as local Administrator.

8. If you selected Start before login in the General Preferences list, then click ControlIT on the taskbar to maximize it.

Otherwise, select Start > Programs > ControlIT > ControlIT, then click ControlIT on the taskbar to maximize it.

9. Edit the access codes as follows:
   a. Select File > Edit Access Codes.
   b. Type waters in the User Name, ControlIT Login Name, and ControlIT Login Password fields (Figure C-14).
   c. Click Add, then click OK.
C.3 Remotely Controlling the LAC/E³² Acquisition Server

To connect to and remotely control the LAC/E³² Acquisition Server from the viewer computer:

1. Select Connect > Connect Remote.
2. At the Remote Workstation Browser dialog box, if TCP/IP is not configured, then click the Netbios tab (Figure C-15).

3. Select the LAC/E³² Acquisition Server from the Networks to browse list, then click Copy. The Enter Address dialog box appears (Figure C-16).
4. Type **waters** in the Login Name and Login Password fields, then click **OK**.

5. From the ControlIT Main window, click **Viewer**. The LAC/E$^{32}$ Acquisition Server Desktop appears with remote keyboard and mouse control (Figure C-17).

![Figure C-17 Switching to Windows Screen](image)

6. If you prefer to see the LAC/E$^{32}$ Acquisition Server screen as a window in the ControlIT application, right-click the blinking red box in the upper-left corner of the screen and select **Switch to Windows Screen** from the blinking red box menu (Figure C-18).

![Figure C-18 ControlIT Main Screen](image)

**Note:** At this point, you can install the LAC/E$^{32}$ Acquisition Server software (see Chapter 6, Installing an Acquisition Server).
7. To exit Remote Control of the LAC/E³² Acquisition Server:
   • **In Full Screen mode** – Right-click the blinking red box in the upper-left corner of the screen and select **Normal Disconnect**.
   • **In Windows Screen mode** – Select **ControlIT Disconnect > Normal**.

8. At the **Disconnect confirmation message**, click **Yes**.

*Note:* **ControlIT** is compatible with **Remotely Possible™³²** (its predecessor). However, if you remotely connect from a ControlIT viewer to a computer running Remotely Possible³², then a message appears (Figure C-19) because Remotely Possible³² is using RP/32 Proprietary encryption, while ControlIT is using 40-bit Windows NT encryption. To prevent future repetition, select **Do not show this warning message again**, then click **Yes**.

![Figure C-19 Compatibility Message Box](image)

This completes the installation and testing of the remote administration software on a viewer client or server computer.
Appendix D
Adding a Listener Service

Use this procedure to add a listener service. You must configure listener services on the server to provide adequate connection performance between the server and your clients. As a general rule, configure one listener service for every 20 clients and LAC/E\textsuperscript{32} Acquisition Servers on your system. If clients or LAC/E\textsuperscript{32} Acquisition Servers are added to your system after the original installation, you may need to configure additional listener services.

To add a listener service:

1. Select Start > Programs > Millennium\textsuperscript{32} > Oracle > Oracle Net8 Configuration Assistant.
2. At the Welcome page of the Net8 Configuration Assistant wizard (Figure D-1), click Listener configuration, then click Next.

3. At the Listener Configuration, Listener page, click Add, then click Next.

Figure D-1 Net8 Configuration Assistant: Welcome Page
4. At the Listener Configuration, Listener Name page (Figure D-2), enter a unique listener name, then click Next.

![Listener Configuration, Listener Name Page](image)

**Figure D-2 Listener Configuration, Listener Name Page**

5. At the Listener Configuration, Select Protocols page, ensure that TCP is listed in the Selected Protocols list, then click Next.
6. At the Listener Configuration, TCP/IP Protocol page (Figure D-3), click Use another port number, enter the next available port number, then click Next.

![Image of Listener Configuration, TCP/IP Protocol Page](image)

**Figure D-3  Listener Configuration, TCP/IP Protocol Page**

7. At the Listener Configuration, More Listeners? page, do one of the following:
   - If you need to configure another listener, click Yes. The Listener Configuration, Listener page reappears. Repeat steps 3 to 6.
   - If you are finished, click No.
8. At the Listener Configuration, Select Listener page (Figure D-4), select the listener that you just created, then click **Next**.

![Figure D-4 Listener Configuration, Select Listener Page](image)

9. At the Listener Configuration Done Page, click **Next**.
10. At the Welcome page of the Net8 Configuration Assistant Wizard, click **Finish**.
Index

Numerics
1100 Series Control Modules 31
150C Plus system 54
150CV Plus system 54
474 Detector 31
5890 GC instrument 55, 57, 58, 61, 63
5890S GC instrument 31, 58
6890 GC instrument 31, 55, 59
6890+ GC instrument 31, 60
7673 Controller 55, 57, 58, 61
7673S Controller 31, 58
8-port serial card 25, 55, 58, 59, 60

B
Bench space 33
Building custom database 107, 192
busLAC/E card 25, 48, 57
connections 38, 48, 49
functions 39
installing 36
ports 37
setting device addresses 43
busLAC/E driver 86, 138, 164
busLAC/E Driver Installation page 164
busLAC/E Module, serial instruments 31
busSAT/IN Module 61
150C plus 54
150CV plus 55
analog output 60
connections 38, 43, 48, 49
converting signals 47
functions 48
installing 50
supported devices 27

A
Accessories, IEEE-488 28, 31
Acquisition Server 35
Add Desktop Shortcut dialog box 86
Add Users and Groups dialog box 114, 197
Add ZQ Option dialog box 86
Adding
listener service 218
printers 148
Addresses, setting IEEE-488 43
Alliance GPC 2000 and GPCV 2000 30
Analog output signals 48, 60
Archive log files 96
Archiving Millennium™ database 111, 194
Autoextend 99
Autoinjectors, IEEE-488 29
Autologon utility, disabling 170
Autosampler 51

C
Cable
GC instrument 59, 60
IEEE-488 40
length 27, 33, 40
serial 48
Calculations
database size 104
number of users 104
Rollback 104
Cards
8-port serial 25, 31, 55, 58, 59, 60
busLAC/E 25, 36, 39, 47, 48, 49, 52, 57
Equinox 31
network interface 35, 37
RS-232 56
Chromatographic devices 36
Chromatography files 98
Client
requirements 24
stack, configuring 202
stack, setting up 202
stack, setting up in Windows NT 119
uninstalling Options 146
Client directory
downloading 118, 202
shared 161
Client/server
configuration 24
installation 145
installation using default settings 96, 100
installing software 122
Computer peripherals 34, 35
Configuration Assistant, Oracle Net8 91, 184
Configuring
guidelines 40
hardware 32
net service name 218
typical systems 22
Connections
150CV plus 54
busLAC/E card 48
busSAT/IN Module 43
detectors 43, 52
GC instruments 59, 60
I/O distribution box 48
IEEE-488 40
LC Module 1plus 42
pumps 42, 51
Waters 150C plus 54
Waters 600 series 42
Contact closure 42
Contact closure signal 51, 62
ControlIT remote administration software 206
connecting to LAC/E32 Acquisition Server 215
setting preferences 210
Conventions, documentation 19
Converting digital signals 47, 48
Create Database dialog box 84, 137
Creating new database instance 192
cs_builddb.bat file 192
Custom database, building 108, 110, 192
Custom installation 83
workstation 88
Customizing the Millennium32 configuration 192

D

Data Directory page 105
Data files, installing on workstation 89
Database
archiving 111, 194
importing 87
instance, creating 192
verifying that it is running 110
Database datafiles 99
installing on workstation 89
Database Directory page 106
Database size 99, 104
Database Size page 104
Detectors
474 30
connections 43
IEEE-488 28, 52
mass 30
non-IEEE-488 30, 50
Devices
IEEE-488 27
non-IEEE-488 30
RS-32-based 27
setting IEEE-488 addresses 43
supported by 27
Digital signals, converting 47, 48
DIP switch settings 44
Directory Permissions dialog box 113, 196
Disabling Autologon utility 170
Disk space and memory 98
Disk space, required 98
Documentation conventions 19
Download Millenium 32 client directory 118, 202

E
Environmental requirements 32
Equinox serial card 31

F
File Verification results 91, 120, 204
File Verification utility 92, 121, 205
Files
  chromatography raw data 98
  cs_builddb.bat 192, 193
data, installing 89
database, installing 89
default project 98
installation log 92, 121, 204
Millenium 32 database 83
Millenium 32 program 83
Millenium 32 raw data 83
Oracle application 98
permanent Oracle 83
program 98
program, installing 88
raw data 98
Read Me 91, 92, 120, 204
share.bat 192
temporary install 83
Verification 92, 121, 205
Firmware versions, minimum 27

G
G1512A Controller 55, 59, 63
GC instrument connections 59, 60
Guidelines
  configuring 40
  IEEE interface 40
  listener service 218

H
Hardware
  configuring 32
  installing 32
Humidity requirements 32

I
I/O distribution box 27, 47, 49, 57
IEEE-488
  accessories 27, 28
  address 44
  addresses, setting 43
  bus 39, 44
  connections 40
  device addresses 43
  devices 27, 37
  guidelines 40
  port 37
  pumps 28
  setting device addresses 43
Import Millennium Database dialog box 90
workstation 87
Information page 84, 101, 173
Inject start signal 42, 51, 62
Injector connections 42
Install Common System DLLs dialog box 84, 137
Installation log 91, 92, 120, 121, 204
Installation Type page
  client 136
  LAC/E\textsuperscript{32} Acquisition Server 162
  typical 84, 136, 162
Installing
  busLAC/E card 36
  client/server 96
  computer peripherals 34, 35
  custom, on workstation 83
  data files 89
  database datafiles 89
  hardware 32
  Millennium\textsuperscript{32} software 122
  network 34
  network interface card 37
  Oracle 8i 96
  Oracle8i Patch Set 190
  PowerStation 34
  program files, custom 82
  server 35
  typical, on workstation 83
  using default settings 100
  workstation license 90
Installing Options
  in a client/server environment 145
  in a workstation environment 93
  instructions 93, 145
Instrument connections 50
Interface
  guidelines 40
  IEEE-488 28, 31
  Internet Explorer 5.5 25, 26

K
  Key disk 93, 145

L
  LAC/E\textsuperscript{32} Acquisition Server 35, 206
  Listener service 218

Log file, installation 92, 121, 204
Logging in to Oracle Net8 Configuration Assistant 139, 140, 165

M
  Mass detectors 30
  Memory considerations 97
  Mill\_project\$ file access 112, 195
  Millennium Server 96
  Millennium Service 172
  Millennium\textsuperscript{32}
    archiving database 111, 194
    before installing 82
    customizing 192
    installing software on a client/server system 122
    program folder 92, 120, 204
    server 35
    starting 81
    starting installation 83
  Millennium\textsuperscript{32} Chromatography Manager 22
  Millennium\textsuperscript{32} Client/Server System, installing software 96
  Millennium\textsuperscript{32} database files 83, 98
  Millennium\textsuperscript{32} program files 83, 98
  Millennium\textsuperscript{32} raw data files 83, 98
  Millennium\textsuperscript{32} Workstation License 90
  millenniumusers.bat file 192
  Minimum system requirements, workstation 84
  Multi-String Editor dialog box 176

N
  Net service name, configuring 218
  Net8 Configuration Assistant 184
  Network
    connection, testing 80
    installing 32
  Network interface card 35
    installing 37
Options
  installation instructions 93, 145
  license 93
  sample project 95, 147
  software 93, 145
  uninstalling 94, 146
Oracle
  application files 98
  Available Product Components 180
  custom installation 177
  functions 97
  initialization parameters 97
  logging in 139, 140, 165
  Net8 Configuration Assistant 184
  program folder 91
  required memory 97
Oracle database 96
Oracle Net8 Configuration Assistant 91
Oracle SID name 104
Oracle tools 97
Oracle8i Patch Set v. 8.1.7.1.1 190
Oracle8i, installing 96
PowerStation primary PC, installing software 96
Powerup sequence 81
Preferences, ControlIT remote administration software 210
Prerequisites, installing stand-alone workstation 82
Printer, adding new 148
Printers control panel 148
Product Support Registration page 103
Program Directory page 105
Program files, installing on workstation 88
Project, restoring 95, 147
Pump Control Module 41
Pumps
  connecting 42, 51
IEEE-488 28
Raw data files 98
Read Me file 91, 92, 120, 204
Register Acquisition Server Printers dialog box 92, 148
Registering printers 92, 148
Registry, NullSessionShares Windows NT 175
Remote administration software 206
Remotely Possible remote administration software 217
Requirements
  client 24
  client/server system 26
  environmental 32
PowerStation 34
Primary PowerStation 25
Secondary PowerStation 24
server 26
  ventilation 33
  workstation 33
Restoring sample project 93, 95, 147
Rollback calculations 104
RS-232 card 56
RS-232-based devices 27

S
Sample project
on CD-ROM 93, 147
restoring 93, 95, 147
using 95, 147
SAT/IN Module 31, 50
SAT/IN2 Module 31
Script files
  build custom database 108, 110, 192
  cs_builddb.bat file 192, 193
  millenniumusers.bat file 192
  newdefaults.bat file 192
  share.bat file 192
Secondary PowerStation
  client requirements 24
Security settings 112, 195
  Directory Permissions dialog box 196
  Permissions dialog box 113
Select Oracle SID Name page 103
Select the Archive Directory Path page 106
Serial cable 48
Serial instrument support 31
Server
  installing hardware 35
  requirements 26
Service Pack 1 for Internet Explorer 5.5 25, 26
Service Pack 2 for Windows 2000 25, 26
Service Pack 6a for Windows NT 25, 26
Setting
  ControlIT preferences 210
  IEEE-488 addresses 43
Setting up
  client debug directory 118, 202
  client stack 118, 119, 202, 203
  share.bat file 192
  Shared client directory 161
Signals
  analog 47, 48
  contact closure 42, 51
  digital 47, 48
  inject start 42, 51
  trigger 42, 51
Site preparation 32
Site selection 32
Software, installing Millennium 81
Stand-alone workstation 36
  software options 93
Starting up Millennium 122
System
  devices supported 27
  IEEE-488 29
  non-IEEE-488 30
Tablespace 100
Temperature Control Module 42
Temperature requirements 32
Template, option sample project 95, 147
Temporary Install Files 83, 98
Testing the network connection 80
Total Assurance Plan 85, 103, 138, 164
Trigger signal 42, 51, 62
Typical installation, workstation 83
Uninstalling Options 94, 146
Upgrade Common System DLLs dialog box 85, 102, 137, 163
Using Option sample project 95, 147
Verify Files program folder 92, 120, 204
Verifying Millennium files 92, 121, 205
Viewing
   File Verification utility 92, 121, 205
   Installation log 92, 121, 204
   Read Me file 92, 120, 204

W

Welcome page 83
Windows 2000
   Service Pack 2 25, 26
Windows NT 4.0
   Service Pack 6a 25, 26
Wizards
   ControlIT Setup 206
   Millennium Setup 83
WordPad 93, 121, 205
Workstation
   installing Options 93
   license 93
   requirements 24, 33
   uninstalling Options 94

Z

ZQ 2000 and ZQ 4000 Mass Detectors 30